%Y insightsoftware

Application Administrator Guide
Longview

Version 26




Y insightsoftware 5

Document Information

Notices
Copyright

Longview is a brand name of the insightsoftware.com Group. insightsoftware.com is a registered
trademark of insightsoftware.com Limited. Longview is a registered trademark of insightsoftware.com
International Unlimited.

Other product and company names mentioned herein may be the trademarks of their respective
owners. The insightsoftware.com Group is the owner or licensee of all intellectual property rights in this
document, which are protected by copyright laws around the world. All such rights are reserved.

The information contained in this document represents the current view of insightsoftware.com on the
issues discussed as of the date of publication. This document is for informational purposes only.
insightsoftware.com makes no representation, guarantee or warranty, expressed or implied, that the
content of this document is accurate, complete or up to date.

Disclaimer

This guide is designed to help you to use the Longview applications effectively and efficiently. All data
shown in graphics are provided as examples only. The example companies and calculations herein are
fictitious. No association with any real company or organization is intended or should be inferred.
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Introduction to Longview

Longview provides corporate performance management (CPM) software that leading companies use to
drive performance with speed, visibility, and financial integrity. Since 1994, many of the world's most
respected companies have been using our technology platform to create a single repository of financial
truth from which statutory consolidation, management reporting, financial planning, modeling, analysis,
budgeting, forecasting, and strategic tax can be performed quickly and accurately, enterprise wide.

Longview enables enterprise clients to collect, store, analyze, and report on data in real-time by
automating, centralizing, and standardizing any one or combination of the following key financial
processes: Planning, Budgeting, Forecasting, Consolidation, Financial Close Management, Profitability
Analytics, Statutory, XBRL Financial Reporting and Tax Provisioning. With Longview customers can
reduce overreliance on spreadsheets, improve transparency, and regain control of these key finance
functions.

Longview Tax calculates your company’s global tax charge, effective tax rate, and deferred taxes for tax
provisioning purposes. Since Longview Tax uses the same technological platform as your corporate
performance management solution, the tax reporting process is directly integrated into the corporate
close process. As one solution, consolidated pre-tax income can be reported by legal entity to
accurately calculate consolidated income tax charges and deferred taxes.

For more information on purchasing Longview Tax, contact your Longview Account Manager. Web
services are a standardized way of integrating applications over the Internet or Internet protocol-based
networks. Web services rely on certain software standards including Extensible Markup Language
(XML), Simple Object Access Protocol (SOAP), Web Service Definition Language (WSDL) and
Universal Description, Discovery & Integration (UDDI).

About this guide

This guide includes basic information on how to install your Longview system. The following sections
indicate conventions that are used in this guide.

Warnings and notes

This guide uses the following conventions for warnings and notes:

A Caution: Warnings provide cautionary information on the possible effect of certain actions,
including the unintentional deletion of data. Be sure to read and understand all warnings
before performing a related procedure.

o Note: Notes provide additional information to help you understand your Longview system
better. They also provide important information on exceptions to general guidelines.

Procedures

There may be several ways to perform a procedure in your Longview system.

® You may be able to choose a menu command. For example, to open a file, you can choose
Open from the File menu. In this documentation, we use: Choose File > Open.
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= You may be able to use a keyboard equivalent. For example, to exit you can press the Alt key
and then the letter F to open the File menu, and then press X for Exit.

® You may be able to click a button or icon. If a menu command has an equivalent button or icon,
an illustration of the button or icon may appear in the margin.

In this documentation, we may not describe all methods to carry out a task. Use whichever method you
prefer. Depending on the task you are performing, certain methods may not be available.

Contacting Longview

Questions? We are ready to help. For contact information for Longview, visit our web site at
insightsoftware.com/Longview/.

Understanding Tasks In Longview
Administrative Components

Longview Application Administrator and Longview Server Manager administer different aspects of the
system. Which components you should use depends on the nature of the task you want to perform.

The following table lists common administrative tasks and the corresponding component to use:
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Administrative tasks Component to use

®  Checking for duplicate data
= Collecting statistics

= Creating, modifying, and deleting users, groups, and
symbols

= Exporting the Data Audit Trail

® Resetting the Data Audit Trail

® |mporting Data Server objects from text files
®  Running restatements or recalculations
® Specifying Journal Entries settings
Longview Application = Specifying NDD settings

Administrator = Working with attributes

= Working with batches

= Working with events

= Working with foreign exchange

= Working with locks

= Working with schedules

= Working with server rules (model, rollup, query, event, and
validation rules)

= Working with symbol access roles

= Working with the hierarchy
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Administrative tasks Component to use

®  Analyzing user data

= Exporting data to files

= |mporting data from files

= Starting and stopping servers
Longview Server Manager = Working with Log files

= Working with server queues
= Working with server status

= Working with servers

= Working with the Data Server Configuration

Overview of Server Tasks And Roles

Server tasks fall into two broad categories that are handled by different kinds of users. Tasks that
involve managing the content of the database are handled by users with administrative permissions.
Tasks that involve creating the database and configuring the server are handled by users with
permissions to manage the database. Each of these user types must exist within the application.

Your company must have at least one user with administrative permissions. However, there can be as
many as you need; each designated to administer a different aspect of the business, or responsible for a
different geographical or organizational department, and so on.

Only one administrator can perform server maintenance tasks at a time. These tasks include, but are not
limited to:

= performing regular user maintenance (creating, deleting, and editing users)
= performing symbol maintenance
® running restatements and recalculations
Changes to the configuration and operation of databases and the server require permissions to make

these changes. Many server tasks, however, can be undertaken by regular administrators. These tasks
deal with creating, managing, and deleting:

®  Users (see Maintaining Users and Groups)
= Groups (see Maintaining Users and Groups)
= Symbols ( see Maintaining Longview Hierarchies)

= Attributes (see Working With Attributes)

insightsoftware.com


https://insightsoftware.com/

Y insightsoftware 12

= Schedules (see Working With Schedules)
= Batches (see Working With Batches)

= | ocks (see Working With Locks)

= Events (see Working With Events)

You can use Longview Application Administrator to perform the following tasks:

= Create, copy, and delete users and user groups

® Set user and group permissions

= Assign users to groups

= Remove users from groups

= Create, modify, and delete symbol access roles

= Apply symbol access roles to users and groups

= Create, edit, and delete attributes, batches, schedules, symbols, and rules
= Configure intercompany eliminations, foreign exchange settings, and NDD settings
®= View and delete locks

® Detect duplicate data

® Collect statistics

= View audit trail data

® Run restatements and recalculations

Conventions

Throughout this documentation, we’ve decided to present information in certain ways. We know you are
anxious to get right to work, but if you take a few moments now to read this section, you’ll learn how to
use this documentation more easily.

This guide includes the basic information on how to use Longview Application Administrator. It is
provided in two formats: PDF and online help. You may access the online help from the Help menu of
the application.
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Getting Started in Longview Application
Administrator

You can use Longview Application Administrator to manage the administrative aspects of your system,
such as users, groups, permissions, and settings.

Understanding multilingual systems

The default language for your system is English. If you intend to use Application Administrator with an
alternate language, be aware that although the user interface appears in English, symbol descriptions
will be stored in the alternate language.

Understanding window elements

Longview Application Administrator, by default, consists of four sections, each of which, except for the
Contents window, can be opened, closed, and resized relative to the other windows. Each section has a
different purpose and allows you to perform different tasks and access different information.

. FProperties/Details
Server Explorer pane Contents window pane

File Ecit View JTecls Actions Help
Mo - 5 - W | 8 Recalculate

A (0 A0S - Bcogunl Farert Syr 0
@ ) ACCTAN - Taneaion Rat for iy — V172012 12:22:52 AV
4 0 CFWAR - Cash Fow Varsbies o

EF [ LonguewTll
H- iy Atributes

S| Balches () DINDSET - Accounts Deimd e o B -.
Wy Events 1 WGFRA Groups Farent S
| ;- JelercompaPiy Eiminations || [ AATE 5 - Transkron Aate TH '__‘j“:l
7 I8 Yournal Entries A () SymTesALT - The SymTesth Leaf1 Symba e o
Lo Ladks @ () SvmTeAR - The SymTeel Aot Swmbd : - |
=i Rudes @ () TESTROIOTA - Taging Font - focounts
Schedues w40 STATACT - St Aecounts Root =omrs= Aok T
1 ¢ Symbal Access E AWCFACT - Cary Forwasd Acocounts Fiool e
= iy Symbais E 0% STOACT - Standard Aecounts Fod rlua &
- il ACCOUNTS A wecht
& TSR
i BT
- il CLRRENCY
i CONTROLS

0 @8 users and Groips

ramE Oesripbion Panent Rizat
TRIaLBAL Tral Ealance THiaLBAL

= Search Resubts - 4 Matches) [l Conscle Witk Detais |;- Froperties
User: puser Maintenance G

Information pane
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Note: Certain changes you make to the appearance and arrangement of elements in
Longview Application Administrator are saved as settings and are remembered the next time
you start the application. For example, if you close the Properties pane by clicking the “X” in its
upper right corner and close the application, the Properties pane will not be displayed the next
time you start the application. To restore elements, you have hidden, click View in the menu
and then click the name of the element you want restored.

Server Explorer pane

The Server Explorer pane displays the elements of your database system in a hierarchical tree format,
grouping items together in specific categories. For example, attributes, symbols, user groups, and so
on. As well, security settings are represented, populated with user groups and users.

= [@ LVTAX

..... ‘FE Locks

----- Schedules

g Symbol Access
[+]-gig Symbols

&8 Users and Groups

When you select a category in the tree, the elements grouped immediately below it are displayed in the
Contents window (for example, choosing Attributes displays symbol, system, and user, the elements
grouped under Attributes). Selecting an item in the Contents window causes its properties (if any) to
display in the Properties window at the bottom of the application window. Many items can be duplicated
or edited in the Contents window by right-clicking them and making the appropriate selection from the
pop-up menu.

Note: To perform actions that make changes to the server or its contents, you must have
permissions to operate these functions on the server.

Contents window

The Contents window displays the constituent elements of whatever is selected in the Server Explorer
pane or was double-clicked in the Contents window itself.

The Contents window provides access to the most basic items in the database hierarchy, such as
individual users and user groups, attributes, symbols, and so on. Selecting an item in the Contents
window causes its properties to display in the Properties window, and for some items, right-clicking the
item provides options to edit, copy, and/or delete it, as well as to create new instances of the same item

type.
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Attributes Batches Events Intercompany  Journal Entries Locks
Eliminations
Rules Schedules  Symbal Access Symbaols Users and
Groups

Information pane
Certain tabs are grouped in the Information pane. These are:

® Console Window
®m  Search Results Window

Each of these windows can be undocked from the others by dragging the tab out of the Information
pane. In addition, dragging the tab towards the center will cause a set of positioning arrows to appear,
allowing you to tile the tab within the group window. Tiled or ungrouped windows can be regrouped by
dragging them back to the tabs at the bottom of the Information pane. Finally, tabs can be dragged left
and right relative to one another to change the order of the group.

Search Results o

MNarme Description

% Search Results @ Console Window |

Console window

The Console window supplies you with information on processes you run, such as restatements and the
collection of statistics. The information shown provides details on whether processes were successful, if
they completed, and what changes were made as a result.

Console Window o x

Collecting statistics from KLX_SPN_POOO_CELLS... -
Collecting statistics from KLX_SVN_POOO_CELLS...
Collecting statistics from KLX_STN_POOO_CELLS...
Callecting statistics from KLX_JLN_POOO_CELLS...

Callecting statistics from KLX_JCN_PODO_CELLS...
Collecting statistics from KLX_JIPN_POOO_CELLS. ..
Collecting statistics Trom KLX_JVN_POOO_CELLS. .. i-—!
Collecting statistics from KLX _JTN_POOO_CELLS... 1=
The statistics table has been updated |

<% Search Results ([l Console Window

1|
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Search Results window

The Search Results window displays the results of searches. If you double-click a search result, the item
is highlighted in the Contents window, and its properties and/or details display in the Properties pane.

Searches can be run on several types of items, though the parameters of the search vary from type to
type. Searches are executed by selecting a category in the Server Explorer pane (e.g., entities under
symbols) and choosing Tools > Search, and entering the criteria of your search in the appropriate fields
of the Search dialog.

Selecting Tools > Highlight Search Results turns on or turns off highlighting of the results of your search
in the Contents window.

Properties pane

Certain tabs are grouped in the Properties pane. These are:

= Properties window
® Details window

Each of these windows can be undocked from the others by dragging the tab out of the Properties pane.
In addition, dragging the tab towards the center causes a set of positioning arrows to appear, allowing
you to tile the tab within the group window. Tiled or ungrouped windows can be regrouped by dragging
them back to the tabs at the bottom of the Properties pane. Finally, tabs can be dragged left and right
relative to one another to change the order of the group.

Properties window

The Properties window gives basic information about the item currently selected in the Contents
window:

Properties o x
Mary - Administrator
Email mscratch@abccorp. com
First Mame Mary
Home Phone
Last Login 1/1/1970 12:00:00 AM
Last Mame Scratch
Last Updated 20102012 7:28:12PM
Office Phone
Type Longview Authentication
User Mame Mary

=| Details |32k Properties

Details window

The Details window gives in-depth information about the currently selected item in the Contents window:
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Details 1 x
i Component Authorization | User and Groups Authorization | Data Server Authorization | Maintenance Authorization | Journal Entry Authorization |

Mary - Mary - Administrator

Component Authorization

Longview Application Administrator ~ Granted
Longview Server Manager Granted

[Z] Details |4 Properties |

Understanding menus

Various Longview Application Administrator functions are available in the menu selections. What follows
is a brief overview of each menu pick.

File Edit View Tools Actions Help
wg New ~ - - | W ¥ | Recalculate

Note: The menu bar appears as shown above when a symbol is selected in the Contents
window. The icons available to you at any given time may vary depending upon your current
selections.

File menu

Most options under File deal with operations outside the application, such as printing, archiving, and
exporting files.

Mew *
%  Import...
#  Export..
Page Setup
s Pnnt...
& Print Preview
%t Properties
Exit
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New

This menu selection is context sensitive and provides different options in a secondary drop-down list
depending on the current selection in other areas of the application window. In general, this item
enables the creation of new access role, attributes, schedules, rules, intercompany eliminations,
symbols, groups, and users, as well as duplicate instances.

Import

Choose Import to open a dialog that lets you designate the type of item to be imported (attribute, symbol,
user, etc.), its dimension (if it is a symbol), and the location of files from which its items, descriptions (if
applicable), and parent-child relationships (if applicable) will be imported. You can use the Browse
button to select already-created import files. For more information on using Import, see Importing Server
Objects.

Export

Choose Export to open a dialog that lets you designate the type of item to be exported (attribute, symbol,
user, etc.), its dimension (if it is a symbol), and the location of files to which its items, descriptions (if
applicable), and parent-child relationships (if applicable) will be exported. You can use the Browse
buttons to select existing files, or type in a path and file name to create new files. For more information
on using Export, see Exporting Server Objects.

Page Setup

Choose Page Setup to open a dialog where you can set the printing parameters such as the paper size
and orientation, the width of page margins, and the paper source.

Print

Choose Print to open a dialog that lets you select your printer, the number or range of pages to print, and
the number of copies. The output is either the Contents window or the grouped tab window that is active
when you click Print.

Print Preview

Choose Print Preview to open a window that shows how your output will appear on the printed page
according to your current Page Setup parameters. It enables you to view one, two, three, four, or six
pages at a time, to change the magnification level of the view (but not the actual output), and to print
directly to the default printer.

Properties

Choose Properties when you have selected an item with viewable or editable properties in the Contents
window. A dialog opens displaying the properties of the item and enabling you to edit those properties
and save your changes. The information is displayed in a tabbed format. The tabs displayed and
information populated varies with the type of item of you have selected.

Exit

Choose Exit to log out of the system and close the application.
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Edit menu

The choices under the Edit menu, Undo and Redo, let you to undo an action just performed, or to redo
the action if you decide to proceed with it after having undone it. These options are available only for
symbol maintenance actions, up until Maintenance is turned off.

View menu

The choices under the View menu let you select the window elements that are displayed or active.

Details

E' Icons

B Console Window
¥ Search Results
=| Details Window
i Property Window

Clear Console

Refresh F5

Toolbars »
E' Component Bar
Status Bar
Details

Choose Details to display the items in the Contents window in a text-only list.

Icons

Choose Icons to display the items in the Contents window as icons.

Console Window

Choose Console Window to activate and display the Console window in the grouped tab window at the
bottom of the Contents window.

Search Results

Choose Search Results to activate and display the Search Results window in the grouped tab window at
the bottom of the Contents window.

Details Window

Choose Details Window to activate and display the Details window in the grouped tab window at the
right of the Contents window.

Property Window

Choose Property Window to activate and display the Property window in the grouped tab window at the
right of the Contents window.
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Clear console

Choose Clear console to discard the contents of the Console window.

A Caution: This procedure cannot be undone.

Refresh

Choose Refresh to update the view in the Contents window.

Toolbars

This option expands into another menu that enables you to turn the Standard and Component toolbars
on or off, and to lock their positions or unlock them so that the toolbars can be repositioned in the
interface.

Component Bar

Choose this option to show or hide the Component Bar.

Status Bar

Choose this option to show or hide the Status Bar.

Tools menu

The Tools menu presents options to do with organizing, refreshing, and gathering information about
data in the system.

Tools | Actions  Help

Change My Password...
3 Recalculate

Audit 3
Collect Statistics

Duplicate Detection...

Fareign Exchange Setup...
Journal Entries Setup...
NDD Setup...

NDD Pattern Table Setup...

Event Rule Merging Setup...
Event Rule Dependencies Setup...

¥ Search
Highlight Search Results F7

Options...

Change My Password

Choose Change My Password to open a dialog allowing you to change the password of the user you are
signed on with.
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Recalculate

Choose Recalculate to have values in the database recalculated and refreshed. The Recalculate dialog
opens and allows you to set the type of recalculation, which partitions to recalculate, the names of files
to archive information before and after the recalculation, and whether to collect and display statistics
about the recalculation.

For more information see Working with Restatements and Recalculations.

A Caution: A recalculation can take a considerable amount of time for large databases and can
be resource intensive. Recalculations can affect other users if run during periods when they
are signed onto the system.

Audit

Choose Audit to access three options:

= Export: Export lets you query the database for records of what values in the database have
been changed and by which users and export those records to a text file. For more information,
see Exporting the Data Audit Trail.

® Recover: Recover lets you reset leaf table values to the values stored in the audit tables. This
function is useful in the event of a system failure.

® Reset: Reset removes all audit detail and sets the initial audit values to the current leaf table
values.

o Note: If you are not connected to the server, Export, Recover, and Reset are disabled. If you
do not have access to view data in the server, Export is disabled.

These options are available only if your system is configured to use Data Audit Trail. For more
information, see the Longview Server Manager Guide.

Collect Statistics

Choose this function to update the collected statistics for the current server. The progress of the update
is displayed in the Console window. Statistics are updated in the following database tables:

= KLX_ULN_P000_CELLS
= KLX_UPN_P000_CELLS
» KLX_SLN_P000 CELLS

® KLX_SPN_P000_CELLS

Duplicate Detection

Choose this option to check the database for duplicate data. For more information, see Checking for
Duplicate Data.
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Foreign Exchange Setup

Choose this option to set up or modify your foreign exchange settings. For more information, see
Working with Foreign Exchange.

Journal Entries Setup

Choose this option to open the Journal Entries Setup dialog and customize the behavior of Longview
Journal Entries. For more information, see Configuring Journal Entries.

NDD Setup

Choose this option to select the modulating, independent, and dependent dimensions for N-dimensional
modeling. When you choose NDD Setup, a dialog is displayed with drop-down lists that allows you to
make your dimension selections. Subsequent dialogs enable you to change Valid Root(s) settings,
Default Symbol, and Modulating Symbol. For more information, see Specifying NDD Settings.

NDD Pattern Table Setup

Choose this option to open a pattern table dialog that allows you to make symbol selections for N-
dimensional modeling. For more information, see Setting Up or Modifying the NDD Pattern Table.

Event Rule Merging Setup

Choose this option to configure event rule merging. You may have event rules that trigger the exact
same process based on different circumstances. If this is the case, you can consider merging these
rules so that they don’t trigger the process multiple times unnecessarily. For more information, see
Specifying Event Rule Merge Settings.

Event Rule Dependencies Setup

Choose this option to configure event rule dependencies. If your system includes a rule that always
triggers another rule, you can specify this dependency so that if those two rules are triggered
simultaneously, the system waits for the preceding rule to finish before it allows the dependent rule to
process, which uses system resources more efficiently. For more information, see Specifying Event
Rule Dependencies.

Search

Choose Search to execute a search by selecting a category in the Server Explorer pane (e.g., entities
under symbols), choosing Tools > Search, and entering the criteria of your search in the appropriate
fields of the Search dialog. Searches can be run on several types of items, though the parameters of the
search vary from type to type.

The Search Results window displays the results of searches. Double-click a result to display its
properties and/or details in the Properties pane.

Highlight Search Results

Choose Tools > Highlight Search Results to highlight or not highlight the results of a search in the
Contents window.

Options

Choose Options to change the way items are displayed in the Contents window.
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For example, you can change the colors used to highlight results when you have Highlight Search
Results on. In addition, you can format how symbols are displayed, and what information about symbols
accompanies them.

(5] Options
[=)- Application Administrator Highlight
- General
Fe d: Back: d:
[=)- Search Highlight S =cgroun
[J'white v Custom... [ <Default> v Custom...
[=1- Symbol
Appearance
(=) Tead

i Accounts

i-- Time Periods

.- Entities

i Cumencies

i Other Dimensions

Actions menu

The Actions menu provides access to functions concerned with maintaining and arranging your symbol
hierarchy.

Connect

i# Disconnect

I Maintenance

| Exclusive Mode

Dynamic Calculations  »
Assign

Assign To

Remuove From Parent

Duplicate Hierarchy...

Set Value...

Delete

Connect

Choose Connect to connect to the server, provided your User ID has the requisite permissions to do so.
This option becomes available when you are not connected to the server. All server tasks require that
you connect to the server as a user with administrative permissions.

Disconnect

Choose Disconnect to disconnect from the server. This option becomes available when you are
connected to the server. Once you click Disconnect you will no longer be able to view, modify, or
otherwise access the resources of the server until you connect to it again.
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Maintenance

Choose Maintenance to turn Maintenance on or off. A check mark beside the option indicates that
maintenance is active.

Exclusive Mode

Choose Exclusive Mode to turn Exclusive Mode on or off. A check mark beside the option indicates that
Exclusive Mode is active.

Dynamic Calculations

Choose Dynamic Calculations to turn the ServerMath Flag on or off.

Assign

Choose Assign to drag a selected symbol to another symbol, which then becomes its parent symbol.
This option becomes available when you select a symbol.

Assign To

Choose Assign To, to assign the previously chosen symbol to the symbol currently selected. This option
becomes available after you have used Assign.

Remove From Parent

Choose Remove From Parent when a child symbol is selected to remove the symbol from the parent's
hierarchy and place the symbol in the root of its class. This option becomes available when you have
selected a child symbol.

Duplicate Hierarchy

Choose Duplicate Hierarchy to open a dialog that lets you create a duplicate of the hierarchy. This
option becomes available when you select a root symbol of a hierarchy. A specified prefix or suffix is
added to each symbol name in the hierarchy being duplicated. For more information, see Duplicating a
Hierarchy.

Set Value

Choose Set Value to open a dialog that lets you set the attribute’s value. This option becomes available
when you select an attribute.

Delete
A Caution: Deletions cannot be undone.

Choose Delete to be prompted by the system to confirm that you want to proceed before the deletion is
performed. This option becomes available when you have selected an item that can be deleted.

Help menu

The Help menu provides you with access to information on how to work in the application, and
information on the current build of the application.
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Longview Application Administrator Help

Choose Longview Application Administrator Help to open another window which presents the online
help system. The system has two panes; one on the left shows the table of contents tab, which features
an expandable and collapsible structure of topics and the subtopics grouped under them. The pane on
the left contains other tabs:

= The index tab, with clickable links to content.

® The search tab, which enables you to search the online help system for instances of words and
then access the results.

= The favorites tab, which enables you to bookmark information you have found useful for future
reference.

The pane on the right is the content pane, where the information contained in the online help system is
displayed. This pane changes to display different information based on the choices you make in the
other pane. It also features navigation buttons at the top and bottom of each topic that display the next
and previous topic respectively, and hyperlinks that take you directly to related information when clicked.

About Longview Application Administrator

Choose About Longview Application Administrator to open an information window that displays the
name of the application and its current version. This can be useful in the event that you need to contact
Longview on a service matter. To close the window, click anywhere within it.

Working in Maintenance mode

When users and administrators are working with Longview components, there may be maintenance
modes turned ON and OFF automatically as part of a process.

For information on using commands involved in maintenance, see the Longview Desktop Commands
and Functions Guide or the Longview Developer’s Guide.

Maintenance mode

When administrators make Database Maintenance changes to the Data Server repository, Maintenance
mode is usually turned ON automatically. While it is ON, the following apply:

®  Users can connect and perform read-only queries

® Users can lock data areas, post journal entries, and submit data (these activities are
suspended, not stopped, while user and symbol changes are committed and refreshed)

The time required for the servers to commit and refresh can be several seconds to several minutes. The
length of time depends on several factors:

= Symbol and hierarchy sizes
m Use of other features, such as NDD or data translation

= Status of the Math queue. When user or symbol changes are committed, the submission queue
is suspended and a suspend request is sent to the Math queue. All pending math jobs in the
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queue prior to this request must complete before the Math Server can be suspended and
refreshed. When large math jobs are pending, long wait times may occur.

Exclusive mode

Exclusive mode may be turned ON automatically (if no pending submissions exist) in conjunction with
Maintenance mode and while it is ON, the following apply:

®  Users can connect and perform read-only queries
= Users cannot lock data areas, post journal entries, or submit any data

If a user has turned Exclusive mode ON, the same user must turn it OFF before certain actions can be
performed by other users.

o Note: If a restatement fails due to errors, exclusive mode will remain on to prevent users from
submitting data to the database. Users will not be able to turn exclusive mode off through
Application Administrator in this case. If exclusive mode needs to be turned off from a failed
restatement either run a successfully restatement or restart the servers.
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Performing General Server Tasks
Checking for duplicate data

Due to user errors or other reasons, you may sometimes have duplicate data in your system. You can
use Longview Application Administrator to check for duplicate data before you perform a data export or
a restatement.

To check for duplicate data, complete the following steps:

1. Open Longview Application Administrator.

2. Select Tools > Duplicate Detection. The Duplicate Detection dialog displays, as shown below:

[E! Duplicate Detection &J
Duplicate Detection
Family Partition List
: PO00
3 Yo POOT
() Schedule P02
: PO03
© Al POD4
DataOption
@ Calculated
) Parent
@ Al
[ Run ] I Close ]

3. Complete these fields:

a. Family: Select Base (to check Base data only), Schedule (to check Schedule data only), or
All (to check all data).

b. Data Option: Select Calculated, Parent, or All types of data.

c. Partition List: Specify the list of partitions you want to check.

4. Click Run. The results of the duplicate check appear in the Console window.

5. Click OK.

Working with restatements and recalculations

An enterprise restatement is a mode of calculation in which a rollup of the entire database is performed
making all values current. An enterprise restatement is required to calculate the effect of major changes
throughout the database.

A partition recalculation is a mode of calculation in which a recalculation of one partition is performed
making all values current. A partition recalculation is required to calculate the effect of changes confined
to a single partition.
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Partition recalculation does not guarantee data integrity under the following scenarios:

= |f the specified partition or partitions do not cover all input leaf data needed to generate data for
the specified partition or partitions.

= [fthere is output data generated outside of the specified partition or partitions. You will see a
warning message in the Longview Data Server Log:
The output data generated to the following partitions were filtered out during partition recalc on

specified_partition_name: list_of partitions.

You can use Longview Application Administrator to run a recalculation that meets your specific
requirements. For information on running a recalculation using line mode, see the Longview Server

Manager Guide.
To run a recalculation, complete the following steps:

1. Open Longview Application Administrator.

2. Onthe toolbar, click Recalculate. The Recalculate dialog opens.

() Recalculate E
Recalculate
Recalculation Type:
Auto w
Partitions to Recalculate:
[P0
Select all Select none
Archive Monitor File
[T] Before Recalculation Flename: Iv_dstaserver_restate_Ydate_%ime log
[] After Recalculation Flename: Iv_dataserver restate_Ydate_%ime log
QOptions
[] Run Collect Statistics after recalculation [] Display recalculstion statistics
Corce

3. Select the Recalculation Type. The recalculation types are as follows:

a. Auto: Performs steps based on Ivsrvr.cfg parameters set to TRUE.

b. Regular: Restate Unadjusted, Recalculate Journals, and Restate Adjusting.
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c. Full: Restate Unadjusted, Recalculate Journals, Recalculate Eliminations, and Restate
Adjusting.

d. Basic: Restate Unadjusted and Restate Adjusting.

e. Journal Entries Only: Recalculate Journals.

4. Select the partitions you want to include in the recalculation. If you want all partitions included, click
Select all.

5. If you want to enable tracking changes to the Data Server Log file, select Before Recalculation,
After Recalculation, or both. In the adjacent text fields, provide the path and file name of the Data
Server Log file to which you want this information written.

6. If you want statistics generated by the recalculation to be recorded, select Run Collect Statistics
after recalculation.

7. If you want to view recalculation statistics, select Display recalculation statistics.

8. Torun the recalculation, click OK. The results of the recalculation appear in the Console window.

Exporting the Data Audit Trail

You can use the Data Audit Trail functionality of Longview to query the database for records of the
values in the database that have been changed and by the users who changed them, and to export
those records to a text file. This information can be important in recovering from system failures,
correcting erroneous entries, and compliance with the Sarbanes-Oxley Act.

o Note: Using the Data Audit Trail functionality requires that the Data Audit Trail parameter be
set to TRUE in Longview Server Manager (the default value is FALSE). In addition, the
RECALC AUDIT RESET command must be performed on the data server. For more
information, see the Longview Server Manager Guide. If you do not have access to this
functionality, contact your System Administrator.

To export the Data Audit Trail, complete the following steps:

1. Open Longview Application Administrator.

2. Select Tools > Audit > Export. The Data Audit dialog displays, as shown below:
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(] Data Audit - olEN |

Data Audit Trail Query

Use the table below to set the symbaols for each dimension. Click the lookup button in the Symbol field to access the symbol selector. Use the Filters
and Options on the right to further define your report

Dimension Symbol(s) tes
ACCOUNTS [ User Filter
TIMEPER Andrew
ENTITIES [ Date Fiter
DETAILS 12/ 6/2016 To 12/ 672016

CURRENCY

SEGMENTS

ELEMENTS

CONTROLS b ad |f
[] Associated With Batch

[] Data Change Threshald

Between

Sorting Options

First sort by w Ascending w
then by v Ascending w
[ Include Schedule Dimension
DataAttributes
Dimension Symbaol
File Name
Location Browse
BExport Cancel

Note: You can enter parameters for as many criteria in the dialog as you choose. If no criterion is
specified, all data audit information is returned.

3. Enter parameters for any or all the following fields:

a. Symbols: To specify a symbol for a dimension, click in the cell under the Symbol column for
that dimension to activate a symbol selector button ( ... ). Click the button to view the Symbols
dialog and use it to select a symbol for that dimension.

Note: The data query defaults to the user attribute values found in the UGPD
[DimensionNumber]QueryDefault attributes. In addition, if you have access to only
one symbol in a dimension, the selection defaults to that symbol.

b. Schedule Dimension: To enable the use of a schedule dimension, select Include Schedule
Dimension, and use the drop-down list to select a schedule. To specify a symbol for that
dimension, click in the cell under the Symbol column for that dimension to activate a symbol
selector button ( ... ). Click the button to view the Select Symbol dialog and use it to select a
symbol for that dimension.

c. User Filter: Select User Filter and use the drop-down list to select a user. Changes made by
this user only are included in your results.

d. Date Filter: Select Date Filter, and type dates in the MM/DD/YYYY format or use the calendar
drop-down menus to select a specific date for each field.
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e. Data Change Threshold: Select Data Change Threshold, and use the drop-down menu to
select Between, Greater Than, Less Than, or Value Of, then supply a value or values in the
field(s) below.

f. Associated With a Batch: Select Associated with a Batch and enter a batch ID number in the
field below.

g. Sorting Options: The Sorting Options enable you to specify how to sort the data audit results.

4. When you have completed configuring the criteria of your query, complete the following fields:
a. File Name: Enter a name for the Export file.
b. Location: Enter a location to which you want to save the Export file. Alternately, you can use
the Browse button to navigate to the folder to which you want to save the Export file.

[ o Note: The Export button is unavailable until the File Name and Location are entered.

5. Click Export. A Data Audit Export progress bar opens.

Note: Depending on the size of the database and the specificity of your query, a data
audit trail export may take several minutes to complete.

6. After the export finishes, an Export Summary screen displays, as shown below. This screen
summarizes the number of entries saved as well as the number of errors encountered.

| (2 Export Summary u
Summary
Mumber of Entries Saved: 153
Mumber of Emors Encountered: 0
7. Click Close.

Audit Trail Export file syntax

After the Data Audit Export is complete, the data specified by your query is exported to a text file. The
syntax of the export file depends on whether only base data was queried, or a schedule was included as
well.

Base data

ID{Dim 0{Dim 1{...{Dim N{Old Value{New Value{Delta{Date{User{Comments

Where:
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= /Dis the batch ID number.

® Dim_0{Dim_1{...{Dim_N are the symbols queried in each base dimension.

®  Old Value is the old value of the data.

= New Value is the new value of the data submitted to the database.

® Deltais the difference between Old Value and New Value.

®  Date is the date on which the changes were submitted to the database.

®  Useris the username of the user that made the changes.

= Comments is any comments associated with the changes, enclosed in double quotation marks.
If the comments already contain quotation marks, they are enclosed in a second set of double

quotation marks (""comment"").

Example:

2174{A11510{A100PEN{B0910{DIM3SET{DIMA4SET { DIM5SSET{DIM6SET{DIM7SET{0{99{99
{11/26/2010 11:11:58 AM{TAXADMIN{"Trial balance input"

Schedule data

ID{Dim 0{Dim 1{...{Dim N{Schedule{Sched Diml{..{Sched DimN{Old Value {New
Value{Delta{Date{User{Comments

Where:
® /D s the batch ID number.

= Dim_0{Dim_1{...{Dim_N are the symbols queried in each base dimension.

®  Schedule is the name of the schedule selected in the Schedule Dimension drop-down list.
® Sched_Dim1{...{Sched_DimN are the symbols queried in each schedule dimension.

= Old Value is the old value of the data.

= New Value is the new value of the data submitted to the database.

® Deltais the difference between Old Value and New Value.

= Date is the date on which the changes were submitted to the database.

®  seris the username of the user that made the changes.
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= Comments is any comments associated with the changes, enclosed in double quotation marks.
If the comments already contain quotation marks, they are enclosed in a second set of double

quotation marks (""comment"").
Example:

3{SALES4 {QAFORO01 {XL2 {DIM3SET{DIM4SET {VALIDATION{DIM6SET{DIM7SET{S1043{L0001
{C0001{ 1126{-112{-1238{29/11/2010 12:04:13 PM{LONGVIEW\MIHA228461{"Data

submission"

Resetting the Data Audit Trail

If your system has Data Audit Trail selected in the Server Configuration settings, you can reset Data
audit detail. If you reset Data audit detail, the trail is deleted and the initial audit values are reset to the
current leaf table values. Batch and event information is also deleted, along with related log, error, and

history files.
To reset the Data Audit Trail, complete the following steps:
1. In Longview Application Administrator, choose Tools > Audit > Data > Reset. A confirmation dialog
opens.

A Caution: Clicking Yes in the next step removes all audit trail values and batch and event
information, as well as log, error, and history files in the file paths defined in the Server

Configuration settings.

2. Click Yes. The Data Audit Trail is reset.

Resetting the Metadata Audit Trail

If your system has Metadata Audit Trail selected in the Server Configuration settings and you have the
appropriate authorizations, you can reset Metadata Audit trail. If you reset Metadata Audit trail, the trail
is deleted according to the specified selections. If the Metadata Audit Trail Log Files location is set in
the Server Configuration, a log of the audit records that were reset will be created in the specified

location.
To reset the Metadata Audit Trail, complete the following steps:
1. In Longview Application Administrator, select Tools > Audit > Metadata > Reset. A dialog opens.

2. Enter parameters for any or all the following fields:
Date: Type dates in the YYYY/MM/DD format or use the calendar drop-down menus to select

a specific date for each field.
b. Category: To reset Metadata Audit Trail for specific category types, select one or more of the
following:

a

o Select All

« Attribute Maintenance
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 Authorization Maintenance

e Group Maintenance

e Group Membership Maintenance
» Role Maintenance

« Symbol Maintenance

« User Maintenance

c. Comment: Optionally, enter a command to be included with the reset action.

A Caution: Clicking Reset in the next step removes the specified metadata audit trail
information.

3. Click Reset. The Metadata Audit Trail is reset.

Configuring Journal Entries

Before using Journal Entries, you can modify journal entry settings to meet your company’s needs. You
can also create sub-categories for schedule journal entries.

Specifying Journal Entries settings

You can use the Journal Entries Setup dialog to quickly set up and modify settings for Journal Entries
more easily than setting individual attributes. You can use this dialog only if you have the necessary
permissions to change settings for Journal Entries.

To use the Journal Entries Setup dialog to set up or modify Journal Entries settings, complete the
following steps:

1. Open Longview Application Administrator.

2. Select Tools > Journal Entries Setup. The Journal Entries Setup dialog displays, as shown below:

insightsoftware.com


https://insightsoftware.com/

Y insightsoftware

35

Tl Pl e - olEN|

General | Symbols

Options

1 Mlow the Joumnal Entry Application |D to be modified

Share Mew Joumal Entries by default

Share Posted Joumal Entries

Alow Joumnal Entries on areas marked submitted or invisible by wordlow
Retain Deleted Joumal Entries in the database

P
2

% MNumber of Decimal Flaces for Financial Joumal Ertries
-

Number of Decimal Places for Non-Financial Joumal Entries

Dimensions that can be unbalanced in Joumal Entriss

[] ACCOUNTS
[] TIMEPER
[] ENTITIES
[[] PRODUCTS
[[] CURRENCY
[[] CONTROLS

Cancel

3. Onthe General tab, set the following parameters:

a.

Allow the Journal Entry Application ID to be modified: Specify whether the Application ID is set
only during the initial creation of the journal entries, or whether it can be modified later.

Share New Journal Entries by default: Specify whether you want journal entries to be shared
by default.

Share Posted Journal Entries: Specify whether all journal entries are shared after posting.

Allow Journal Entries on areas marked submitted or invisible by workflow: Specify whether
you want users to be able to submit journal entries on areas of workflow that have been
submitted for approval or are invisible.

Retain Deleted Journal Entries in the database: Specify if you want deleted journal entries to
be retained by the database, and users to have the option to retrieve deleted journal entries.

Number of Decimal Places for Financial Journal Entries: Enter a value between 0-100 or use
the arrow buttons to raise and lower the value, to specify the number of decimal places you
want financial journal entries to display.

Number of Decimal Places for Nonfinancial Journal Entries: Enter a value between 0-100 or
use the arrow buttons to raise and lower the value, to specify the number of decimal places
you want non-financial journal entries to display.

Dimensions that can be unbalanced in Journal Entries: Select the check box associated with
a dimension to allow it to be unbalanced in journal entries.

4. Click the Symbols tab.
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General | Symbols

Journal Entries Setup

Select default symbol and postable roots for each dimension

Dimension Postable Roots Default Symbol
ACCOUNTS Trial_Balance DIMOSET
TIMEPER CP14,CP15 DIM1SET
ENTITIES ABC_Operations, ABC_Global_Operations DIM2ZSET
PRODUCTS DIM3SET, Total_Products_Services DIM3SET
CURRENCY DIM4SET, SourceC DIM4SET
CONTROLS DIMBSET DIMBSET

ar

5. Foreach dimension in the database, select a post-able root symbol. This symbol does not have to
be a dimension root symbol; however, make sure it contains all possible leaf symbols to be used for
adjusting journal entries. Ignore any unused dimensions.

a. Toselectasymbol, click in the Default Symbol cell for a dimension. A symbol selector button
(... )appears. Click it to open the selection dialog. You can locate and select the default
symbol for that dimension. Repeat this step for all applicable dimensions.

T <]
B
Type ACCOUNTS
ACCOUNTS Pl CIMOSET - Accounts Default
i#-[ ] EMPLOYEES - Employees
([ ] FXRates - Translation Rate Types
|:| JEGROUP - Shared JE Groups
|£||:| LAFF_PARAM - LAFF Parameter Parent
([ ] LAFF_STATUS - LAFF STATUS
[#-[¥] Trial_Balance - Trial Balance
|§||:| WTPRO - TPro Row Parent Varable
Summary:
Type Name Description
ACCOUNTS Trial_Balance Trial Balance
QK

6. When you have completed the general settings and symbol selections, click OK.

Creating sub-categories for journal entries

You can create new journal entry sub-categories in addition to the out-of-the-box sub-categories that are

built into Longview. Sub-categories can be associated with schedules.
For more information on schedules, see Understanding Schedules.

To create a journal entry sub-category, complete the following steps:

1. Open Longview App

lication Administrator.

2. Inthe Server Explorer pane, expand Journal Entries, and select Sub-Categories. The list of sub-

categories appears i
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3. Right-click and select New JE Sub-Category. The New JE Sub-Category dialog displays, as
shown below:

) MNew JE Sub-Category EX
General
Description: || I E’D
Schedule Name: L

Reclassification

Carc

4. Complete the following fields:

a. Schedule Name: Use the drop-down list to select a schedule to base the sub-category on. For
Elimination journal entries, select an Intercompany Transaction schedule, such as
ICStandard. This field is optional.

b. Reclassification: Select this option to allow base details to have different amount