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Getting Started In Longview Analysis and
Reporting
You can get started quickly and easily in Longview Analysis and Reporting. You can also choose to work
offline to save Internet connection costs, or when no connection is available for your computer.

Launching Longview Analysis and Reporting
This section explains how to start Longview Analysis and Reporting, including authentication and
security considerations.

https://insightsoftware.com/
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Understanding your Longview database
Your company uses a large database containing its financial data. A Longview database consists of
dimensions, hierarchies, and symbols. You can work with the application more effectively if you
understand the basic concepts first.

Dimensions
The Longview database contains a wealth of information, divided into different categories. For example,
some of the information describes the accounts in the General Ledger, some the world-wide locations in
which your company does business, and so on. Each individual bit of information is stored in a symbol.
Symbols are organized in hierarchies.

In the Longview database, each broad category of data is called a dimension. A dimension is a set of
similar elements providing a structure for information analysis. You can manipulate the display of
dimensions to see exactly the combination of data you need.

ACCOUNTS dimension
The ACCOUNTS dimension contains symbols that represent the accounts in a Trial Balance. The
ACCOUNTS dimension is the first dimension in the Longview database for our hypothetical company.

Dimension Description Example

ACCOUNTS
Contains symbols representing Trial Balance accounts.

Usually listed down the left side of the document.

n Cash

n Net Income

TIMEPER dimension (TIME)
The TIMEPER dimension contains the concept of time references such as months, quarters, and years.
The TIMEPER dimension is the second dimension in the Longview database for our hypothetical
company

Dimension Description Example

TIMEPER
Contains symbols representing time periods. Usually listed

across the top of the document.

n current month

n current year

Note: Depending on how your Longview system has been set up, your TIMEPER dimension
may appear with another name — for example, TIMEPERIODS. Examples and illustrations in
this guide may appear with either variation.

ENTITIES dimension
The ENTITIES dimension is the third dimension in the Longview database for our hypothetical company.

https://insightsoftware.com/
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To understand the concept of the third dimension, imagine that you are stacking worksheets with
accounts down, time periods across, and entities deep. This stack of worksheets can be compared to a
cube of data, where each dimension of the cube (down, across, and deep) represents the first three
dimensions in the database.

Dimension Description Example

ENTITIES

Contains symbols representing business locations.

Represents the depth of the three-dimensional cube

behind the ordinary flat workbook.

n Dallas

n Toronto

CURRENCY dimension
The CURRENCY dimension contains symbols used in the data translation process (also known as
foreign exchange). The CURRENCY dimension is the fourth dimension in the Longview database for
our hypothetical company.

Note: Depending on how your Longview system has been set up, your CURRENCY
dimension may appear with another name — for example, CURRENCIES. Examples and
illustrations in this guide may appear with either variation.

Dimension Description Example

CURRENCY
Contains symbols representing the various
currencies used by your company.

n Total U.S. dollars

n Total Euros

Almost all Longview databases contain a CURRENCY dimension. However, if your company deals
solely with one currency, you may not have a CURRENCY dimension in your Longview database.

PRODUCTS dimension
The PRODUCTS dimension contains symbols that represent products manufactured by our
hypothetical company. The PRODUCTS dimension is the fifth dimension in the Longview database for
our hypothetical company.

Dimension Description Example

PRODUCTS
Contains symbols representing the individual

products sold by your company.

n Modems

n Printers

CONTROLS dimension (VERSIONS)
The CONTROLS dimension contains symbols needed for various special tasks in the application. The
CONTROLS dimension is the sixth dimension in the Longview database for our hypothetical company.

https://insightsoftware.com/
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The CONTROLS dimension is usually the last dimension in a Longview system.

Dimension Description Example

CONTROLS

Also contains symbols required by your Longview

system for allocations and scenarios, to view subsets

of hypothetical data for planning and budgeting

purposes.

n PFCut1

n PFCut2

Note: Depending on how your Longview system has been set up, your CONTROLS
dimension may appear with another name — for example, VERSIONS. Examples and
illustrations in this guide may appear with either variation.

Fixed symbols in each dimension --specific to AR,
move to working with data content
Each dimension needs a reference to an individual default symbol in the dimension. The fixed symbol is
a single symbol selected in one of the fixed dimensions.

The default fixed symbol is known as the Dim#Set, where the pound sign ( # ) represents the number of
the dimension (beginning with zero, not one).

Note: Depending on how your Longview system has been set up, your default fixed symbol
may be name <dimension>_Default. Examples and illustrations in this guide may appear with
either variation.

So, for example, the dimensions for our hypothetical company contain the following fixed symbols:

Dimension Order in database Fixed symbol

ACCOUNTS First Dim0Set / ACCOUNTS_Default

TIMEPER Second Dim1Set / TIMEPER_Default

ENTITIES Third Dim2Set / ENTITIES_Default

PRODUCTS Fourth Dim3Set / PRODUCTS_Default

CURRENCY Fifth Dim4Set / CURRENCY_Default

CONTROLS Sixth Dim5Set / CONTROLS_Default

Hierarchies
Each of the symbols in the Longview database relates in some way to other symbols. For example, the
symbol Sales in the ACCOUNTS dimension intersects every symbol in all the other dimensions of the
Longview database.

https://insightsoftware.com/
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The relationship between individual symbols is called a parent/child relationship. The relationships as
a whole are known as a hierarchy.

A hierarchy is a method of organizing symbols and their relationships to each other in their dimension.
In a Longview database, a symbol can occur only once, and can reside in only one dimension.

In any hierarchy, there are four types of symbols.

Symbol

Type
Description

Leaf
Has no child symbols beneath it in its hierarchy. The value of a leaf symbol can be entered

manually or by import, but it cannot be specified by a rollup like the value of a parent symbol.

Child

Has at least one level of symbols above it in its hierarchy. The total value of each child symbol

specifies the value of the parent. A child symbol is often referred to as a leaf symbol, but it is

important to remember that a parent symbol can also be a child symbol.

Parent

Has at least one child symbol beneath it in its hierarchy. The values of the child symbols

specify the value of the parent symbol. However, some parent symbols are static, and

therefore their value is not specified by their child symbols.

Root

Has no symbols above it in its hierarchy. Its value does not roll up to any other symbols. There

is only one root symbol in any hierarchy. However, there may be more than one hierarchy in a

dimension, and thus more than one root symbol in a dimension.

In this component, a hierarchy looks like this

https://insightsoftware.com/
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Symbol information
Every symbol in the Longview database is identified by characteristics, such as names and descriptions.

Information

type
Description

Name

Condensed form of the symbol’s description. A symbol name can be from two to 31

characters in length.

These short forms are specified when a Longview application is originally written. When
referring to a specific symbol, the application identifies it by its symbol name.

Description

Text describing the purpose of a symbol in more detail than the symbol name. A symbol

description can consist of a maximum of 100 characters.

The Longview database can contain descriptions in additional languages for the same
symbol. A symbol description in a language other than the primary language of your
company is an alternate symbol description.

Depending on how your Longview system is configured, you might see the name, the description, or
both.

The way a symbol appears and operates in the application depends on its symbol characteristics. You
specify symbol characteristics in Longview Application Administrator. For information on creating,
modifying, and deleting symbols, see the Longview Application Administrator Guide.

https://insightsoftware.com/
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Preparing Your System for Longview
Analysis and Reporting and Input
Use Longview Analysis and Reporting to view and analyze Longview data in reports. Use Longview
Input to submit data to the Longview database.

Before the users of the application can start to work, the System Administrator must perform a few
preparation tasks in Longview Application Administrator.

Specifying settings in Longview Application
Administrator
Before users can use Longview Analysis and Reporting, your System Administrator must use Longview
Application Administrator to specify the appropriate type of access for each user group. Only the System
Administrator can perform this task.

Settings for Longview Analysis and Reporting
To use Longview Application Administrator to specify settings for Longview Analysis and Reporting,
follow these steps.

1. If you are not already in Longview Application Administrator, start that component by clicking on its
icon in Longview Component Manager.

2. In the Server Explorer pane, click on either Users or Groups, depending on whether you want to
give permissions to a particular user, or to a user group. The list of existing users, or groups, is
displayed in the work pane.

3. Select the user or group you want to give Longview Analysis and Reporting permissions to and
double-click it to open its properties dialog.

4. Select the Authorization tab.

5. Select Application Access. The list of available applications is displayed

6. Select Longview Analysis & Reporting (if it is cleared) and select a role for the user or group. The
choices are:

Reporting role Tasks

Report Publisher Sets the general content, criteria, and format of the report templates that
Report Users use to analyze data and run reports.

Report Author Populates Data Views with data for analysis purposes, and then runs
reports either individually or in batches.

Report User Uses the report templates created by the Report Publisher to analyze
data and run reports.

7. When you are finished, click OK. For more information, see the Longview Application Administrator
Guide.

https://insightsoftware.com/
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Specifying attributes in Longview Application
Administrator
It is your responsibility to prepare your Longview system to allow users to access the application
components they require. In the case of Longview Analysis and Reporting and Longview Input, you
need to prepare an attribute and a static schedule to permit a particular type of activity.

SGPFloatingTimePeriods attribute for floating time
period symbols
If the users of the application have many standard reports that they want to reuse in the next calendar
month or fiscal year, they can use floating time period symbols in these reports. A floating time period
symbol ensures that they each show the correct month and year when the database is updated during a
rollover.

For example, let’s say you have 100 reports containing year 2009 time period symbols, and you want to
use these same reports in the year 2010. If you used regular time period symbols, you would have to go
into each of these reports and manually change the time period symbols from 2009 to 2010. However, if
you use floating time periods, the symbols update automatically when the database is rolled over to the
next year.

When preparing a report in the application, you select time period symbols in the Symbol Selection
dialog. You have the option of selecting either regular time period symbols or floating time period
symbols.

An asterisk is added to the symbol name to identify it as a floating time period symbol.

To allow users of the application to use floating time periods, you must set them up in Longview
Application Administrator.

To prepare floating time periods, follow these steps.

https://insightsoftware.com/
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1. Find the attribute SGPFloatingTimePeriods.

2. Set the values for SGPFloatingTimePeriods as a list of attributes. The list consists of attributes that
each represent one time period symbol that gets updated, either manually or automatically, during
the various rollover processes (month-end, year-end, and so on). Separate each attribute with a
pipe symbol ( | ). For example: SGPCurrentPeriod|SGPCurrentYear

3. Depending on the number of values you need to include, select the appropriate method.

l If you use the Attribute dialog in Longview Application Administrator to set the values of the
attribute, you are limited to a certain number of characters. If you exceed the maximum, the list
is automatically truncated.

l If you use a command and an ASCII file to set the values of the attribute, there is no limit.

4. Select attributes that represent a fully defined time period (for example, AYR10, P10Q1).

l You cannot use attributes that represent only parts of time symbols (for example, 2010, 10).

l You cannot combine multiple attributes that have partial time symbol names to make a full one.

UAccSchedules attribute to specify access to
schedules
To give users access to schedules in the application, you must select those schedules for the attribute
UAccSchedules set in Longview Application Administrator. You can select schedules individually or set
the attribute to ALL to give users access to all non-system schedules.

Attribute symbol selection
When selecting both base and schedule symbols for Longview Analysis and Reporting templates,
Publishers can select attributes instead of symbols. These attributes can be used to automate the
subsequent symbol selections of other users.

For each type of attribute (System, Symbol, and User), there are 16 attributes corresponding to 16
dimensions, resulting in 48 attributes.

SGPD#AttrSys

SGPD#AttrSym

SGPD#AttrUser

where:

n # can be 0-15 representing each of the possible sixteen dimensions in a Longview system.

https://insightsoftware.com/
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Working with Longview Analysis and
Reporting Files
In Longview Analysis and Reporting, the tasks you perform and the functionality to which you have
access depend on the role you have been assigned.

Your role in the reporting process
In Longview Analysis and Reporting, you perform tasks based on a role assigned to your individual user
ID or user group (if you are using V3 compatibility — for more information, see the Longview Application
Administrator Guide).

People who need to analyze data, and prepare or run reports are assigned one of three roles:

Reporting role Tasks

Report Publisher
Sets the general content, criteria, and format of the report templates that

Report Users use to analyze data and run reports.

Report Author
Populates DataViews with data for analysis purposes, and then runs

reports either individually or in batches.

Report User
Uses the report templates created by the Report Publisher to analyze data

and run reports.

Your System Administrator uses Longview Application Administrator to assign your role. If you think
your role has been assigned incorrectly, see your System Administrator.

Your starting point
In Longview Analysis and Reporting, your starting point is the Longview Analysis and Reporting dialog.
The appearance of this dialog depends on your role — Report Publisher, Report Author, or Report User.

Report Publishers and Report Authors
If you are a Report Publisher or Report Author, the Longview Analysis and Reporting dialog contains
tabs for Views, Templates, Batches, Links, and Categories.

https://insightsoftware.com/
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Files are listed numerically and alphabetically.

Report Users
If you are a Report User, the Longview Analysis and Reporting dialog contains tabs for Templates and
Batches.

Files are listed numerically and alphabetically.

In this chapter, you can find information on these main topics:

n Understanding file types and dimensions

n Creating templates and DataViews

n Opening templates and DataViews

n Refreshing templates and DataViews

https://insightsoftware.com/
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n Saving templates and DataViews

n Deleting templates and DataViews

Understanding file types and dimensions
In Longview Analysis and Reporting, you can work with various file types.

n report templates (.rtp)

n DataViews (.kdv)

n report batches (.rbt)

While the types of files to which you have access depends on your role in the reporting process, both
report templates and DataViews share some basic common characteristics.

Report templates (rtp)
In Longview Analysis and Reporting, Report Publishers create the report templates that set the general
criteria for the content and format of the reports that Report Users access for their tasks.

All data in report templates is read-only.

When published to the database, Report Users can access the template to run their reports either
individually or in batches. However, they see the template in report view format only.

https://insightsoftware.com/
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Report Users cannot create report templates. They can only view the templates the Report Publisher
has published to the database, in report view format. For more information, see Designing reports.

DataViews (kdv)
In Longview Analysis and Reporting, Report Publishers and Report Authors can create DataViews for
their own analysis purposes.

DataViews are similar to report templates and have the same functionality. However, they cannot be
published to the database, and can only be saved locally.

https://insightsoftware.com/
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All data in DataViews is read-only.

Report batches (rbt)
In Longview Analysis and Reporting, both report templates and DataViews can be viewed and formatted
in report view format.

Note: When Report Users open report templates published by the Report Publisher, they see
the template only in report view format.

https://insightsoftware.com/
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Individually, reports can be printed, or saved as .pdf or .png files.

However, if you have many standard reports that must be run at regular intervals, you can automate the
process using batch files. When a batch file is run, each report in the batch is either printed, or saved as
a .pdf or .png file to a location of your choosing.

For more information, see Working with report batches.

Use and fixed dimensions
Within a report template or DataView, there are two types of dimensions:

n The use dimensions are those that are visible in either the down or across directions of the
template or DataView. You can choose to display as many symbols as you want in these
dimensions. Also, you can have more than one dimension in the down and across directions at
the same time.

n The fixed dimensions are used to complete the database coordinates of the symbols and
data to include in the template. These can contain no more than one symbol at a time.

Inner and outer dimensions
In Longview Analysis and Reporting, you have the option of including more than one dimension in either
the down direction or across direction. For example, if you want to see data for multiple accounts in
multiple entities, you may want to identify multiple dimensions for the down dimension.

If there is more than one dimension in either the down or across directions, the innermost dimension (the
one closest to the data), is called the inner dimension. Each of the others is called an outer
dimension.

The following illustration shows the inner and outer dimensions in the down direction.

https://insightsoftware.com/
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The following illustration shows the inner and outer dimensions in the across direction. The inner across
dimension is the right-most dimension in the list.

https://insightsoftware.com/


23

Creating templates and DataViews
Regardless of whether you are building report templates or DataViews, the common starting point is
called a view.

Notice that initially, there is no file type associated with the view in the title bar.

It is only when you save the view that you must decide what type of file it must be. For example, the
following view has been saved as a report template.

The file’s type is identified by its file name extension (.rtp) in the title bar.

Creating a report template
As Report Publisher, it is your responsibility to create the report templates that are the basis for the
activities of Report Users.

Depending on your role, you may be able to create a report template.

https://insightsoftware.com/
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Role Can perform this task?

Report Publisher yes

Report Author no

Report User no

The procedure you use depends on your starting point.

From the Longview Analysis and Reporting dialog
To create a report template from the Longview Analysis and Reporting dialog, follow these steps.

1. In the Longview Analysis and Reporting dialog, click the Views tab.

2. Choose File > New. A blank view appears.

You are now ready to work with the content and appearance of the template.

3. When you save the file, be sure to save it in report template format. For more information, see
Saving a report template - Report Publishers.

From the view window
To create a report template from a currently open view window, follow these steps.

1. In the view window, do one of the following:

l To create a report template in the current window, choose File > New >Replace this window. A
confirmation dialog may appear asking if you want to save changes to the open view. Click Yes
or No as necessary.

l To create a report template in a different window without closing the open view, choose File >
New > Open in new window.

https://insightsoftware.com/
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2. A blank view appears.

You are now ready to work with the content and appearance of the view.

3. When you save the file, be sure to save it in report template format. For more information, see
Saving a report template - Report Publishers.

Creating a DataView
As Report Publisher or Report Author, you can create local DataViews for your own data analysis and
report requirements.

Depending on your role, you may be able to create a DataView.

Role Can perform this task?

Report Publisher yes

Report Author yes

Report User no

The procedure you use depends on your starting point.

From the Longview Analysis and Reporting dialog
To create a DataView from the Longview Analysis and Reporting dialog, follow these steps.

https://insightsoftware.com/
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1. In the Longview Analysis and Reporting dialog, click the Views tab.

2. Choose File > New. A blank view appears.

You are now ready to work with the content and appearance of the view.

3. When you save the file, be sure to save it in DataView format. For more information, see Saving a
DataView.

From the view window
To create a DataView from a currently open view window, follow these steps.

1. In the view window, do one of the following:

l To create a DataView in the current window, choose File > New > Replace this window. A
confirmation dialog may appear asking if you want to save changes to the open view. Click Yes
or No as necessary.

l To create a DataView in a different window without closing the open view, choose File > New >
Open in new window.

https://insightsoftware.com/
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2. A blank view appears.

You are now ready to work with the content and appearance of the view.

3. When you save the file, be sure to save it in DataView format. For more information, see Saving a
DataView.

Opening templates and DataViews
The types of files you can open in Longview Analysis and Reporting depend on your role.

Role Can perform this task?

Report Publisher
Yes, either the local version or the published version. If you open the

published version, the local version is created automatically.

Report Author Yes. Follow the procedure in Opening a report template - Report Authors.

Report User Yes. Follow the procedure in Opening a report template - Report Users.

For more information on types of files, see Understanding file types and dimensions.

Opening a report template - Report Publishers
The procedure you use depends on your starting point.

From the Longview Analysis and Reporting dialog
To open an existing report template from the Longview Analysis and Reporting dialog, follow these
steps.

1. In the Longview Analysis and Reporting dialog, click the Templates tab. A list of existing report
templates appears.

https://insightsoftware.com/
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Files are listed numerically and alphabetically.

2. To see all your existing templates, select Any Group in the Templates published to field.

3. Select the report template to open and choose File > Open. The report template appears.

From the view window
Only Report Publishers and Report Authors can open a report template from the view window.

To open an existing report template from a view window, follow these steps.

1. In the view window, choose File > Open. If you have any unsaved changes in the view currently
open, a confirmation dialog appears prompting you to save those changes.

https://insightsoftware.com/
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2. Click Yes or No as desired. The Open dialog appears.

3. Complete these fields:

Field Description

Look in Select the folder containing the view you want to open. The default is the reporting
folder.

Files of
type Select Report Template (*.rtp). A list of existing report templates appears.

File name Select the report template from the list.

4. Click Open. The report template appears.

Opening a report template - Report Authors
Depending on your role, you may be able to open report templates.

Role Can perform this task?

Report Publisher
Yes. Follow the procedure in Opening a report template • Report

Publishers.

Report Author Yes, to access published templates.

Report User Yes. Follow the procedure in Opening a report template • Report Users.

For more information on types of files, see Understanding file types and dimensions.

To open a published report template, follow these steps.

1. In the Longview Analysis and Reporting dialog, click the Templates tab. A list of report templates
published to your group appears.
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Files are listed numerically and alphabetically.

2. Select the report template to open and choose File > Open.

l If symbols have already been selected for each dimension in the template, the template
appears.

l If there are currently no symbols selected in one or more of the dimensions, the Symbol
Selection dialog appears. Proceed to step 3.
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3. Complete the following:

Field Description

Available
Symbols and
Selected
Symbols

Find symbols in the Available Symbols list and click the arrow to move them to the
Selected Symbols list. You may select as many symbols as necessary.

If you want to prompt Report Users or Input Contributors to select symbols for a
particular dimension (for example, an entity) when they open the template, do not
select a symbol for that dimension. You must remember however, to make sure
users are allowed to select symbols for that dimension when you publish the
template.

You can change the order of the symbols in the Selected Symbols list. Simply
click and hold, and then drag the symbol to its desired place.

Depending on how your system is set up, Publishers may have the ability to
select attributes instead of symbols. These attributes can be used to automate
the selection of specified symbols in the templates that Report Users have access
to.

4. You can search for symbols in several ways:

To search Do this

Through the
hierarchy

Click on symbol names in the hierarchy to drill down to the appropriate symbol.
Parent symbols that you can expand, and collapse are identified by a grey
circle beside them.

By name
Start to type its name in the Search field. (You do not have to worry about case-
sensitivity.) The application finds the first symbol whose name contains the
letters you typed. To find the next occurrence, click Find Next.

By description

Select By Description and start to type its description in the Search field. (You
do not have to worry about case-sensitivity.) The application finds the first
symbol whose description contains the letters you typed. To find the next
occurrence, click Find Next.

5. Click OK. If there are more dimensions for which symbols have not been selected, the Symbol
Selection dialog reappears. Repeat step 3 to step 5 for each dimension you are prompted to select
symbols for. When you are finished selecting symbols, the report template appears.

Opening a report template - Report Users
Depending on your role, you may be able to open report templates.
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Role Can perform this task?

Report Publisher Yes. Follow the procedure in Opening a report template - Report Publishers.

Report Author Yes. Follow the procedure in Opening a report template - Report Authors.

Report User Yes, to access published templates in report view format.

For more information on types of files, see Understanding file types and dimensions.

To open an existing report template, follow these steps.

1. In the Longview Analysis and Reporting dialog, click the Templates tab. A list of report templates
published to your group appears.

Files are listed numerically and alphabetically.

2. Select the report template to open and choose File > Open.

l If you are not allowed to select any symbols in the report, the report appears. You can proceed
to analyze the data and print the report. For more information, see Designing reports.

l If you are allowed to select symbols in the report, but symbols have already been selected for
each dimension, the report appears. You can proceed to analyze the data and print the report.
For more information, see Designing reports.

l If you are allowed to select symbols for your report, and there are currently no symbols
selected in one or more of the dimensions, the Symbol Selection dialog appears. Proceed to
step 3.
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3. Complete the following:

Field Description

Available
Symbols
and
Selected
Symbols

Find symbols in the Available Symbols list and click the arrow to move them to the
Selected Symbols list. You may select as many symbols as necessary.

If you want to prompt Report Users or Input Contributors to select symbols for a
particular dimension (for example, an entity) when they open the template, do not select
a symbol for that dimension. You must remember however, to make sure users are
allowed to select symbols for that dimension when you publish the template.

You can change the order of the symbols in the Selected Symbols list. Simply click and
hold, and then drag the symbol to its desired place. Depending on how your system is
set up, Publishers may have the ability to select attributes instead of symbols. These
attributes can be used to automate the selection of specified symbols in the templates
that Report Users have access to.

4. You can search for symbols in several ways:

To search Do this

Through
the
hierarchy

Click on symbol names in the hierarchy to drill down to the appropriate symbol. Parent
symbols that you can expand, and collapse are identified by a grey circle beside them.

By name
Start to type its name in the Search field. (You do not have to worry about case-
sensitivity.) The application finds the first symbol whose name contains the letters you
typed. To find the next occurrence, click Find Next.
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To search Do this

By
description

Select By Description and start to type its description in the Search field. (You do not
have to worry about case-sensitivity.) The application finds the first symbol whose
description contains the letters you typed. To find the next occurrence, click Find
Next.

5. Click OK. If there are more dimensions for which symbols have not been selected, the Symbol
Selection dialog reappears. Repeat step 3 to step 5 for each dimension you are prompted to select
symbols for.

6. When you are done selecting symbols, the report template appears. You can proceed to analyze
the data and print the report. For more information, see Designing reports.

Opening a DataView
Depending on your role, you may be able to open DataViews.

Role Can perform this task?

Report Publisher yes

Report Author yes

Report User no

For more information on types of files, see Understanding file types and dimensions.

To open an existing DataView from the Longview Analysis and Reporting dialog, follow these steps.

1. In the Longview Analysis and Reporting dialog, click the Views tab. A list of all your locally saved
DataViews appears.

Files are listed numerically and alphabetically.

2. Select the DataView to open and choose File > Open. The DataView appears.
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Refreshing templates and DataViews
You can use the refresh features in Longview Analysis and Reporting to ensure that you are viewing and
using the most recently published versions of templates, as well as the most current data in other types
of files.

Refreshing report templates - Report Publishers
You can use the refresh feature to restore the content of the local version of a report template with the
most recently published version of the file.

For example, let’s say you publish a report template to the database, and then make changes to your
local copy. If you decide at a later time that you do not want to publish those changes, you may want to
make your local copy match the published one on the database.

You can also refresh just the data content of report templates that you currently have open, on an
individual basis.

Role Can perform this task?

Report Publisher yes

Report Author no

Report User no

Restoring a local report template
To restore the structure and content of a local report template, so that it matches the currently published
version, follow these steps.

1. In the Longview Analysis and Reporting dialog, click the Templates tab.
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2. For Templates published to select the group to which you published the report template, the local
version of which you want to restore. A list of report templates published to that group appears. For
a list of all report templates, select Any group.

3. Do one of the following:

l To restore all local report templates that have been published, make sure none of the
templates in the list is selected (if any template is selected, you can clear it by holding down the
Ctrl key and clicking it), and choose Tools > Refresh Data. A confirmation dialog appears.

Click Yes. The local versions of all published report templates are restored to show the content
of the published versions.

l To restore a single local report template, select it in the list and choose Tools > Refresh Data.
The local version of the template is restored to show the content of the published version.

Refreshing the data content of an open report template
To refresh the data content of a report template while it is open, choose Tools >Refresh Data. The data
content of the template is refreshed.

Refreshing report templates - Report Publishers
You can use the refresh feature to restore the content of the local version of a report template with the
most recently published version of the file.

For example, let’s say you publish a report template to the database, and then make changes to your
local copy. If you decide at a later time that you do not want to publish those changes, you may want to
make your local copy match the published one on the database.

You can also refresh just the data content of report templates that you currently have open, on an
individual basis.

Role Can perform this task?

Report Publisher yes

Report Author no

Report User no

Restoring a local report template
To restore the structure and content of a local report template, so that it matches the currently published
version, follow these steps.
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1. In the Longview Analysis and Reporting dialog, click the Templates tab.

2. For Templates published to select the group to which you published the report template, the local
version of which you want to restore. A list of report templates published to that group appears. For
a list of all report templates, select Any group.

3. Do one of the following:

l To restore all local report templates that have been published, make sure none of the
templates in the list is selected (if any template is selected, you can clear it by holding down the
Ctrl key and clicking it), and choose Tools > Refresh Data. A confirmation dialog appears.

Click Yes. The local versions of all published report templates are restored to show the content
of the published versions.

l To restore a single local report template, select it in the list and choose Tools > Refresh Data.
The local version of the template is restored to show the content of the published version.

Refreshing the data content of an open report template
To refresh the data content of a report template while it is open, choose Tools >Refresh Data. The data
content of the template is refreshed.
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Refreshing report templates - Report Authors
You can use the refresh feature to refresh the structure and content of all report templates published to
your group. You can also refresh just the data content of report templates that you currently have open,
on an individual basis.

Role Can perform this task?

Report Publisher no

Report Author yes

Report User no

Refreshing all published report templates
You can use the refresh feature to refresh the structure and content of all report templates published to
your group. This ensures that you are accessing the most recently published versions of those
templates.

To refresh the structure and content of all report templates published to your group, follow these steps.

1. In the Longview Analysis and Reporting dialog, click the Templates tab.

2. Choose File > Refresh. A confirmation dialog appears.

3. Click Yes. All report templates published to your group are refreshed.

Refreshing the data content of an open report template
To refresh the data content of a report template while it is open, choose Tools >Refresh Data. The data
content of the template is refreshed.
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Refreshing report templates - Report Users
You can use the refresh feature to refresh the structure and content of all report templates published to
your group. This ensures that you are accessing the most recently published versions of those
templates.

Role Can perform this task?

Report Publisher no

Report Author no

Report User yes

To refresh the structure and content all report templates published to your group, follow these steps.

1. In the Longview Analysis and Reporting dialog, click the Templates tab.

2. Choose File > Refresh. A confirmation dialog appears.

3. Click Yes. All report templates published to your group are refreshed.

Refreshing DataViews
You can refresh the data content of an open DataView so that it displays the most current database
data.

To refresh the data content of an open DataView, choose Tools > Refresh Data. The data content of the
DataView is refreshed.
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Saving templates and DataViews
While you are working on a view, or when you are finished, you can save it. You can save it in several
different formats, depending on the component you are using and your role.

Saving a report template - Report Publishers
You can save a report template locally before publishing it to the database. When you save a template
for the first time, you are prompted to define the dimensions in which users can select and drill into the
symbols in the published report.

Role Can perform this task?

Report Publisher yes

Report Author no

Report User no

To save a view in report template format, follow these steps.

1. In the view, do one of the following:

l Choose File > Save.

l To save an existing template using a different name, choose File > Save As. The Save dialog
appears

2. Complete these fields:

Field Description

Save in Select the folder in which you want to save the template. The default is the reporting
folder.

Files of
type Select Report Template (*.rtp).

File name Type a name for the template.
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3. Click Save. If you have not saved the template before, the Select Frozen Dimensions dialog
appears.

4. For each dimension listed, complete these fields:

Field Description

Frozen Select this field to specify that the dimension is frozen or clear this field to allow Report
Users to select the symbols for this dimension in the template.

Drillable
If Frozen is cleared for this dimension, this field is automatically selected and cannot
be cleared. Select this field to allow Report Users to drill into the symbol hierarchies in
this dimension in the template.

Available
Symbols

This field is available only if Frozen is cleared for this dimension. This field is
unavailable for Schedule dimensions.

Click the symbol selector button ( ... ) and use the Available Symbol Selection dialog
to specify the symbols that are available to Report Users in the Symbol Selections
dialog in the template.

If you do not specify any symbols for this field, all symbols that Report Users have
access to in the dimension are available.

Note: The symbols specified for this field should include the symbols
selected for the template in Specifying orientation and symbols in a
template. If a symbol is selected in the template and is not specified as an
available symbol, Report Users cannot reselect it if they remove it in the
Symbol Selections dialog.

Resolution
Depth

This field is available only if Frozen is selected for this dimension. Specify the number
of levels to go down in the hierarchy until a symbol the Report User has access to is
reached. This number is only applicable when a template is set to use a symbol above
the Report User’s access in the hierarchy. This number may be entered manually
(valid values are from 0 to 99) or can be selected by clicking the cell and selecting the
number from the drop-down list. The default value for this field is 99.

For more information on how these settings affect template behavior, see Editing dimension and
symbol control.

5. Click OK. The template is saved locally on your hard drive.

https://insightsoftware.com/


42

Saving a report template - Report Users
As a Report User, you can access published report templates only in report view format. As such, when
you save a report template, you must save it in either .pdf or .png format.

For more information, see Saving reports.

Saving a DataView
In Longview Analysis and Reporting, while you are working on a view, you may be able to save it in
DataView format.

Role Can perform this task?

Report Publisher yes

Report Author yes

Report User no

To save a view in DataView format, follow these steps.

1. In the view, do one of the following:

l Choose File > Save.

l To save an existing view using a different name, choose File > Save As. The Save dialog
appears.
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2. Complete these fields:

Field Description

Save in Select the folder in which you want to save the DataView. The default is the reporting
folder.

Files of
type Select DataView (.kdv).

File name Type a name for the DataView.

3. Click Save. The DataView is saved.

Saving a file in Excel format
You may be able to export the contents of a view to an Excel worksheet.

Role Can perform this task?

Report Publisher yes

Report Author yes

Report User no

With the view saved in Excel format, you can open it as a worksheet in Microsoft Excel.

To save a view as an Excel worksheet, follow these steps.

1. Hidden symbols, suppressed symbols, and the child symbols of collapsed symbols do not appear in
an Excel worksheet. If you want them to appear in the Excel worksheet, make these symbols visible
before exporting.

2. In the view window, choose Tools > Export to Excel. The Export to Excel - 1 of 3 - Output Format
dialog appears.

Note: If you are working with a report that contains more than 255 columns, the “As
displayed” option is unavailable and the “In PivotTable format” option is selected by
default.
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3. Select one of the following:

Field Description

As
displayed

To display data in the Excel worksheet exactly as it is in the view. If you select this
option, you cannot change the orientation in the Excel worksheet, as you can in the
original view.

In
PivotTable
format

To display data in PivotTable format. This format allows you to create PivotTable
reports in Excel. For more information, see your Microsoft Excel documentation.

4. Click Next. The Export to Excel - 2 of 3 - Filename dialog appears.

5. For Save the file as, type the folder path and file name for the new Excel file, or click Browse to find
an existing file to replace.

6. Click Next. The Export to Excel - 3 of 3 - Launch Excel dialog appears.

7. For Open in Excel Now, do one of the following:

l To open the Excel worksheet you have just created, select this field.

l To save the Excel worksheet without opening it right now, clear this field.

8. Click Finish. Depending on your selection in step 7, the view or the Excel worksheet appears.

Deleting templates and DataViews
The types of files you can delete in Longview Analysis and Reporting depend on your role.

Deleting a report template
Depending on your role, you may be able to delete report templates when they are no longer useful.
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Role Can perform this task?

Report Publisher yes

Report Author no

Report User no

Caution: If you follow this procedure, you cannot reverse your decision. Use with caution.

If you delete a published template without unpublishing first, you delete the copy on your local drive, but
not the one on the application database. To completely delete a template, you must also unpublish it,
before or after you delete the local copy.

The procedure you use depends on your starting point.

From the Longview Analysis and Reporting dialog
To delete a report template from the Longview Analysis and Reporting dialog, follow these steps.

1. In the Longview Analysis and Reporting dialog, click the Templates tab. A list of existing report
templates appears.

2. To see all your existing templates, select Any Group in the Templates published to field.

3. Select the template you want to delete.

4. Press the Delete key. A confirmation dialog appears.

5. Click OK. The local copy of the template is deleted.

From Windows Explorer
If the Longview Analysis and Reporting dialog is not open, you can delete a report template in Windows
Explorer as you would any other file.
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Deleting a DataView Depending on your role, you may be able to delete DataViews when they are no
longer useful.

Role Can perform this task?

Report Publisher yes

Report Author yes

Report User no

The procedure you use depends on your starting point.

From the Longview Analysis and Reporting dialog
To delete a DataView from the Longview Analysis and Reporting dialog, follow these steps.

1. In the Longview Analysis and Reporting dialog, click the Views tab. A list of all your locally saved
DataViews appears.

Files are listed numerically and alphabetically.

2. Select the DataView to delete.

3. Press the Delete key. A confirmation dialog appears.

4. Click OK. The DataView is deleted.

From Windows Explorer
If the Longview Analysis and Reporting dialog is not open, you can delete a DataView in Windows
Explorer as you would any other file.
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Working with Data Content
In the application, a Report Publisher prepares the templates that specify the content and format of the
templates and reports that are accessed by other users.

In this section, you can find information on these main topics:

n Specifying default settings

n Specifying orientation and symbols in a template

n Changing symbol content in a template or view

n Expanding and collapsing hierarchies

n Working with conditions

n Adding calculated rows and columns

n Working with range calculations

n Editing symbol formats

n Hiding symbols

n Adjusting spacing with blank symbols

n Adding links to a template

Specifying Default Settings
When you create a new view, certain default settings and formats are used. Depending on your role, you
may be able to change these settings and formats.

Specifying general settings
When a new view is created, certain default options are used for:

n the size of the view windows

n the type of symbol information and data to display

You may be able to change these options.

Role Can perform this task?

Report

Publisher

Yes, to create report views for data analysis and report templates for reporting

purposes.

Report Author Yes, to create report views for data analysis.

Report User No.
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To change default options, follow these steps.

1. In the view window, choose Tools > Options. The Options dialog appears, with the General tab in
view.

2. Complete these fields:

Field Description

Initial Window
Size

Select a window size, as a percentage of the screen size. This setting also
applies to the initial size of the published reports and templates opened by
Contributors.

Adjust Column
Widths

You can choose to have column widths adjust automatically to the size of the
largest number in each column. Do one of the following:

n To allow the column widths to adjust automatically, select this field.

n Otherwise, leave this field empty.

Specify Width -
enter value
below

Enter a percent (whole numbers only) of the window width for the width of
columns.

Wrap Text If you want text to wrap to the width of columns, select this option.

https://insightsoftware.com/


49

3. Click the Display tab.

4. For each dimension in the Longview database, select the type of symbol information to view. You
can choose to see symbol names, symbol descriptions, or both.

5. Click the Schedule tab.

6. Select whether you want the name or description of the schedule, or both, displayed when viewing
schedule information in your views. For more information, see Including schedule data.
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7. Click the Data tab.

8. Complete these fields:

Field Description

Adjusted

Do one of the following:

n To allow users to view data adjusted by journal entries (JEs), select this field.
(This is the most commonly used option.)

n To allow users to view unadjusted data, leave this field empty.
For more information, see Including unadjusted, adjustment, and total adjusted data.

Show as
Virtual
Dimension

Select this field to compare unadjusted, adjustment, and total adjusted data in the
template or report view. Before you can select this option, Adjusted must be selected.
As well, you cannot have a schedule selected in the view.

For more information, see Including unadjusted, adjustment, and total adjusted data.

9. Click OK. The view window appears.

Including schedule data
In the application, a schedule is the concept of one or more extra dimensions, associated with
designated symbols that allow you to store additional information about particular cells in the Longview
database.

Your Longview system may contain schedules for many purposes; for example, to provide extra detail
about intercompany transactions, taxes, inventory, property, plant, and equipment information, and
meals and entertainment expenses.

Your Longview system already contains the schedule definitions that allow you to include, view, and
enter schedule data. You can include, and view schedule data in your templates, and DataViews. Each
view can include only one schedule at a time. Base and schedule data cannot coexist in the same report
view or template, unless you follow the steps outlined in this section.

Depending on your role, you may be able to include schedule data in templates and report views.

https://insightsoftware.com/


51

Role Can perform this task?

Report

Publisher

Yes, to create report views for data analysis and report templates for reporting

purposes.

Report Author Yes, to create report views for data analysis.

Report User
No. Users have access only to the schedules defined by the Publisher for the

template.

To include schedule data in your report view or template, follow these steps.

1. In the view, for Schedule, select the schedule you want to include. Dimension buttons for each
schedule dimension as well as a button labelled Schedule appear, in a separate dimension bar.

Note: If dimension orientation and symbol selection were defined before selecting a
schedule, that orientation is lost when each dimension is moved to the fixed dimension
position. Fixed dimensions can only contain one symbol. If there were down or across
dimensions containing more than one symbol, you are prompted to redefine your symbol
selections so that each dimension contains only one symbol.

2. Click a schedule dimension button (not the button labeled Schedule). The Symbol Selection dialog
appears, displaying the symbols in that schedule dimension.
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3. Select the schedule symbols you want to appear in the view and move them to the Selected
Symbols field.

4. Click OK. The view appears.

5. Repeat step 2 to step 4 for each schedule dimension in the view.

Caution: If you select symbols for line-item detail comments or line-item detail values,
make sure you select the related time period. Selecting the wrong time period symbol
could result in mismatched data.

6. When you are finished selecting symbols, click OK. The view appears.

7. Define the orientation of the dimensions as desired. When you are finished the view may look like
this:
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Note: If you report on the CDate symbol for the VComments schedule, the comment date
is displayed in international format for the time zone of the application server.

8. You can proceed to Comparing base and schedule data.

Comparing base and schedule data
You can compare base data and schedule data in your templates, and DataViews.

For example, the following illustration shows a simple comparison between base and schedule data for
the Cash account.

Depending on your role, you may be able to compare base and schedule data.

Role Can perform this task?

Report Publisher Yes, to create views for data analysis and report templates for reporting purposes.
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Role Can perform this task?

Report Author Yes, to create views for data analysis.

Report User No.

To compare base and schedule data, follow these steps.

1. Define the view as described in Including schedule data.

2. Drag and drop the Schedule button to the down or across directions of the view.

3. Click the Schedule button. The Symbol Selection dialog appears.

4. Move the BASEDATA symbol to the Selected Symbols field. By default, SCHEDDATA data is
already selected.
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5. Click OK. The view appears showing both base and schedule data.

When working with templates or views containing both base and schedule data, base data is always
read-only and can be used for comparison purposes only.

Including unadjusted, adjustment, and total adjusted data
You can choose to view three variations of your data: Unadjusted, Adjustment, and Total Adjusted data.

In the Data tab of the Options dialog, as described in step 8, the Show as Virtual Dimension field is
available only when the Adjusted field is selected.

When the Show as Virtual Dimension field is selected, a virtual dimension called Adjustment appears in
the dimension bar. The Adjustment dimension contains three symbols: Unadjusted (child), Adjustments
(child), and Adjusted (parent of Unadjusted and Adjustments).

The virtual Adjustment dimension behaves like a light version of a regular dimension. You can do most
things that you can with regular dimensions, with the following exceptions:
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n You cannot add, edit, or delete calculated symbols.

n You cannot add, edit, or delete blank symbols.

n You cannot hide symbols.

n Frozen and drillable options do not apply to the Adjustment dimension. This dimension is
drillable and non-frozen at all times to all users.

Specifying number formats
When a new view is created, certain default settings for number formats are used. You may be able to
change these settings.

Role Can perform this task?

Report

Publisher

Yes, to create report views for data analysis and report templates for reporting

purposes.

Report Author Yes, to create report views for data analysis.

To change number formats, follow these steps.

1. In the view window, choose Format > Number. The Number Format dialog appears.

Note: If you are working in Longview Analysis and Reporting, the Rules section does not
appear in this dialog.
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2. Complete these fields:

Field Description

Use
parentheses

Do one of the following:

n To display negative numbers enclosed in parentheses, select this field.

n To display negative numbers with a minus sign, leave this field empty.

Use 1000
Separator

Do one of the following:

n To display commas as thousands separators, select this field.

n To display numbers without thousands separators, leave this field empty.

Scaling

Select a scaling factor for all numbers in the template. Scaling refers to the format in
which the data appears. For example, if you are dealing with very large numbers,
you may want to view numbers in thousands or millions. Scaling makes the numbers
easier to read.

For example, to view the number “10,000” as “10”, select 000s to specify that all
numbers appear in thousands.

You can set the scaling of individual symbols and cells as well. For more
information, see Editing symbol formats and Editing cell formats.

Decimals

Select the number of decimal places for all symbols in the template. The results of
allocation calculations are rounded up to the precision you select here.

You can set the decimal settings of individual symbols and cells as well. For more
information, see Editing symbol formats and Editing cell formats.

3. Click Apply to see the changes before exiting this dialog.

4. When you are finished, click OK. The view window appears.

Specifying color and font formats
When a new view is created, certain default color and font settings are used. You may be able to change
these settings.

Role Can perform this task?

Report

Publisher

Yes, to create DataViews for data analysis and report templates for reporting

purposes.

Report Author Yes, to create DataViews for data analysis.

Report User No.

To change color and font settings, follow these steps.
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1. In the view window, choose Format > Color. The Set Color Preferences dialog appears.

2. For Dimension, select a dimension that appears in either the down or across directions of the view,
and then select a color in which to display the symbols in that dimension.

3. Repeat step 2 for each dimension in the down or across direction for which you want to define a
color.

4. In the top left drop-down list in the Data section, select one of the following:

Data Description

Default To specify the default color and font formats for all data in Longview Analysis and
Reporting.

Leaves
To specify the color and font formats for leaf rows only. If there is more than one
down dimension, the color applies to the leaf symbols in the inner down dimension
only.

Calculations To specify the color and font formats for calculated data. The color applies to
calculated symbols in the down and across directions.

Totals
To specify the color and font formats for totals data (rows only). If there is more than
one down dimension, the color applies to the parent symbols in the inner down
dimension only.

5. Do one of the following:

l If you want to use the defaults, proceed to step 10.

l If you do not want to use the defaults, clear the Use Default Font field. The other fields become
active. Proceed to step 6.
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6. Complete these fields. For each, select Use Default to return to the default setting.

Field Description

Foreground Select a color for your selection in step 4. This setting overrides the default setting.
Font Select a font for your selection in step 4. This setting overrides the default setting.

Font Style Select a font style for your selection in step 4. This setting overrides the default
setting.

Size Select a font size for your selection in step 4. This setting overrides the default
setting.

7. Repeat step 4 and step 6 as required, for each type of data listed in step 4.

8. You can apply different colors to alternating rows, to distinguish between them. To do so, do the
following:

a. For Background, select Primary.

b. In the drop-down list in the middle, select either Row or Column.

c. In the drop-down list on the right, select the color to use for the primary rows or columns.

d. For Background, select Alternating.

e. In the drop-down list in the middle, select either Row or Column.

f. In the drop-down list on the right, select the color to use for the alternating rows or columns.

9. Click Apply to see the changes before exiting this dialog.

10. When you are finished, click OK. The view window appears.

Adjusting column widths
When a new view is created, default settings for columns are used. You can make column widths adjust
automatically to the size of the largest number in each column.

Role Can perform this task?

Report Publisher Yes, to create views for data analysis and report templates for reporting purposes.

Report Author Yes, to create views for data analysis.

Report User No.

Manually

You can manually change column widths in two ways:

n Place the cursor just under the across symbol whose column width you want to adjust so that
the double-sided arrow appears, and then drag the column to the desired width.

n Follow these steps:

a. In the view window, choose Tools > Options. The Options dialog appears, with the General
tab in view.
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b. Make sure the Adjust Column Widths field is disabled. For more information, see
Specifying general settings.

c. Click OK. The view appears.

d. Choose Format > Column > Auto-size Columns. All columns in the template are adjusted
to the size of the largest number in each column.

Note: When you manually adjust column widths, those settings are not saved when you save
the template.

Automatically

To have column widths adjust automatically to the size of the largest number in each column every time
you open a file, follow these steps.

1. In the view window, choose Tools > Options. The Options dialog appears, with the General tab in
view.
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2. Make sure the Adjust Column Widths field is selected. For more information, see Specifying general
settings.

3. Click OK. The view appears.

Specifying Orientation and Symbols In A
Template
When a new view is created, the Report Publisher must specify the orientation and symbols for each
dimension in the database. The root symbol is the top hierarchy symbol that can be accessed in a
particular situation.

You may be able to specify orientation and symbols.

Role Can perform this task?

Report

Publisher

Yes, to create DataViews for data analysis and report templates for reporting

purposes.

Report Author Yes, to create DataViews for data analysis.

Report User No.

In many organizations, a report template contains the same symbols for every Report User, except for
one or two dimensions, where each user works with his or her own area of responsibility, typically an
entity. If this is the situation at your company, leave the symbol selection empty for that dimension, so
that users must select their own entities when they first open the template.

When you create a view for the first time, you should probably follow the procedure in Specifying
orientation and symbols - Basic method.
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Afterwards, you may prefer to use the procedure in Specifying orientation and symbols • Advanced
method.

Specifying orientation and symbols - Basic method
To specify orientation and symbols, follow these steps.

1. In the view window, choose Format > Orientation. The Orientation dialog appears.

2. For Dimension, select each dimension you want to appear in the down direction, and click Add
Down. (You can select more than one by holding down the Ctrl key on your keyboard while making
your selections.) The dimension names move to the Down field.

3. For Dimension, select each dimension you want to appear in the across direction, and click Add
Across. (You can select more than one by holding down the Ctrl key on your keyboard while making
your selections.) The dimension names move to the Across field.
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4. Click OK. The Symbol Selection dialog appears.

In this dialog, you are prompted to select symbols for the down and across dimensions, in the order
in which those dimensions are indexed in the database.

5. Complete the following:

Field Description

Available
Symbols
and
Selected
Symbols

Find symbols in the Available Symbols list and click the arrow to move them to the
Selected Symbols list. You may select as many symbols as necessary.

If you want to prompt Report Users to select symbols for a particular dimension (for
example, an entity) when they open the template, do not select a symbol for that
dimension. You must remember however, to make sure users are allowed to select
symbols for that dimension when you publish the template.

You can change the order of the symbols in the Selected Symbols list. Simply click and
hold, and then drag the symbol to its desired place.

Depending on how your system is set up, Publishers may have the ability to select
attributes instead of symbols. These attributes can be used to automate the selection
of specified symbols in the templates that Report Users have access to. For more
information, see Using attributes to automate symbol selection.

Note: To use the value of a floating time period, navigate through the time periods
hierarchy in the Available Symbols list, and double-click a floating time period (indicated
by an asterisk) to select it. For more information, see Using floating time period symbols.
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6. Click OK. If there are more dimensions designated to the down or across directions, the Symbol
Selection dialog reappears. Repeat step 4 and step 5, for each dimension you are prompted to
select symbols for.

7. When you are done selecting symbols for the down and across dimensions, the view window
appears.

8. At this point, you have selected symbols only for the dimensions in the down and across positions.
Now you can do so for the fixed dimensions as well. Choose Edit > Symbol Selections. The Symbol
Selection dialog appears.
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9. Select each of the other dimensions in turn and select one symbol for each.

If you want to prompt Report Users to select symbols for a particular dimension (for example, an
entity) when they open the template, do not select a symbol for that dimension. You must remember
however, to make sure users are allowed to select symbols for that dimension when you publish the
template.

Depending on how your system is set up, Publishers may have the ability to select attributes instead
of symbols. These attributes can be used to automate the selection of specified symbols in the
templates that Report Users have access to. For more information, see Using attributes to automate
symbol selection.

Note: For fixed dimensions, you can select one symbol only. Typically, you would select
an entity, a currency, and the Dim#Set symbols for the remaining dimensions.

10. When you are finished, click OK. The view window appears.

You can see the symbols for the fixed dimensions in the status bar at the bottom of the window.

Specifying orientation and symbols - Advanced method
To specify orientation and symbols, follow these steps.

1. In the view window, click and drag a dimension button to the box just above the down column.
(Typically, you would select your ACCOUNTS dimension.) A small black arrow appears to indicate
the correct position.
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2. As soon as you release your mouse button, the Symbol Selection dialog appears.
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3. Complete the following:

Field Description

Available
Symbols
and
Selected
Symbols

Find symbols in the Available Symbols list and click the arrow to move them to the
Selected Symbols list. You may select as many symbols as necessary.

If you want to prompt Report Users to select symbols for a particular dimension (for
example, an entity) when they open the template, do not select a symbol for that
dimension. You must remember however, to make sure users are allowed to select
symbols for that dimension when you publish the template.

You can change the order of the symbols in the Selected Symbols list. Simply click and
hold, and then drag the symbol to its desired place.

Depending on how your system is set up, Publishers may have the ability to select
attributes instead of symbols. These attributes can be used to automate the selection
of specified symbols in the templates that Report Users have access to. For more
information, see Using attributes to automate symbol selection.

4. Click OK. Depending on the type of template, the dialog may reappear prompting you to select time
period symbols. If so, repeat step 2 and click OK.

Note: To use the value of a floating time period, navigate through the time periods
hierarchy in the Available Symbols list, and double-click a floating time period (indicated
by an asterisk) to select it. For more information, see Using floating time period symbols.

The view window appears.

5. Repeat step 1 to step 4 for any other down dimension, if applicable.

6. In the view window, click and drag a dimension button to the box just below the dimension bar.
(Typically, you would select your TIMEPER dimension.) A small black arrow appears to indicate the
correct position.
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7. As soon as you release your mouse button, the Symbol Selection dialog appears.
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8. Complete the following:

Field Description

Available
Symbols
and
Selected
Symbols

Find symbols in the Available Symbols list and click the arrow to move them to the
Selected Symbols list. You may select as many symbols as necessary.

If you want to prompt Report Users to select symbols for a particular dimension (for
example, an entity) when they open the template, do not select a symbol for that
dimension. You must remember however, to make sure users are allowed to select
symbols for that dimension when you publish the template.

You can change the order of the symbols in the Selected Symbols list. Simply click and
hold, and then drag the symbol to its desired place.

Depending on how your system is set up, Publishers may have the ability to select
attributes instead of symbols. These attributes can be used to automate the selection
of specified symbols in the templates that Report Users have access to. For more
information, see Using attributes to automate symbol selection.

9. At this point, you have selected symbols only for the dimensions in the down and across positions.
Now you can do so for the fixed dimensions as well.

10. Click on a dimension button in the fixed dimension bar. The Symbol Selection dialog appears, with
the dimension you selected displayed in the Dimension field.
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11. Complete the following:

Field Description

Available
Symbols
and
Selected
Symbols

Find symbols in the Available Symbols list and click the arrow to move them to the
Selected Symbols list. You may select as many symbols as necessary.

If you want to prompt Report Users to select symbols for a particular dimension (for
example, an entity) when they open the template, do not select a symbol for that
dimension. You must remember however, to make sure users are allowed to select
symbols for that dimension when you publish the template.

You can change the order of the symbols in the Selected Symbols list. Simply click and
hold, and then drag the symbol to its desired place.

Depending on how your system is set up, Publishers may have the ability to select
attributes instead of symbols. These attributes can be used to automate the selection
of specified symbols in the templates that Report Users have access to. For more
information, see Using attributes to automate symbol selection.

Note: For fixed dimensions, you can select one symbol only. Typically, you would select
an entity, a currency, and the Dim#Set symbols for the remaining dimensions.

12. Click OK. The view window appears.

13. Repeat step 10 to step 12 for each remaining fixed dimension. When you are finished, the view
window may look like this.

You can see the symbols for the fixed dimensions in the status bar at the bottom of the view window.

Using attributes to automate symbol selection
Depending on how your system is set up, Publishers may have the ability to select attributes instead of
base and schedule symbols when defining the symbol content of templates. These attributes can be
used to automate the selection of specified symbols in the templates that Report Users have access to.
This is useful in minimizing potential mistakes made by users. As well, the number of templates that
must be created for the various types of users can be reduced.
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The following scenarios illustrate typical usage. For more information, see your System Administrator or
your Professional Services representative.

Usage Example

To make symbol selections in the ACCOUNTS

dimension automatic based on a user’s user

group or user ID.

Group 1 needs access to the Total revenue
accounts, but Group 2 needs access to the Total cost
of revenue accounts.

Both groups can use the same template. Only the
appropriate symbols appear for each group.

To make symbol selections in the ACCOUNTS

dimension automatic based on a user’s user

group or user ID.

Group 1 needs access to the Total revenue
accounts, but Group 2 needs access to the Total cost
of revenue accounts.

Both groups can use the same template. Only the
appropriate symbols appear for each group.

In each case, the Publisher can select the appropriate attribute in the Symbol Selection dialog.

If the Publisher selects an attribute whose value is dependent on the symbol selection in another
dimension, the Source Dimension Selection dialog appears.
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In this dialog, the Publisher can select the defining dimension.

Publishers must work closely with the System Administrator to ensure that these attributes are properly
defined.

Using floating time period symbols
In the application, you can use floating time period symbols in templates and views.

If you have many standard reports that you want to reuse in the next calendar month or fiscal year, you
can use floating time period symbols in these reports. Floating time periods are updated during a
rollover. To ensure that you are using the correct year and month in your report templates, you can use
floating time periods instead of regular time periods.

For example, let’s say you have 100 reports containing 2009 time period symbols, and you want to use
these same reports in the year 2010. If you used regular time period symbols, you would have to go into
each of these reports and manually change the time period symbols from 2009 to 2010. However, if you
use floating time periods, the symbols update automatically when the database is rolled over to the next
year.

When you prepare a report, you select time period symbols in the Symbol Selection dialog. You have
the option of selecting either regular time period symbols or floating time period symbols.
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An asterisk appears with the symbol name to identify it as a floating time period symbol.

Changing Symbol Content In A Template Or
View
You may from time to time, want to change the symbol selections in your templates, and DataViews.

If you are a Report Publisher, or Report Author, you can change the symbol selection for any
dimensions in your templates and DataViews at any time.

Depending on your role, you may be able to perform this task.
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Role Can perform this task?

Report Publisher
Yes, to create DataViews for data analysis and report templates for reporting

purposes.

Report Author Yes, to create DataViews for data analysis.

Report User No.

When you select symbols for the first time, you should follow the procedure in Changing symbol content
- Basic method.

Afterwards, you may prefer to use the procedure in Changing symbol content - Advanced method.

Changing symbol content - Basic method
To change symbols for a dimension, follow these steps.

1. In the view window, choose Edit > Symbol Selections. The Symbol Selection dialog appears.

2. For Dimension, select the dimension containing the symbols to select.
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3. Complete the following:

Field Description

Available
Symbols
and
Selected
Symbols

Find symbols in the Available Symbols list and click the arrow to move them to the
Selected Symbols list.

If you want to prompt Report Users to select symbols for a particular dimension (for
example, an entity) when they open the template, do not select a symbol for that
dimension. You must remember however, to make sure users are allowed to select
symbols for that dimension when you publish the template.

For the down and across dimensions, you may select more than one symbol. For other
dimensions, only one symbol is allowed.

You can change the order of the symbols in the Selected Symbols list. Simply click
and hold, and then drag the symbol to its desired place.

4. When you are finished, click OK. The view window appears.

Changing symbol content - Advanced method
To change symbols for a dimension, follow these steps.

1. In the view window, click a dimension button, located just below the toolbar.
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2. The Symbol Selection dialog appears, with the dimension you selected in the Dimension field.

3. Complete the dialog, as described in step 2 to step 4 of Changing symbol content - Basic method.

Expanding And Collapsing Hierachies
You can expand and collapse hierarchies in the down and across dimensions of a template, or
DataView, by clicking the plus and minus signs beside parent symbols.

However, you can also choose a menu command to expand a selected parent symbol to show every
level of symbol detail within it. For example:

You can also choose a menu command to display one level of detail within each occurrence of a
selected parent symbol.
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For example, if you have two outer dimension symbols, each inner dimension symbol occurs twice. You
can expand each occurrence of the same parent symbol in the down or across dimensions to show one
level of detail below the selected parent. For example:

Expanding hierarchies
To expand hierarchies in a template, or DataView, follow these steps.

1. Right-click a parent symbol. A pop-up menu appears.

2. Do one of the following:

l Click the Expand All For Selected Symbol icon. The hierarchy expands to show all symbols
within the selected parent symbol, but only for the selected occurrence of that parent symbol.
Other occurrences of that parent symbol are not expanded.

l Click the Expand One Level for All Occurrences icon. The hierarchy expands to only the first
level of symbols under the selected parent symbol, for all the occurrences of that parent
symbol.

l In a template that includes an inner dimension, expand the inner dimension to display the
symbols you want, and then right-click its corresponding symbol in the outer dimension and
select Expand One - Match Inner Detail. This expands the outer dimension symbol one level
down, and for each outer dimension child symbol, the inner dimension expands to match the
inner dimension expansion of the parent symbol.

l In a template that includes an inner dimension, expand the inner dimension to display the
symbols you want, and then right-click in the outer dimension and select Expand All - Match
Inner Detail. This expands all symbols visible in the outer dimension all levels down, and for
each outer dimension child symbol, the inner dimension expands to match the inner dimension
expansion of the parent symbol.
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l Click Expand All For All to expand all the symbols in all the dimensions in a given direction.

Caution: Depending on the number of symbols in your template, the Expand All For
All function has the potential to retrieve huge amounts of data, which may adversely
affect the performance of your system. Use this function with caution.

Collapsing hierarchies
To collapse hierarchies in a template, or DataView, follow these steps.

1. Right-click a symbol. A pop-up menu appears.

2. Do one of the following:

l To collapse all hierarchies in a dimension, right-click any symbol in that dimension, and click
the Collapse All icon. All hierarchies in that dimension are collapsed.

l To collapse the parent of a symbol, right-click the symbol whose parent you want to collapse
and click the Collapse Parent icon. The parent is collapsed.

Working With Conditions
You may be able to apply conditions to data that meet certain criteria, so that the data stands out from
the rest of the data.

For example, in the following illustration, you may want to highlight all numbers less than or equal to
10,000,000, for easier identification and analysis.

Creating a condition
You may be able to apply a condition to an entire view, or to one symbol at a time.
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Role Can perform this task?

Report Publisher yes

Report Author yes

Report User no

For an entire view

You may be able to apply a condition to an entire view.

To apply a condition to an entire view, follow these steps.

1. Make sure that no row or column symbol is currently highlighted (selected).

2. Choose Format > Edit Conditional Displays. The Conditional Display dialog appears.

3. Complete these fields:

Field Description

Top left
drop-down
list

Select one of the following:

n Highlight: To highlight the cells containing data meeting the condition.

Note: To display highlighting for users in the report, you must show
conditional display highlights. To do so, follow the steps in
Formatting the report body.

n Filter: To blank out the cells containing data meeting the condition.

n Suppress: To hide the entire row or column containing data meeting the
condition.

Values Specify the condition you want to apply to the data. For example, you can choose to
have values between 0 and 10,000,000 highlighted, filtered, or suppressed.

4. If you selected Highlight in step 3, you also need to specify background and foreground colors for
the cells containing the data meeting the condition. For each of Background and Foreground, select
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colors for the cells containing data meeting the condition. If you select a color only for Background
or only for Foreground, the system automatically applies a default color to the other.

5. Click Add. The new condition is added to the list.

6. Repeat step 3 to step 5 for each condition you want to create.

Note: Conditions are prioritized according to the order in which they appear in the list. For
example, if the first condition shows numbers between 0 and 500 in red, and the second
condition shows numbers between 0 and 1000 in blue, both red and blue conditions
appear. However, if the first condition shows numbers between 0 and 1000 in blue, and
the second condition shows numbers between 0 and 500 in red, only the blue condition
appears, as it has priority over the second condition in the list. To change the priority,
select a condition in the list, and then move it either up or down using the arrow keys to the
left of the list.

7. Click Apply to see the changes before exiting this dialog.

8. When you are finished, click OK. The view appears, with the conditions you specified.

Note: To display highlighting for users in the report, you must show conditional display
highlights. To do so, follow the steps in Formatting the report body.

For one symbol only

You may be able to apply a condition to one symbol at a time. If you have more than one dimension in
the down or across directions of the view, the symbol must be in the inner dimension.

To apply a condition to one symbol only, follow these steps.
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1. Click the symbol to which you want to apply a condition.

2. Choose Format > Edit Conditional Displays. The Conditional Display dialog appears.

3. Complete the dialog, as described in For an entire view.

4. Click Add. The new condition is added to the list.

5. Repeat for each condition you want to apply to the symbol.

Note: Conditions are prioritized according to the order in which they appear in the list. For
example, if the first condition shows numbers between 0 and 500 in red, and the second
condition shows numbers between 0 and 1000 in blue, both red and blue conditions
appear. However, if the first condition shows numbers between 0 and 1000 in blue, and
the second condition shows numbers between 0 and 500 in red, only the blue condition
appears, as it has priority over the second condition in the list. To change the priority,
select a condition in the list, and then move it either up or down using the arrow keys to the
left of the list.

6. Click Apply to see the changes before exiting this dialog.

7. When you are finished, click OK. The view window appears, with the conditions showing for the
symbol.
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8. If the conditions do not appear, make sure that conditions are activated. For more information, see
Activating and deactivating all conditions.

Editing a condition
Once you have created a condition, you may be able to make changes to its appearance and associated
criteria.

Role Can perform this task?

Report Publisher yes

Report Author yes

Report User no

To edit a condition, follow these steps.

1. Choose Format > Edit Conditional Displays. The Conditional Display dialog appears, listing the
existing conditions.
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2. From the list, select the condition to edit.

3. Complete the dialog, as described in For an entire view.

4. When you are satisfied with the changes, click Update. The changes are applied to the condition.

Note: Conditions are prioritized according to the order in which they appear in the list. For
example, if the first condition shows numbers between 0 and 500 in red, and the second
condition shows numbers between 0 and 1000 in blue, both red and blue conditions
appear. However, if the first condition shows numbers between 0 and 1000 in blue, and
the second condition shows numbers between 0 and 500 in red, only the blue condition
appears, as it has priority over the second condition in the list. To change the priority,
select a condition in the list, and then move it either up or down using the arrow keys to the
left of the list.

5. Click Apply to see the changes before exiting this dialog.

6. Click OK. The changes are saved.

Deleting a condition
If you do not need a condition in a template, or DataView, you may be able to delete it.

Role Can perform this task?

Report Publisher yes

Report Author yes

Report User no

Caution: If you follow this procedure, you cannot reverse your decision. Use with caution.

To delete a condition from a view, follow these steps.

1. Choose Format > Edit Conditional Displays. The Conditional Display dialog appears, listing the
existing conditions.
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2. In the list, select the condition, and click Remove. The condition is deleted from the list.

3. Click OK.

Activating and deactivating all conditions
You may be able to activate and deactivate all the conditions in a template, or DataView.

Role Can perform this task?

Report Publisher yes

Report Author yes

Report User no

The default setting is the activated state, represented by a check mark beside Apply Conditional
Displays in the Format menu.

To change the activation of conditions, follow these steps.

1. Choose Format and look at the Apply Conditional Displays command:

Command Description

check The conditional displays appear in the view.
no check The conditional displays do not appear in the view.

2. To change the setting, choose Format > Apply Conditional Displays. If you enable the command,
the conditions appear in the view.

Adding Calculated Rows And Columns
To compare data, you can create a calculated symbol. You can also use a calculated symbol to
compare values from any row symbol or column symbol.

You can create a calculated row or column that compares two other rows or columns according to
percentage, ratio, or variance. For example, the following illustration shows a calculated column that
displays the variance between the first two time period symbols.
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A calculated symbol is a symbol that exists in the template or view only. It does not exist in the Longview
database, and its data is not submitted to the database.

Because multiple calculated symbols from various dimensions may intersect, a decision must be made
to determine which of the calculations should apply at those intersections. You can determine the order
of calculations of all calculated symbols in a template, or DataView, and can therefore control which
formula applies at each calculation intersection.

You can perform calculations based on a complete slice of data, or you can limit calculations to specific
ranges of cells within that slice of data. For example, you may need to create reports containing “per
unit” calculations that vary between revenue and cost accounts.

Creating a ratio row or column
A ratio row or column is a type of calculated symbol that shows the ratio between two other rows or
columns. When you place the cursor over this row or column, the calculation appears in a ScreenTip.

You may be able to create a calculated row or column that compares two other rows or columns
according to the ratio between them.

Role Can perform this task?

Report Publisher yes

Report Author yes

Report User no

To create a calculated ratio row or column, follow these steps.

1. Click on a symbol next to which you want to create a calculated symbol.

2. Right-click the symbol name. A pop-up menu appears.

3. Choose Insert Calculated Symbol. The Create Calculated Symbol dialog appears. The appearance
of this dialog varies according to the orientation of the symbol you selected in step 1, and the type of
calculation you select next in this procedure.
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4. Complete these fields:

Field Description

Name Type a name for the calculated row or column.
Description Type a description for the calculated row or column.
Type Select Ratio. The available fields in the dialog change according to your selection.
Numerator Select the symbol for the numerator in the ratio.
Denominator Select the symbol for the denominator in the ratio.

Insert Point Select a location for the comparison row or column. You can place it either before or
after the symbol you selected in step 1.

Decimal Select the number of decimal places to include in the calculated data. To retain the
global decimal setting for the calculated symbol, select Default.

5. You may be able to create a condition for data in the calculated row or column, so that values
meeting a certain condition are highlighted, filtered, or suppressed altogether.

l To create a calculated row or column without a condition, proceed to step 6.

l To create a condition, click Conditional Display, and complete the dialog, as described in
Working with conditions.

6. Click OK. The view appears, showing the calculated row or column.

If you hold the cursor over a cell in the calculated row or column, a ScreenTip appears, showing the
formula.

Creating a variance row or column
A calculated variance row or column is a type of calculated symbol that shows the difference between
two other rows or columns as either a currency value, a percentage, or both.

When you place the cursor over this row or column, the calculation appears in a ScreenTip. You may be
able to create a calculated variance row or column.
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Role Can perform this task?

Report Publisher yes

Report Author yes

Report User no

To create a calculated variance row or column, follow these steps.

1. Click on a symbol next to which you want to create a calculated symbol.

2. Right-click the symbol name. A pop-up menu appears.

3. Choose Insert Calculated Symbol. The Create Calculated Symbol dialog appears.

4. For Type, select Variance. The appearance of the dialog changes.

5. Complete these fields:

Field Description

Name Type a name for the variance row or column.
Description Type a description for the variance row or column.
Type You have already selected Variance.

Base Select the base symbol against which you want to compare another symbol, to
derive the variance between the two.

Comparison Select the symbol you want to compare with the base symbol.
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Field Description

Use

Select one of the following:

n Value As Calculated: To show the value as it is calculated whether positive
or negative.

n Absolute Value: To show the value as a positive number only.

Display

Select one of the following:

n In Currency: To show the variance as a currency value.

n As a Percentage: To show the variance as a percentage.

n Both: To show the variance as both a currency value and a percentage. If
you select this option, two calculated rows or columns appear.

Insert Point Select the location of the comparison row or column. You can place it either before
or after the symbol you selected in step 1.

Decimal Select the number of decimal places to include in the calculated data. To retain the
global decimal setting for the calculated symbol, select Default.

6. You can create a condition for data in the calculated row or column, so that values meeting a certain
condition are highlighted, filtered, or suppressed altogether.

l To create a calculated row or column without a condition, proceed to step 7.

l To create a condition, click Conditional Display, and complete the dialog, as described in
Working with conditions.

7. Click OK. The view appears, showing the calculated row or column.

If you hold the cursor over a cell in the calculated row or column, a ScreenTip appears, showing the
formula.

Creating a percentage row or column
A calculated percentage row or column is a type of calculated symbol that shows the value of each
symbol in a selected row or column as a percentage of one of the symbols in that same row or column.

When you place the cursor over this row or column, the calculation appears in a ScreenTip.
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You may be able to create a calculated percentage row or column.

Role Can perform this task?

Report Publisher yes

Report Author yes

Report User no

To create a calculated percentage row or column, follow these steps.

1. Click on a symbol next to which you want to create a calculated symbol.

2. Right-click the symbol name. A pop-up menu appears.

3. Choose Insert Calculated Symbol. The Create Calculated Symbol dialog appears.

4. For Type, select Percentage of. The appearance of the dialog changes.

5. Complete these fields:

Field Description

Name Type a name for the percentage row or column.
Description Type a description for the percentage row or column.
Type You have already selected Percentage Of.
Symbol To
Calculate

Select the symbol, the values of which you want to view as a percentage of the values
of another symbol.

Base Select the base symbol which is given the value of 100%, against which the other
symbols in the row or column are compared.

Display Select whether you want the data shown as a percentage or as a decimal.

Insert Point Select the location of the comparison row or column. You can place it either before or
after the symbol you selected in step 1.

Decimal Select the number of decimal places to include in the calculated data. To retain the
global decimal setting for the calculated symbol, select Default.
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6. You can create a condition for data in the calculated row or column, so that values meeting a certain
condition are highlighted, filtered, or suppressed altogether.

l To create a calculated row or column without a condition, proceed to step 7.

l To create a condition, click Conditional Display, and complete the dialog, as described in
Working with conditions.

7. Click OK. The view appears, showing the calculated row or column.

If you hold the cursor over a cell in the calculated row or column, a ScreenTip appears, showing the
formula.

Creating a formula row or column
A calculated formula row or column is a type of calculated symbol that shows data that has been
calculated according to a particular algebraic formula. For example, you might want to create a formula
that performs a Quick Ratio calculation:

(Total cash + Other current assets + Accounts receivable) / Total current liabilities

When you place the cursor over this row or column, the calculation appears in a ScreenTip.

You may be able to create a calculated formula row or column.

Role Can perform this task?

Report Publisher yes

Report Author yes

Report User no

To create a calculated formula row or column, follow these steps.

1. Click on a symbol next to which you want to create a calculated symbol.

2. Right-click the symbol name. A pop-up menu appears.
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3. Choose Insert Calculated Symbol. The Create Calculated Symbol dialog appears.

4. For Type, select Formula. The appearance of the dialog changes.

5. Complete these fields:

Field Description

Name Type a name for the formula row or column.
Description Type a description for the formula row or column.
Type You have already selected Formula.

Insert Point Select the location of the calculated row or column. You can place it either before or
after the symbol you selected in step 1.

Decimal Select the number of decimal places to include in the calculated data. To retain the
global decimal setting for the calculated symbol, select Default.

6. For Formula, type the formula you want to apply to the calculated row or column. If you are not sure
how to create a formula, click Edit. The Build Formula dialog appears.
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7. To create a formula, do any of the following:

l In Formula, type the formula using your keyboard.

l To use the value of a symbol for the formula, navigate through the hierarchy in Available
Symbols, and double-click the symbol to select it.

l To use the value of a symbol for the formula, type the full or partial symbol name in the Search
field. Click Find Next and double-click the symbol to select it.

l To use the value of a floating time period (for formulas in the TIMEPER dimension only),
navigate through the time periods hierarchy in the Available Symbols list, and double-click a
floating time period (indicated by an asterisk) to select it. You may also type the attribute name
of the floating time period, enclosed in square brackets, in Formula (for example,
[SGPCurrentYear]). For more information on floating time periods, see Using floating time
period symbols.

l To insert mathematical operators ( + , - , and so on), type them, or click the buttons under
Formula.

l Use any combination of the above.
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8. When you are finished creating the formula, click OK. The Create Calculated Symbol dialog
appears, showing the formula in the Formula field.

9. You can create a condition for data in the calculated row or column, so that values meeting a certain
condition are highlighted, filtered, or suppressed altogether.

l To create a calculated row or column without a condition, proceed to step 10.

l To create a condition, click Conditional Display, and complete the dialog, as described in
Working with conditions.

10. Click OK. The view appears, showing the calculated row or column.
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Defining calculation order for calculated rows and columns
When you have more than one calculated symbol in a template, or DataView, you can determine the
order in which these symbols are calculated. This is useful when two or more calculated symbols
intersect, or when one calculation depends on the results of another.

For example, the following illustration contains two calculated symbols — a variance symbol in the down
direction, and a percentage symbol in the across direction.

The variance column shows the variance between two time periods for all displayed accounts. The
percentage row shows Gross Profit as a percentage of Total revenue over the course of the year.

In this case, where the two calculated symbols intersect, you would typically want the percentage
symbol to be calculated and displayed. This is precisely what happens as a default, because the
percentage symbol is in the down dimension and the inner down dimension always “wins” as a default.

However, if the dimension orientation gets reversed, the desired calculated symbol is no longer
displayed. You can make sure that where the calculations intersect, the percentage symbol always gets
calculated last (and is thus the calculation displayed) by defining the calculation order.

Depending on your role, you may be able to define the order in which calculated symbols are calculated.

Role Can perform this task?

Report Publisher yes

Report Author yes

Report User no

To specify the order in which calculated symbols are calculated, follow these steps.

1. In the view window, choose Tools > Calculation Order. The Calculation Order dialog appears, listing
all calculated symbols in the view.
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The calculations are listed in the order in which they are calculated, from the top down. This means
that where calculated symbols intersect, the calculation lower in the list is the one that appears,
because it is calculated last.

2. Select the calculation that you want to relocate.

3. Use the arrow buttons to move the calculation either up or down in the list.

Editing a calculated row or column
Once you have created a calculated symbol, you may be able to make changes to it, as new
requirements arise.

Role Can perform this task?

Report Publisher yes

Report Author yes

Report User no

To edit a calculated row or column, follow these steps.

1. In the view window, click the calculated symbol name to highlight it.

2. Right-click the symbol name. A pop-up menu appears.
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3. Choose Edit Calculated Symbols. The Edit Calculated Symbol dialog appears.

4. Make changes to the calculated row or column, in the same way you created it. For more
information, see

l Creating a ratio row or column

l Creating a variance row or column

l Creating a percentage row or column or

l Creating a formula row or column.

Deleting a calculated row or column
If you do not need a calculated symbol, you may be able to delete it.

Role Can perform this task?

Report Publisher yes

Report Author yes

Report User no

To delete a calculated row or column, follow these steps.

Caution: Warnings provide cautionary information on the possible effect of certain actions,
including the unintentional deletion of data. Be sure to read and understand all warnings
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before performing a related procedure. If you follow this procedure, you cannot reverse your
decision. Use with caution.

1. Click the calculated symbol name to highlight it.

2. Right-click the symbol name. A pop-up menu appears.

3. Choose Remove Calculated Symbols. The calculated row or column is deleted.

Working With Range Calculations
In regular calculated rows and columns, one calculation applies to the entire range of symbols within
that row or column. Using range calculations, you can create calculated rows and columns in which you
can define more than one calculation and apply them to different ranges of symbols within that row or
column.

Understanding range calculations
You define a range by selecting a parent symbol in the ranging dimension. The ranging dimension is the
dimension containing the symbols on which the calculation is based. By default, the ranging dimension
is the innermost dimension in the opposite direction of the calculated symbol. For example:

You can make any dimension in either the down or across direction of your view the ranging dimension,
as long as it resides in the opposite direction to the one containing the calculated symbol.

All child symbols beneath the selected parent symbol are included in the range and are thus subject to
the same calculation. For example, in the previous example, the initial range is Gross profit and all its
children.
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In this example, all symbols in the initial range are subject to the following calculation:

2003 - 2003 Budget

This calculation results in all calculated data being shown as positive.

To show the expense accounts as negative, you must define a second range with a different calculation.

This calculation results in all data in the second range being shown as negative.

You can add as many ranges as you want. The order in which you create ranges does not matter.
Ranges are calculated according to their position in the hierarchy from the top of the hierarchy down.
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Creating range calculations
Depending on your role, you may be able to create range calculations within a calculated symbol.

Role Can perform this task?

Report Publisher yes

Report Author yes

Report User no

To create range calculations within a calculated symbol, follow these steps.

1. Click on a symbol next to which you want to create a calculated symbol.

2. Right-click the symbol name. A pop-up menu appears.

3. Choose Insert Calculated Symbol. The Create Calculated Symbol dialog appears.

4. For Type, select Range Calculation. The appearance of the dialog changes.

5. Complete these fields:

Field Description

Name Type a name for the range.
Description Type a description for the range.
Type You have already selected Range Calculation.
Ranging
Dimension

Select the dimension containing the parent symbols within which you want to
specify ranges of symbols.
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6. Click Add/Remove Symbols. The Symbol Selection For Range dialog appears.

7. Complete the following:

Field Description

Available
Symbols and
Selected
Symbols

Find the symbols within which you want to define symbol ranges in the Available
Symbols list and click the arrow to move them to the Selected Symbols list. You
may select as many symbols as necessary.

8. Click OK. The Create Calculated Symbol dialog appears with the symbols you selected in the
Ranging Symbols drop-down list.
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9. For Ranging Symbols, select a symbol within which you want to create a range calculation.

10. Click Create/Edit Calculation. The Create Calculation dialog appears.

11. Define the calculation to apply to the range as described in:

l Creating a ratio row or column

l Creating a variance row or column

l Creating a percentage row or column

l Creating a formula row or column

For Calculation Type Applied, you can select None (blank) if you do not want the range calculation
performed on a parent symbol (and all its children) to apply to one or more child symbols (and all
their children) within that parent symbol. In this case, you would have to create a separate range
within the parent range, to which you would apply the None (blank) setting.

12. Repeat step 9 to step 11 for each range to include in the calculated column or row.

Note: The order in which you define the range calculations does not matter because
ranges are calculated according to their position in the hierarchy — symbols higher in the
hierarchy are calculated before symbols lower in the hierarchy.

13. When you are finished, click OK. The Create Calculated Symbol dialog appears.

14. Complete these fields:

Field Description

Insert
Point

Select the location of the calculated row or column. You can place it either before or after
the symbol you selected in step 1.
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Field Description

Decimal Select the number of decimal places to include in the calculated data. To retain the
global decimal setting for the calculated symbol, select Default.

15. You can create a condition for data in the calculated row or column, so that values meeting a certain
condition are highlighted, filtered, or suppressed altogether.

l To create a calculated row or column without a condition, proceed to step 16.

l To create a condition, click Conditional Display, and complete the dialog, as described in
Working with Conditions.

16. Click OK. The view appears, showing the calculated row or column.

Editing Symbol Formats
Depending on your role, you may be able to edit the appearance of individual symbols in a template,
DataView, or view. For example, you may want to change the scaling of the symbol’s data, the number
of decimals shown in the symbol’s data, or the description of the symbol itself.

For example, in the following illustration, the scaling and number of decimals for the Total revenue
symbol have been changed.

When you define individual symbol formats, those settings override the global settings for the file.

Depending on your role, you may be able to perform this task.

Role Can perform this task?

Report Publisher yes

Report Author yes

Report User no

To edit the format of an individual symbol, follow these steps.
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1. Right-click on the symbol you want to edit. A pop-up menu appears.

2. Choose Edit Symbol Format. The Symbol Format dialog appears, with the Number tab in view.

In the Symbol Format section, make sure the symbol you want to edit is selected.

To add symbols to the list, select them in the drop-down list, and click Add.

To remove symbols from the list, select them and click Remove.

Complete these fields.

Field Description

Decimal

Select the number of decimal places for the symbol’s data. If you select Default, the
global template setting specified in the Number Format dialog is applied. For more
information, see Specifying number formats.

The results of allocation calculations are rounded up to the precision you select here.

Scaling
Factor

Select a scaling factor for the symbol’s data. Scaling refers to the format in which the
data appears. For example, if you are dealing with very large numbers, you may want to
view numbers in thousands or millions. Scaling makes the numbers easier to read. For
example, to view the number “10,000” as “10”, select 000s to specify that all numbers
appear in thousands.

If you select Default, the global template setting specified in the Number Format dialog is
applied. For more information, see Specifying number formats.
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3. Click the Header tab.

4. Do one of the following:

l To change the description of the symbol, clear the Use Default field, and type the new
description in the Header Text field. The description can contain a maximum of 100 characters.

l To use the default symbol description, select Use Default.

5. Click OK. The symbol is reformatted.

Editing Cell Formats
Depending on your role, you may be able to edit the format of individual cells in a template, DataView, or
view. For example, you may want to change the scaling of the cell’s data, or the number of decimals
shown in the cell’s data.

For example, in the following illustration, the scaling and number of decimals for the selected cell have
been changed.
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When you define individual cell formats, those settings override the format settings of the symbols to
which that cell belongs, as well as the global format settings for the file. Depending on your role, you
may be able to perform this task.

Role Can perform this task?

Report Publisher yes

Report Author yes

Report User no

To edit the format of an individual cell, complete these steps.

1. Right-click on the cell you want to edit. A pop-up menu appears.

2. Choose Edit Cell Format. The Cell Format dialog appears, with the coordinates of the cell you
want to edit highlighted in the list box.
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3. In the list box, make sure the cell you want to edit is selected.

l To add cells to the list, select the coordinates of the cell to edit in the Symbol section, and click
New.

l To remove cells from the list, select them and click Delete.

4. Complete these fields.

Field Description

Decimal

Select the number of decimal places for the cell’s data.

If you select Default, the setting specified in the Symbol Format dialog is applied. For
more information, see Editing symbol formats.

The results of allocation calculations are rounded up to the precision you select here.

Scaling
Factor

Select a scaling factor for the cell’s data. Scaling refers to the format in which the data
appears. For example, if you are dealing with very large numbers, you may want to view
numbers in thousands or millions. Scaling makes the numbers easier to read. For
example, to view the number “10,000” as “10”, select 000s to specify that all numbers
appear in thousands.

If you select Default, the setting specified in the Symbol Format dialog is applied. For
more information, see Editing symbol formats.
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5. Click OK. The cell is reformatted.

Hiding Symbols
You may be able to hide an individual symbol if it contains data that would clutter the screen with
extraneous detail but is still needed for calculations.

Role Can perform this task?

Report Publisher yes

Report Author yes

Report User no

For example, in the following illustration, you may want to hide one or more of the child symbols rolling
up to Total revenue to see their siblings more clearly in relation to the value of the parent symbol.

Once their siblings have been hidden, Product revenue and Service revenue are more easily identifiable
as a proportion of Total revenue.

To hide symbols, follow these steps.
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1. In the file window, choose Edit > Hidden Symbols. The Hidden Symbol Selection dialog appears.

2. Complete the following.

Field Description

Dimension Select the dimension containing the symbols you want to hide.

3. Select symbols, as required.

4. When you are finished, click OK.

Note: Alternatively, you can right-click on a symbol name or description, and in the menu that
appears, choose Hide Symbol. The symbol (and all its children) is hidden. To see all hidden
symbols, right-click on any symbol name or description, and in the menu that appears, choose
Show Hidden Symbols.

Adjusting Spacing With Blank Symbols
To make the data in a template, or DataView easier to read, you may want to separate certain symbols
by inserting a blank row or column between them.

The following illustration shows a blank row to separate the total symbol from its child symbols.
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The blank row above the Total row makes the data easier to read.

Creating a spacing row or column
To make data easier to read, you may want to separate certain symbols by inserting a blank row or
column between them.

Role Can perform this task?

Report Publisher yes

Report Author yes

Report User no

To add a blank row or column to a view, follow these steps.

1. Click on a symbol next to which you want to create a blank symbol.

2. Right-click the symbol name. A pop-up menu appears.

3. Choose Insert Blank Symbol. The Create Blank Symbol dialog appears.
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4. Complete these fields:

Field Description

Before To insert the blank symbol before the symbol you selected in step 1, select this field.
After To insert the blank symbol after the symbol you selected in step 1, select this field.

5. Click OK. The view window appears, with the blank row or column.

Removing a spacing row or column from a view
To make data easier to read, a blank row or column may appear. If you do not need the blank row or
column, you may be able to delete it.

Role Can perform this task?

Report Publisher yes

Report Author yes

Report User no

To delete a blank row or column, follow these steps.

1. Right-click the symbol. A pop-up menu appears.

2. Choose Remove Blank Symbol. The view window appears, with the blank row or column removed.

Adding Links To A Template
If you want, you can attach links from your Longview Analysis and Reporting templates to external
systems. This link might be to any external system that can accept a URL. The system on the receiving
end must be able to interpret the URL and resolve the request.
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You can create two kinds of links:

Link type Description

Cell-level

Used to provide a link to an external URL, to provide additional information on a
particular data cell.

This type of link can be invoked from all cells in the template, except calculated cells or
blank cells.

Template-

level

Used to provide information related to the template as a whole, such as instructions, in a
pdf file.

This type of link can be invoked from all cells, or from the toolbar or menu.

Once a link is defined, you can assign it to one or more templates, and then publish the templates.

Creating a link
Depending on your role, you may be able to create links in the application.

Role Can perform this task?

Report Publisher yes

Report Author yes

Report User no

To create a link in the application, follow these steps.

1. In the Longview Analysis and Reporting dialog, click the Links tab.
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2. Choose File > New. The Create Link dialog appears.

3. Complete these fields:

Field Description

Name Type a name for the link.
Description Type a description in the language of your current application.

Level

Select one of the following:

n Cell: Used to provide a link to an external URL with detailed information on a
particular data cell. This type of link can be invoked from all cells except
calculated cells or blank cells.

n Template: Used to provide information related to the template as a whole,
such as instructions, and can be a pdf file. This type of link can be invoked
from all cells, or from the toolbar or menu.

URL Type the absolute URL of this external link. For more information, see Constructing a
link URL and Editing a link.
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4. Click OK. The Create Link dialog appears. Click OK. The new link appears in the Links tab.

Constructing a link URL
Depending on your needs, the URL of the link can be very simple, or very complex. It is your
responsibility to ensure that the URL is valid.

Caution: The application is not responsible for link validation. If you specify an invalid URL to
a link, users might see unexpected results, such as a blank Internet Explorer window.

Parameters
A parameter for the symbol name for each dimension, including schedules, exists.

For example:

%%ACCOUNTS%%

%%TIMEPER%%

For schedules, a parameter is required for the schedule name and schedule dimension name.

For example:

%%Sched_Name%%

%%Sched_Dim_Name%%

These parameters resolve to the symbol names for the data intersection of the cell the link was invoked
from. These parameters are resolved when specified in the URL of a cell level link only. If they are
specified in a template level link, they are not resolved. For more information, see Creating a link.
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There are also parameters which resolve to a pipe-delimited list of root symbols included in the report.
For the full report context, the parameters use the following naming convention:
%%ROOTSDimensionName%%

These %%ROOTS%% parameters resolve to a pipe-delimited list of root symbols included in the report
for the specified dimension. Hidden and suppressed root symbols will be included in the list if the user
has symbol access to these symbols.

For example, you can create a template link to a Longview App using the following syntax:

LongviewApp=Details.lvapp&
ACCTROOTS=%%ROOTSACCOUNTS%%&RootTimePeriods=%%ROOTSTIMEPERIODS%%

In this example, if the report contains the Trial_Balance account and the Actual and Budget time
periods, the link will resolve to:

LongviewApp=Details.lvapp& ACCTROOTS=Trial_
Balance&RootTimePeriods=Actual|Budget

Tokens

Use Web attribute tokens in the same way that they are used in Longview Dashboard Designer.

<%[[ATTRIBUTE,AttrClass,AttrName,ObjectName]]%>

where:

n AttrClass is SYSTEM, SYMBOL, USER, or GROUP.

Note: The GROUP attribute class can be used only with DESCRIPTION specified for
the AttrName parameter, which retrieves the current user group description.

n AttrName is the attribute name.

ObjectName is the attribute object. System attributes and the GROUP attribute class do not
require an object. ObjectName is mandatory for symbol attributes and specifies the symbol
name. ObjectName is optional for user attributes and specifies the user ID. If no ObjectName is
specified, the current user ID is used.

Note: For cell level links, you can also specify parameters for the
ObjectNameparameter; for example, %%ENTITIES%%.

For example:

<%[[ATTRIBUTE, SYMBOL, ZGPNativeCurrency, %%ENTITIES%%]]%>
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Specifying the launch mode

When launching URLs from Report Viewer within the Longview Client, you have the option of defining
whether the URL should open internally as a tab within the Longview Client or as an external window.
Use the following URL parameter to define how the URL should be launched as follows:

LongviewLaunchMode=Internal|IE|DefaultBrowser

where:

n Internal specifies that the URL should open internally as a tab within the Longview Client. This
is the default if the LongviewLaunchMode parameter is not specified.

n IE specifies that the URL should open externally using IE as the browser

n DefaultBrowser specifies that the URL should open externally using the default browser.

URL syntax

The link URL might look like this:

http://www.longview.com?TIMEPERIOD=<%[[ATTRIBUTE, SYSTEM,
ASCurrentPeriod]]%>http://www.longview.com?CURRENCY=<%[[ATTRIBUTE, SYMBOL,
ZGPNativeCurrency, %%ENTITIES%%]]%>&LongviewLaunchMode=Internal

Constructing a link to an App
You can also construct a link to an App. The link to an app can use the Parameters and Tokens
mentioned above. The syntax for the link depends on how you launch the initiating Report.

Link to an App Syntax (for Reports and Apps launched standalone from the Dashboard)

For Reports launched from the Dashboard, the link must be constructed as a URL that refers to the
smart client application, the web session parameters, the name of the App to launch and any pertinent
parameters and tokens.

The link to an App might look like this:

Longview.ApplicationSmartClient.application?LongviewWebSID=<%

[[WEBVARIABLE,LongviewWebSID]]%>&LongviewWebBridge=<%

[[WEBBRIDGE]]%>&LongviewIdentifier=<%

[[WEBVARIABLE,LongviewIdentifier]]%>&LongviewLangCode=<%

[[WEBVARIABLE,LongviewLangCode]]%>&LongviewApp=Review%20Intercompany%20Trans
actions.lvapp&ACCOUNTS=%%ACCOUNTS%%&ENTITIES=%%ENTITIES%%&DETAILS=%%DETAILS%
%&SEGMENTS=%%SEGMENTS%%
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Link to an App Syntax (for Reports and Apps launched within the Longview Client)

For Reports launched within the Longview Client (Performance Manager or Longview Tax), the link is
simplified and only requires the name of the App to launch and any pertinent parameters and tokens.

The link to an App might look like this:

LongviewApp=Review%20Intercompany%20Transactions.lvapp&ACCOUNTS=%%ACCOUNTS%%
&ENTITIES=%%ENTITIES%%&DETAILS=%%DETAILS%%&SEGMENTS=%%SEGMENTS%%

Constructing a link to a report
You can also construct a link to a report. The link to a report can use the Parameters and Tokens
mentioned above. The syntax for the link depends on how you launch the initiating Report.

Link to a Report Syntax (for reports launched standalone from the Dashboard)

For reports launched from the Dashboard, the link must be constructed as a URL that refers to the
Longview Report Viewer client application, the web session parameters, the name of the Report to
launch, and any pertinent parameters and tokens.

The link to a report might look like this:

Longview.ReportViewer.application?LongviewWebSID=<%

[[WEBVARIABLE,LongviewWebSID]]%>&LongviewWebBridge=<%
[[WEBBRIDGE]]%>&LongviewIdentifier=<%

[[WEBVARIABLE,LongviewIdentifier]]%>&LongviewLangCode=<%

[[WEBVARIABLE,LongviewLangCode]]%>&LongviewReportName=Review%20Intercompany%
20Transactions&selectedSymbols=ACCOUNTS:%%ACCOUNTS%%,ENTITIES:%%ENTITIES%%

Link to a Report Syntax (for reports launched within the Longview Client)

For reports launched within the Longview Client (Performance Manager or Longview Tax), the link is
simplified and only requires the name of the report to launch, and any pertinent parameters and tokens.

The link to a report might look like this:

LongviewReportName=Review%20Intercompany%20Transactions&selectedSymbols=ACCO
UNTS:%%ACCOUNTS%%,ENTITIES:%%ENTITIES%%

Editing a link
Once you have created a link, you may be able to make changes to it.

Role Can perform this task?

Report Publisher yes
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Role Can perform this task?

Report Author no

Report User no

To edit a link, follow these steps.

1. In the Longview Analysis and Reporting dialog, click the Links tab.

2. Choose File > Open. The Modify Link dialog appears. Attaching a link to a template

3. Once you have created links, you can attach them to a template in the application.

Role Can perform this task?

Report Publisher yes
Report Author no
Report User no

4. To attach a link to a template, follow these steps.

5. Open a template.

https://insightsoftware.com/


118

6. To attach a link to the template, choose Links > Attach Links. The Attach Links dialog appears.

7. In the Attach to template column, select the links you want to attach to this template.

l Users of this template are able to access both cell and template level links by right-clicking any
cell other than a calculated cell or a blank cell.

l Users of this template are also able to access all template level links from the Links menu in the
application, or a Links icon in a report template.

8. Click OK.

9. When you are finished with this template, publish it so that the template and its links are available to
users.
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10. Edit as necessary. For more information, see Creating a link.

Attaching a link to a template
Once you have created links, you can attach them to a template in the application.

Role Can perform this task?

Report Publisher yes

Report Author no

Report User no

To attach a link to a template, follow these steps.

1. Open a template.

2. To attach a link to the template, choose Links > Attach Links. The Attach Links dialog appears.
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3. In the Attach to template column, select the links you want to attach to this template.

l Users of this template are able to access both cell and template level links by right-clicking any
cell other than a calculated cell or a blank cell.

l Users of this template are also able to access all template level links from the Links menu in the
application, or a Links icon in a report template.

4. Click OK.

5. When you are finished with this template, publish it so that the template and its links are available to
users.

Detaching a link from a template
If you need to detach an attached link, you can do so.

Role Can perform this task?

Report Publisher yes

Report Author no

Report User no

To detach a link from a template, follow these steps.

1. Open a template.

2. Choose Links > Attach Links. The Attach Links dialog appears, with the currently attached links
identified with a check mark.
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3. In the Attach to template column, remove the check marks as required.

4. Click OK.

5. When you are finished with this template, republish it so that the template is available to users,
without the detached link.

Deleting a link
If you do not need a link, you may be able to delete it.

Role Can perform this task?

Report Publisher yes

Report Author no

Report User no

Caution: If you follow this procedure, you cannot reverse your decision. Use with caution.

To delete a link, follow these steps.
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1. In the Longview Analysis and Reporting dialog, click the Links tab.

2. Select the link and press the Delete key. A confirmation dialog appears.

3. Click Yes. The link is deleted. In existing templates with a deleted link attached, the link becomes
obsolete and does not show up in the template.
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Working With Report Batches
If you have several reports to run, you can save time by creating a batch to run them together, rather
than individually.

Creating report batches
If you have several reports to run, you can save time by creating a batch to run them together, rather
than individually. All types of users can run report batches. However, the contents of your batches
depend on your role in the process.

Role Can include these files in a batch

Report Publisher

n DataViews (kdv)

n published report
templates (rtp)

n batches (rbt)

n published batches (rbt)

Report Author

n DataViews (kdv)

n published report
templates (rtp)

n published batches (rbt)

Report Users

n published report
templates (rtp)

n published batches (rbt)

An asterisk ( * ) in the file name extension indicates that the file has been published.

Creating a report batch
If you have several reports to run, you can save time by creating a batch to run them together, rather
than individually.

Role Can perform this task?

Report Publisher yes

Report Author yes, but saved locally only.

Report Users yes, but saved locally only.

The procedure you use differs depending on your role.
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Report Publishers
To create a report batch, follow these steps.

1. Open the Longview Analysis and Reporting dialog, and click the Batches tab.

2. Choose File > New. The Edit Report Batch dialog appears.
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3. Choose File > Save As. The Save dialog appears.

4. Complete these fields:

Field Description

Save in If necessary, select the folder in which you want to save the batch.
File Name Type a name for the report batch.
Files of type Select Report Batches (*.rbt).

5. Click Save. The Edit Report Batch dialog appears, with the name of the report batch in the title bar.

6. Click the Close button in the top right corner. The Longview Analysis and Reporting dialog appears.
If the report batch does not appear in the list, select Any group in the Templates Published to
drop list.
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7. Once you have created the report batch, you can proceed to Adding report templates to a report
batch, or Adding report batches to a report batch.

Report Authors and Users
To create a report batch, follow these steps.

1. Open the Longview Analysis and Reporting dialog, and click the Batches tab.

2. Choose File > New. The Edit Report Batch dialog appears.
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3. Choose File > Save As. The Save dialog appears.

4. Complete these fields:

Field Description

Look in If necessary, select the folder in which you want to save the batch.
File Name Type a name for the batch.
Files of type Select Report Batches (*.rbt).

5. Click Save. The Edit Report Batch dialog appears, with the name of the report batch in the title bar.

6. Click the Close button in the top right corner. The Longview Analysis and Reporting dialog appears.

7. Choose Tools > Refresh. The report batch appears in the Local batch files list.
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8. Once you have created the report batch, you can proceed to Adding report templates to a report
batch, or Adding report batches to a report batch.

Adding report templates to a report batch
After the report batch has been created, you can add reports to it.

Role Can perform this task?

Report Publisher yes

Report Author yes

Report Users yes

The procedure you use differs depending on your role.

Report Publishers
To add a report to a report batch, follow these steps.

1. Create the report batch, as described in Creating a report batch.

2. Open the Longview Analysis and Reporting dialog, and click the Batches tab.

3. If you want to add a report template to a report batch that you have published to the database,
select the group to which you published it in the Templates  published to drop-down list. A list of
report batches published to that group appears. For a list of all report batches, select Any group.

4. Select the report batch to which you want to add a report template and choose File > Open. The Edit
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Report Batch dialog appears.

5. The Local Files section lists each DataView and report batch you have saved locally. The
Published Files section lists report templates and report batches you have published to the
database for use by other users. Published report templates and batches are listed according to the
groups to which they have been published. You can change the group in the Group list.

In either of these sections, select the DataView or report template you want to add, and click the
right arrow button to move it to the Current Items in Batch field.

Note: If you intend to publish this report batch to the database, make sure you include
only published reports and published batches in the report batch.

l If, when preparing the report template, you decided to keep all dimensions frozen (to prevent
users from selecting any of the symbols in the report), the report appears in the Current Items
in Batch field. Proceed to step 12.

l If, when preparing the report template, you decided to allow users to select symbols in any of
the dimensions in the report, the Select Symbols dialog appears, showing the dimension for
which, you must now select the symbols yourself. (Users are still able to change these symbols
when they access the published batch.) Proceed to step 6.
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6. Complete the following:

Field Description

Available
Symbols

The available root symbols for the unfrozen dimension appear in this field. When you
find a symbol to use as a root symbol for that dimension, highlight it, and click the right
arrow button to move it to the Selected Symbols list. (If you know the name of a symbol,
you can also type the name in the text field beside the Find Next button, and then click
the button.)

7. Repeat step 6 for each root symbol you want to include in the report for that dimension.

8. In the Dimension Report Settings section, complete these fields:

Field Description

Auto-Expand Symbols To show the child symbols of the parent symbols in the report, select this
field.

Depth Select the number of levels of child symbols you want to show in the
report.

Print a separate report
for each selected
symbol

To print individual reports for each symbol in the Selected Symbols list
and for the child symbols of those selected symbols, select this field.

Depth Select the number of levels of symbols beneath the selected symbol, for
which you want to print a separate report.
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Field Description

Type

Select one of the following:

n All: To print individual reports for the selected symbol and all
symbols within the selected symbol.

n Parents only: To print individual reports for the selected symbol
and all parent symbols within the selected symbol.

n Leaves only: To print individual reports only for leaf symbols
within the selected symbol.

9. Click OK and repeat step 6 to step 8 for each dimension for which you are prompted to select
symbols. When you finish selecting symbols, the Edit Report Batch dialog appears, showing the
report template in the Current Items in Batch field.

10. In the Current Items in Batch field, select the report template you have just moved there, and
complete these fields:

Field Description

Output
type

Select one of the following:

n Output to Printer: To print the report.

n Output to PDF: To save the report with the file name extension pdf.

n Output to Image: To save the report as an image file, with the file name
extension png.
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Field Description

Output
Folder

If you chose to save the report as a pdf file or png image file, type the path and folder
name for the location in which you want to save the file.

Output
Filename If you chose to save the report as a pdf file or png image file, type a name for the file.

11. Repeat step 5 to step 10 for each report you want to include in the batch.

12. To remove a report from the batch, select the report in the Current Items in Batch field, and click
the left arrow button.

13. When you have finished selecting report templates for the report batch, choose File > Save. The
report batch is saved locally.

Note: You can also publish the report batch to the database so that other users can
access it. If the batch has already been published, you must publish it again.

14. Click the Close button in the top right corner to return to the Longview Analysis and Reporting
dialog.

15. Proceed to Adding report batches to a report batch, or Running report batches.

Report Authors and Users
To add a report to a report batch, follow these steps.

1. Create the report batch, as described in Creating a report batch.

2. Open the Longview Analysis and Reporting dialog, and click the Batches tab.

3. The Local batch files section lists report batches you have saved locally. The Published batch
files section lists report batches the Report Publisher has published to the database. In either
section, select the report batch to which you want to add a report, and choose File > Open. The Edit
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Report Batch dialog appears.

4. In the Published Files field, select a Report template (rtp) that you want to include in the batch, and
click the right arrow button.

l If, when preparing the report template, the Report Publisher decided to keep all dimensions
frozen (to prevent users from selecting any of the symbols in your report), the report appears in
the Current Items in Batch field. Proceed to step 9.

l If, when preparing the report template, the Report Publisher decided to allow users to select
symbols in any of the dimensions in your report, the Select Symbols dialog appears, showing
the dimension for which, you can select symbols. Proceed to step 5.
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5. Complete the following:

Field Description

Available
Symbols

The available root symbols for the dimension appear in this field. When you find a
symbol to use as a root symbol for that dimension, make sure the symbol is highlighted,
and click the right arrow button to move the symbol to the Selected Symbols list. (If you
know the name of a symbol, you can also type the name in the text field beside the Find
Next button, and then click the button.)

6. Repeat step 5 for each root symbol to include in the report for that dimension.

7. In the Dimension Report Settings section, complete these fields.

Field Description

Auto-Expand Symbols To show the child symbols of the parent symbols in the report, select this
field.

Depth Select the number of levels of child symbols you want to show in the
report.

Print a separate report
for each selected
symbol

To print individual reports for each symbol in the Selected Symbols list
and for the child symbols of those selected symbols, select this field.
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Field Description

Depth Select the number of levels of symbols beneath the selected symbol, for
which you want to print a separate report.

Type

Select one of the following:

n All: To print individual reports for the selected symbol and all
symbols within the selected symbol.

n Parents only: To print individual reports for the selected symbol
and all parent symbols within the selected symbol.

n Leaves only: To print individual reports only for leaf symbols
within the selected symbol.

8. Click OK and repeat step 5 to step 7 for each dimension for which you are prompted to select
symbols. When you finish selecting symbols, the Edit Report Batch dialog appears, showing the
report in the Current Items in Batch field.

https://insightsoftware.com/


136

9. In the Current Items in Batch field, select the report, and complete these fields:

Field Description

Output
type

Select one of the following:

n Output to Printer: To print the report.

n Output to PDF: To save the report with the file name extension pdf.

n Output to Image: To save the report as an image file, with the file name
extension png.

Output
Folder

If you chose to save the report as a pdf file or png image file, type the path and folder
name for the location in which you want to save the file.

Output
Filename If you chose to save the report as a pdf file or png image file, type a name for the file.

10. In the Current Items in Batch field, select the report, and complete these fields:

11. Repeat step 4 to step 9 for each report you want to include in the batch.

12. To delete a report from the batch, select the report in the Current Items in Batch field, and click the
left arrow button.

13. When you have finished selecting report templates, choose File > Save. The batch is saved locally.

14. Click the Close button in the top right corner to return to the Longview Analysis and Reporting
dialog.

15. Proceed to Adding report batches to a report batch, or Running report batches.

Adding report batches to a report batch
After the report batch has been created, you can add reports to it. You can also add other batches to it.

Role Can perform this task?

Report Publisher yes

Report Author yes

Report Users yes

The procedure you use differs depending on your role.

Report Publishers
To add a report batch to a report batch, follow these steps.
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1. Create the report batch, as described in Creating a report batch.

2. Open the Longview Analysis and Reporting dialog, and click the Batches tab.

3. If you want to add a report batch to a report batch that you have published to the database, select
the group to which you published it in the Templates published to drop-down list. A list of report
batches published to that group appears. For a list of all report batches, select Any group.

4. Select the report batch to which you want to add a batch and choose File >Open. The Edit Report
Batch dialog appears.

5. The Local Files section lists each DataView and report batch you have saved locally. The Published
Files section lists each report template and report batch you have published to the database for use
by other users. Published report templates and batches are listed according to the groups to which
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they have been published. You can change the group in the Group list.

In either of these sections, select the batch you want to add, and click the right arrow button to move
it to the Current Items in Batch field.

Note: If you intend to publish this report batch to the database, make sure you include
only published report templates and published batches in the report batch.

6. Repeat step 5 for each batch you want to add to the report batch.

7. To remove a batch from the report batch, select the report in the Current Items in Batch field, and
click the left arrow button.

8. When you have finished selecting report batches for the report batch, choose File > Save. The
report batch is saved locally.

Note: You can also publish the report batch to the database so that other users can
access it. Furthermore, if the batch has already been published, saving your changes
does not update the published version of the report batch.

9. Click the Close button in the top right corner to return to the Longview Analysis and Reporting
dialog.

10. Proceed to Adding report templates to a report batch, or Running report batches.

Report Authors and Users
To add a report batch to a report batch, follow these steps.

1. Create the report batch, as described in Creating a report batch.

2. Open the Longview Analysis and Reporting dialog, and click the Batches tab.

https://insightsoftware.com/


139

3. The Local batch files section lists the report batches you have saved locally. The Published
batch files section lists the report batches the Report Publisher has published to the database.
Select the report batch to which you want to add a batch and choose File > Open. The Edit Report
Batch dialog appears.

4. The Local Files section lists batches you have saved locally. The Published Files section lists
report templates and report batches the Report Publisher has published to the database. In either of
these sections, select the batch you want to add, and click the right arrow button to move the batch
to the Current Items in Batch field.
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5. Repeat step 4 for each batch you want to add to the report batch.

6. To remove a batch from the report batch, select the batch in the Current Items in Batch field, and
click the left arrow button.

7. When you have finished preparing the batch, choose File > Save. The report batch is saved locally.

8. Close the Edit Report Batch dialog. The Longview Analysis and Reporting dialog appears.

9. Proceed to Adding report templates to a report batch, or Running report batches.

Opening report batches
You may want to edit the content and settings of your report batches from time to time. To do so, you
must open the batch file you want to edit.

Role Can perform this task?

Report Publisher yes

Report Author yes

Report Users yes

The procedure you use differs depending on your role.

Report Publishers
To open a report batch, follow these steps.

1. Open the Longview Analysis and Reporting dialog, and click the Batches tab.

2. If you want to open a report batch that you have published to the database, select the group to
which you published it in the Templates published to drop-down list. A list of report batches
published to that group appears. For a list of all report batches, select Any group.

https://insightsoftware.com/


141

3. Select the batch you want to edit and choose File > Open. The Edit Report Batch dialog appears.

4. Make changes to the batch as described in Creating report batches.

Report Authors and Users
To open a report batch, follow these steps.

1. Open the Longview Analysis and Reporting dialog, click the Batches tab.

2. To view the most current list of published batches, make sure none of the report batches are
selected (if any template is selected, you can clear it by holding down the Ctrl key and clicking it),
and choose Tools > Refresh.
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3. Select the batch you want to edit and choose File > Open. The Edit Report Batch dialog appears.

4. Make changes to the report batch as described in Creating report batches.

Refreshing report batches
Depending on your role, you may be able to use the refresh feature to restore the content of batches
with the most recently published version of those files.

Refreshing a local batch
You may be able to use the refresh feature to restore the content of a local report batch with the most
recently published version of those files.

Role Can perform this task?

Report Publisher yes

Report Author no

Report Users no

For example, let’s say you publish a report batch to the database, and then make changes to your local
copy. If you decide at a later time that you do not want to publish those changes, you may want to make
your local copy match the published one on the database.

To restore the content of your local report batch, follow these steps.
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1. Open the Longview Analysis and Reporting dialog, and click the Batches tab.

2. For Templates published to select the group to which you published the report batch, the local
version of which you want to restore. A list of report batches published to that group appears. For a
list of all report batches, select Any group.

3. Do one of the following:

l To restore all local report batches that have been published, make sure none of the report
batches in the list is selected (if any report batch is selected, you can clear it by holding down
the Ctrl key and clicking it), and choose Tools > Refresh. A confirmation dialog appears.

Click Yes. The local versions of all published report batches are restored to show the content of
the published versions.

l To restore a single local report batch, select it in the list and choose Tools > Refresh. The local
version of the report batch is restored to show the content of the published version.

Click Yes. The local versions of all published report batches are restored to show the content of
the published versions.

Refreshing a published batch
You may be able to use the refresh feature to refresh the content of batches published to your group with
the most recently published versions.
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Role Can perform this task?

Report Publisher no

Report Author yes

Report Users yes

To refresh the content of a published report batch, follow these steps.

1. Open the Longview Analysis and Reporting dialog, and click the Batches tab.

2. Do one of the following:

l To refresh all published report batches, make sure none of the report batches in the list is
selected (if any file is selected, you can clear it by holding down the Ctrl key and clicking it), and
choose Tools > Refresh.

l To refresh a single published report batch, select it in the list and choose Too ls > Refresh. The
report batch is refreshed.

Running report batches
A report batch runs a collection of reports at one time, rather than individually. For more information on
creating a report batch, see Creating report batches.

Previewing and changing symbols in a report batch
Before you run a batch, you can preview the symbol content of the reports within that batch. Depending
on how the reports were prepared, you may be able to change the symbols as well.
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Role Can perform this task?

Report Publisher yes

Report Author yes

Report Users yes

The procedure you use differs depending on your role.

Report Publishers
To preview the symbol contents of the reports in your report batch, follow these steps.

1. Open the Longview Analysis and Reporting dialog, and click the Batches tab.

2. If you want to preview the symbols in a report batch that you have published to the database, select
the group to which you published it in the Templatespublished to drop-down list. A list of report
batches published to that group appears. For a list of all report batches, select Any group.

3. Select the batch whose symbol content you want to preview and choose File >Open. The Edit
Report Batch dialog appears.
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4. To view the symbol content of a particular report within the batch, select that report in the Current
Items in Batch field, and click the Edit Report Settings icon in the toolbar. The Select Symbols
dialog appears.

5. For Dimension, select the dimension whose symbols you want to view or change. The symbols for
that dimension appear in the Selected Symbols list.

Note: Some buttons and fields may be unavailable. If so, you can only view the symbols in
that dimension of the report.

6. For Dimension, select the dimension whose symbols you want to view or change. The symbols for
that dimension appear in the Selected Symbols list.

7. Depending on how you prepared the report template, you may be able to change its symbols. To do
so, complete step 6 to step 8 in Report Publishers.

8. When you are finished, click OK. The Edit Report Batch dialog appears.

9. Repeat step 4 to step 7 for each report in the batch whose symbols you want to preview.

10. When you are finished previewing the symbol content of the reports in the batch, click the Close
button in the top right corner. The Longview Analysis and Reporting dialog appears.

11. You can proceed to Running a report batch.

Report Authors and Users
To preview the symbol contents of the reports in your report batch, follow these steps.
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1. Open the Longview Analysis and Reporting dialog, and click the Batches tab.

2. Select the batch whose symbol content you want to preview and choose File >Open. The Edit
Report Batch dialog appears.

3. To view the symbol content of a particular report template within the batch, select that report in the
Current Items in Batch field, and click the Edit Report Settings icon in the toolbar. The Select
Symbols dialog appears.
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4. For Dimension, select the dimension whose symbols you want to view or change. The symbols for
that dimension appear in the Selected Symbols list.

Note: Some buttons and fields may be dimmed. If so, you can only view the symbols in
that dimension of the report.

5. Depending on how the Report Publisher prepared the report template, you may be able to change
its symbols. To do so, complete step 5 to step 7 in Report Authors and Users.

6. When you are finished, click OK. The Edit Report Batch dialog appears.

7. Repeat step 3 to step 6 for each report in the batch whose symbols you want to preview.

8. When you are finished, click the Close button in the top right corner. The Longview Analysis and
Reporting dialog appears. You can proceed to Running a report batch.

Running a report batch
A report batch runs a collection of reports at one time, rather than individually. For more information on
creating a report batch, see Creating report batches.

Once you have prepared your report batch, you can run it. Before you do, make sure you have
completed the steps in Previewing and changing symbols in a report batch.

Role Can perform this task?

Report Publisher yes
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Role Can perform this task?

Report Author yes

Report Users yes

The procedure you use differs depending on your role.

Report Publishers
To run a report batch, follow these steps.

1. Open the Longview Analysis and Reporting dialog, and click the Batches tab.

2. If you want to run a report batch that you have published to the database, select the group to which
you published it in the Templates published to drop-down list. A list of report batches published to
that group appears. For a list of all report batches, select Any group.
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3. Select the batch you want to run and choose File > Open. The Edit Report Batch dialog appears.

4. Choose Batch > Run Batch. The Run Report Batch dialog appears, listing the reports and batches
in the report batch.

5. To preview a report, select it and click Preview.
The Report View appears, displaying the report you selected. To close the report, click the Close
button in the top right corner. The Run Report Batch dialog reappears.

https://insightsoftware.com/


151

6. To run the batch, click Run Batch. If any of the reports are printed, the Print dialog appears.

7. Specify your print options as required and click OK. The Batch Status dialog appears, listing any
errors that may have occurred.

8. When the batch is complete, click OK. The Run Report Batch dialog appears.

9. Click the Close button in the top right corner to close the dialog.

Report Authors and Users
When users run a batch published to their group that contains a report that was not published to their
group, that report does not run, but the rest of the batch runs normally.

Note: This assumes that V3 compatibility mode is in effect for your system. Contact your
System Administrator for more information.
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Even if a user belongs to more than one group, he or she is signed on to only one group at a time, and
therefore is limited to running reports published to the currently active group.

To run a report batch, follow these steps.

1. Open the Longview Analysis and Reporting dialog, and click the Batches tab.

2. Select the batch you want to run and choose File > Open. The Edit Report Batch dialog appears.

3. Choose Batch > Run Batch. The Run Report Batch dialog appears, listing the reports and batches
in the report batch.
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4. To preview a report, select it and click Preview. The Report View appears, displaying the report you
selected.

5. To close the report, click the Close button in the top right corner. The Run Report Batch dialog
reappears.

6. To run the batch, click Run Batch. If any of the reports are printed, the Print dialog appears.

7. Specify your print options as required and click OK. The Batch Status dialog appears, listing any
errors that may have occurred.
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8. When the batch is complete, click OK. The Run Report Batch dialog appears.

9. Click the Close button in the top right corner to close the dialog.

Deleting report batches
If you no longer need a report batch, you may be able to delete it.

Role Can perform this task?

Report Publisher yes

Report Author yes, but local report batches only. You cannot delete published report batches.

Report Users yes, but local report batches only. You cannot delete published report batches.

Caution: If you follow this procedure, you cannot reverse your decision. Use with caution.

The procedure you use differs depending on your role.

Report Publishers
To delete a report batch, follow these steps.
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1. Open the Longview Analysis and Reporting dialog, and click the Batches tab.

2. If you want to delete a report batch that you have published to the database, select the group to
which you published it in the Templates published to drop-down list. A list of report batches
published to that group appears. For a list of all report batches, select Any group.

3. For Location, select the folder containing the report batch you want to delete, if necessary.

4. Select the batch you want to delete.

5. Press the Delete key. A confirmation dialog appears.

6. Click Yes. The application deletes the report batch.

Note: When you delete a report batch that has been published to the database, you delete the
local version of that report batch only. The published version still exists on the database.

Report Authors and Users
To delete a report batch, follow these steps.
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1. Open the Longview Analysis and Reporting dialog, and click the Batches tab.

2. For Location, select the folder containing the report batch you want to delete, if necessary.

3. In the Local batch files list, select the report batch you want to delete.

4. Press the Delete key. A confirmation dialog appears.

5. Click Yes. The application deletes the report batch.
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Designing Reports
No matter what your role in Longview Analysis and Reporting and Longview Input, you can view
templates, DataViews, and input views in report format.

Understanding reports and their features
The following illustration shows a report with its main features.

A report consists of the following features:

Feature Description

title The title provides a brief description of the report’s contents.

header
The header provides additional report information, such as the date and time the report was

created.

body
The body of the report consists of the data. You can specify the font for data displayed. Also,

you can choose to either include or omit fixed symbols in the report.

footer The footer provides additional report information, such as page numbering.

column

formats
You can change the column heading
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Feature Description

row

formats
You can change the row heading formats as well as the row heading widths in a report.

print

order

You can specify the order in which the pages of a report are printed — either side to side, or

top to bottom.

Viewing files in report format
No matter what your role in Longview Analysis and Reporting and Longview Input, you can view
templates, DataViews, and input views in report format.

However, the way in which you access the report view may differ according to your role.

Role Can perform this task?

Report

Publisher
yes

Report

Author
yes

Report

User

no. However, when you open a published report template, it automatically appears in
report format. You can ignore the rest of this section.

To view a file in report format, follow these steps.

1. Open the file you want to view in report format.

2. In the template, DataView, or input view, choose View > Report. The report view appears, showing
your file in report format. (If you are an Input Publisher, the data appears as blanks only.)
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Selecting new symbols for reports
Depending on your role and the properties of the file on which the report is based, you may be able to
change the symbols that appear in a report.

To change the symbols in a report, follow these steps.

1. In the report view, choose Format > Choose Symbols. The Symbol Selections dialog may appear,
or you may have to select other dimensions first. (Alternatively, you can right-click on a symbol
name or description, and in the menu that appears, choose Choose Symbols. The Symbol
Selection dialog appears, showing the dimension you chose.)

2. Select symbols, as required.

3. When you are finished selecting your symbols, click OK. The report view appears showing the
symbols you selected.

Navigating reports
You can use various features within the report to navigate and configure your reports.

Navigating through the pages of a report
The reports you open may contain many pages. If so, you can easily navigate through these pages
using the navigation buttons in the report toolbar.

Note: A report contains more than one page only if you selected the With Page Breaks view
mode. Otherwise, the report contains one page only, and the navigation buttons are inactive.
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Changing the magnification of a report You can change the magnification of a report, to make it easier to
read on your computer screen. The magnification setting does not change how the report is printed or
saved.

To change the magnification of a report on your computer screen, select the appropriate percentage in
the Zoom field.

The default value is 100%.

Changing the level of symbol detail
Depending on your role and the properties of the template, you may be able to increase or decrease the
level of hierarchy detail within a report.

To do so, place the arrow pointer over a parent symbol. If a minus sign appears, you can collapse the
hierarchy.
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If a plus sign appears, you can expand the hierarchy. If you expand a down dimension, the hierarchy
expands downwards; if you expand the across dimension, the hierarchy expands to the right.

Expanding and collapsing a hierarchy
You can expand and collapse hierarchies in the down and across dimensions of a report by clicking the
plus and minus signs beside parent symbols, as described in Changing the level of symbol detail.

However, you can also choose a menu command to expand a selected parent symbol to show every
level of symbol detail within it. For example:
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You can also choose a menu command to display one level of detail within each occurrence of a
selected parent symbol.

For example, if you have two outer dimension symbols, each inner dimension symbol occurs twice. You
can expand each occurrence of the same parent symbol in the down or across dimensions to show one
level of detail below the selected parent. For example:
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Expanding hierarchies
To expand hierarchies in a report, follow these steps.

1. Right-click a parent symbol. A pop-up menu appears.

2. Do one of the following:

l Choose Expand All For Selected Symbol. The hierarchy expands to show all symbols within
the selected parent symbol, but only for the selected occurrence of that parent symbol. Other
occurrences of that parent symbol are not expanded.

l Choose Expand One Level for All Occurrences. The hierarchy expands to only the first level of
symbols under the selected parent symbol, for all the occurrences of that parent symbol.

l In a template that includes an inner dimension, expand the inner dimension to display the
symbols you want, and then right-click its corresponding symbol in the outer dimension and
select Expand One - Match Inner Detail. This expands the outer dimension symbol one level
down, and for each outer dimension child symbol, the inner dimension expands to match the
inner dimension expansion of the parent symbol.

l In a template that includes an inner dimension, expand the inner dimension to display the
symbols you want, and then right-click in the outer dimension and select Expand All - Match
Inner Detail. This expands all symbols visible in the outer dimension all levels down, and for
each outer dimension child symbol, the inner dimension expands to match the inner dimension
expansion of the parent symbol.

l Click Expand All For All to expand all the symbols in all the dimensions in a given direction.

Caution: Depending on the number of symbols in your template, the Expand All For
All function has the potential to retrieve huge amounts of data, which may adversely
affect the performance of your system. Use this function with caution.

Collapsing hierarchies
To collapse hierarchies in a report, follow these steps.

1. To collapse all hierarchies in a dimension, right-click any symbol in that dimension, and click
Collapse All. All hierarchies in that dimension are collapsed.

2. To collapse the parent of a symbol, right-click the symbol whose parent you want to collapse and
click Collapse Parent. The parent is collapsed.

Finding a specific symbol in a report
To navigate through a report, you can use the standard method of pressing the arrow keys and scroll
bars. However, this can be time-consuming in a large report. If you know the name of the symbol you
want to find, you can go to it directly.

To find a specific symbol, follow these steps.

1. In the report view, choose Go > Find Symbol. The Find Symbol dialog appears, showing a list of all
symbols in the down dimension and across dimension of the report.
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2. Complete these fields:

Field Description

Dimension Select the dimension containing the symbol.
Symbol List Select the symbol.

3. One or more of the arrow buttons become active, showing the direction in which, the symbol can be
found. Select one of these buttons. The viewing area of the report shifts to display the symbol you
selected, demarcated with a red marker.

4. To return to the report, click Close in the Find Symbol dialog.

Viewing additional information through links
The Publisher of a template may have set up external links to provide additional information about the
template. The additional information may be available through a link to another web site, or perhaps to a
pdf file containing additional information.
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Role Can perform this task?

Report Publisher yes

Report Author yes

Report User yes

There are two types of links:

Field Description

Cell-level

n Used to provide a link to an external URL, to provide additional information on a
particular data cell.

n You can view this link from all cells in the template, except calculated cells or
blank cells.

Template-

level

n Used to provide information related to the template as a whole, such as
instructions, in a pdf file.

n You can view this link from all cells, or from the toolbar or menu.

To view additional information through links, follow these steps.

1. Make sure you are working online. You cannot view links if you are working offline.

2. If any template-level links are associated with this template, all template links are listed in the Links
menu. (If you are not a Publisher, and no template-level links are associated with this template, the
Links menu does not appear at all.)

3. To view additional information related to a particular cell, right-click the cell. If any links of either type
are associated with this template, they appear at the bottom of the pop-up menu.

Formatting reports
After you have opened a report, you may be able to change any or all of its features.

Specifying a title
Depending on your role and the properties of the template, you may be able to create a title for the
report. The title provides a brief description of the report’s contents.

To specify the title of a report, follow these steps.

1. In the report view, choose Format > Edit Global Format. The Global Format dialog appears, with the
Title tab in view.
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2. Click one of the following tabs:

Field Description

Left To place the report title on the left side of the page.
Center To center the report title at the top of the page.
Right To place the report title on the right side of the page.

3. If you want the title to contain text, do the following:
a. In the Text field, type a title for the report.

b. Complete these fields:

Field Description

Font Select a font for the report title.
Font Style Select a font style for the report title.
Size Select a font size for the report title.

4. You can insert additional items whose values may change — for example, the page number or
current date. The application inserts a token as a placeholder, to ensure that the date shown on the
report, for example, is always current when saved. The token appears in the format:

%%TokenName%%

To use a token to insert information into the title, click the following icons as required:

Icon Description

To insert the schedule name, description, or both, into the report title. This option applies
only if the report contains schedule information.
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Icon Description

To insert the date into the report title.

To insert the time into the report title.

To insert the page number into the report title.

To insert the page number and total number of pages into the report title — for example, “2 of
10”.

To insert the name of the template into the report title.

To insert the current user’s full name into the report title.

To insert a list of the report’s root symbols for a particular dimension into the report title.
Make sure you select the appropriate dimension in the Dimension field.

5. You can insert attribute values into the title by inserting an attribute token. To insert an attribute
token into the title, enter the following into the Text field:

<%[[ATTRIBUTE,AttrClass,AttrName,ObjectName]]%>

where:

l AttrClass is the attribute class. It can be SYSTEM, SYMBOL, USER, or GROUP.

Note: The GROUP attribute class can be used only with DESCRIPTIONs specified
for the AttrName parameter, which retrieves the current user group description.

l AttrName is the attribute name.

l ObjectName is the attribute object. System attributes and the GROUP attribute class do not
require an object. ObjectName is mandatory for symbol attributes and specifies the symbol
name. ObjectName is optional for user attributes and specifies the user ID. If no ObjectName is
specified, the current user ID is used.

Note: You can also specify other tokens for the ObjectName parameter; for example,
%%TIMEPER%%. For this token to resolve correctly, the dimension must have one
symbol selected and only the symbol name displayed. For more information, see
Specifying general settings.

For example:

<%[[ATTRIBUTE, SYMBOL, ZGPNativeCurrency, %%ENTITIES%%]]%>

For more information on attribute tokens, see the Longview Dashboard Designer Guide.
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6. To insert an image, such as your company logo, into the title, do the following:
a. Select Image.

b. For Image File, type the name and path of the image file you want to use. If you are not sure of
the file’s name or location, click Browse.

7. To see what the report looks like when printed, click OK. The report view appears, showing your
changes.

Specifying a header
Depending on your role and the properties of the template, you may be able to create a header to
provide more information about the report. The header may provide additional information such as the
date and time the report was created.

To specify the header in a report, follow these steps.

1. In the report view, choose Format > Edit Global Format. The Global Format dialog appears.

2. Click the Header tab.

3. Click one of the following tabs:

Field Description

Left To place the report header on the left side of the page.
Center To center the report header at the top of the page.
Right To place the report header on the right side of the page.
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4. If you want the header to contain text, do the following:
a. In the Text field, enter text for the header.

b. Complete these fields:

Field Description

Font Select a font for the report header.
Font Style Select a font style for the report header.
Size Select a font size for the report header.

5. You can insert additional items whose values may change — for example, the page number or
current date. The application inserts a token as a placeholder, to ensure that the date shown on the
report, for example, is always current when saved. The token appears in the format:

%%TokenName%%

To use a token to insert information into the header, click the following icons as required:

Icon Description

To insert the schedule name, description, or both, into the header. This option applies only if
the report contains schedule information.

To insert the date into the header.

To insert the time into the header.

To insert the page number into the header.

To insert the page number and total number of pages into the header — for example, “2 of
10”.

To insert the name of the template into the header.

To insert the current user’s full name into the header.

To insert a list of the report’s root symbols for a particular dimension into the report header.
Make sure you select the appropriate dimension in the Dimension field.

6. You can insert attribute values into the header by inserting an attribute token. To insert an attribute
token into the header, enter the following into the Text field:

<%[[ATTRIBUTE,AttrClass,AttrName,ObjectName]]%>

where:
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l AttrClass is the attribute class. It can be SYSTEM, SYMBOL, USER, or GROUP.

Note: The GROUP attribute class can be used only with DESCRIPTION specified for
the AttrName parameter, which retrieves the current user group description.

l AttrName is the attribute name.

l ObjectName is the attribute object. System attributes and the GROUP attribute class do not
require an object. ObjectName is mandatory for symbol attributes and specifies the symbol
name. ObjectName is optional for user attributes and specifies the user ID. If no ObjectName is
specified, the current user ID is used.

Note: You can also specify other tokens for the ObjectName parameter; for example,
%%TIMEPER%%. For this token to resolve correctly, the dimension must have one
symbol selected and only the symbol name displayed. For more information, see
Specifying general settings.

For example:

<%[[ATTRIBUTE, SYMBOL, ZGPNativeCurrency, %%ENTITIES%%]]%>

For more information on attribute tokens, see the Longview Dashboard Designer Guide.

7. To insert an image, such as your company logo, into the header, do the following:
a. Select Image.

b. For Image File, type the name and path of the image file you want to use. If you are not sure of
the file’s name or location, click Browse.

8. To see what the report looks like when printed, click OK. The report view appears showing your
changes.

Specifying a footer
Depending on your role and the properties of the template, you may be able to create a footer to provide
more information about a report. The footer may provide additional report information such as page
numbering and total number of pages in the report.

To specify a footer for a report, follow these steps.
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1. In the report view, choose Format > Edit Global Format. The Global Format dialog appears.

2. Click the Footer tab.

3. Click one of the following tabs:

Field Description

Left To place the report footer on the left side of the page.
Center To center the report footer at the bottom of the page.
Right To place the report footer on the right side of the page.

4. If you want the footer to contain text, do the following:
a. In the Text field, type text for the footer.

b. Complete these fields:

Field Description

Font Select a font for the report footer.
Font Style Select a font style for the report footer.
Size Select a font size for the report footer.

5. You can insert additional items whose values may change — for example, the page number or
current date. The application inserts a token as a placeholder, to ensure that the date shown on the
report, will always be current when saved. The token appears in the format:

%%TokenName%%

To use a token to insert information into the footer, click the following icons as required:
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Icon Description

To insert the schedule name, description, or both, into the footer. This option applies only if
the report contains schedule information.

To insert the date into the footer.

To insert the time into the footer.

To insert the page number into the footer.

To insert the page number and total number of pages into the footer — for example, “2 of 10”.

To insert the name of the template into the footer.

To insert the current user’s full name into the footer.

To insert a list of the report’s root symbols for a particular dimension into the report footer.
Make sure you select the appropriate dimension in the Dimension field.

6. You can insert additional items whose values may change — for example, the page number or
current date. The application inserts a token as a placeholder, to ensure that the date shown on the
report will be current when saved. The token appears in the format:

<%[[ATTRIBUTE,AttrClass,AttrName,ObjectName]]%>

where:

l AttrClass is the attribute class. It can be SYSTEM, SYMBOL, USER, or GROUP.

Note: The GROUP attribute class can be used only with DESCRIPTION specified for
the AttrName parameter, which retrieves the current user group description.

l AttrName is the attribute name.

l ObjectName is the attribute object. System attributes and the GROUP attribute class do not
require an object. ObjectName is mandatory for symbol attributes and specifies the symbol
name. ObjectName is optional for user attributes and specifies the user ID. If no ObjectName is
specified, the current user ID is used.

Note: You can also specify other tokens for the ObjectName parameter; for example,
%%TIMEPER%%. For this token to resolve correctly, the dimension must have one
symbol selected and only the symbol name displayed. For more information, see
Specifying general settings.

For example:
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<%[[ATTRIBUTE, SYMBOL, ZGPNativeCurrency, %%ENTITIES%%]]%>

For more information on attribute tokens, see the Longview Dashboard Designer Guide.

7. To insert an image, such as your company logo, into the header, do the following:
a. Select Image.

b. For Image File, type the name and path of the image file you want to use. If you are not sure of
the file’s name or location, click Browse.

8. To see what the report looks like when printed, click OK. The report view appears showing your
changes.

Formatting the report body
The body of the report contains your data. Depending on your role and the properties of the template,
you may be able to specify the underlines, gridlines, grid-shading, and frames used to accentuate your
data, as well as the number formatting in which your data is displayed.

To specify the fonts in which your data is displayed, see Formatting columns, and Formatting rows.

To format the body of the report, follow these steps.

1. In the report view, choose Format > Edit Global Format. The Global Format dialog appears.

Note: To display the report view, select View > Report.

2. Click the Report Body tab.
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3. In the Appearance section, complete these fields:

Field Description

Automatic
Underline

Select this field if you want parent symbols automatically separated from their
children with an underline.

Frame Select this field if you want the body of the report framed with a border. Select
the type of border in the drop-down list.

Show Gridlines Select this field if you want gridlines separating each row and column.

Gridshade Select this field if you want alternating rows or columns shaded. Then, select
one of the two corresponding options in the drop-down list.

Show Conditional
Display Highlights

Select this field if you want the conditional highlighting and colors to be
carried over into the report view and Web reports.

Note: Conditional display highlights are overridden by symbol
shading.

4. For Alternate Zero Indicator, select this field if you want a character other than 0 to represent zero
values, and then select the alternate character in the drop-down list.

5. To see what the report looks like when printed, click OK. The report view appears showing your
changes.

Formatting columns
Depending on your role and the properties of the template, you may be able to specify the font in which
column headings appear as well as the width of a report’s columns.

To specify the font of column headings and the width of columns in a report, follow these steps.
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1. In the report view, choose Format > Edit Global Format. The Global Format dialog appears.

2. Click the Columns tab.

3. In the Column Headings section, complete these fields:

Field Description

Font Select a font for the column headings.
Font Style Select a font style for the column headings.
Size Select a font size for the column headings.
Underline headings for inner
dimension Select this to underline inner dimension headings.

Underline headings for outer
dimensions Select this to underline outer dimension headings.

Bold headings for expanded
parentsUnderline

Select this to bold the parents in the column headers when the
parent is expanded.

4. In the Column Widths section, complete these fields.

Field Description

To Fit - columns adjust
to widest content

To specify the width of the report columns as the width of the column with
the longest description or largest number.

Specify Width – enter
value below

To specify the width of the report columns as something other than the
default. Enter the number of spaces in the field.

Wrap Text If you want text to wrap to the width of columns, select this option.
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5. In the Column Options section, complete the following.

Field Description

Display column
headings on all
pages

Select this field if you want the column headers displayed on all pages of the
report. Otherwise, clear this field and the column headers appear on the first
page only.

6. To see what the report looks like when printed, click OK. The report view appears showing your
changes.

Formatting rows
Depending on your role and the properties of the template, you may be able to specify the font in which
both leaf symbol and parent rows appear, as well as the width of row headings in a report.

To specify the font for leaf and parent rows, and the width of row headings in a report, follow these steps.

1. In the report view, choose Format > Edit Global Format. The Global Format dialog appears.

2. Click the Rows tab.

3. In the Leaf Row Font section, complete these fields:

Field Description

Font Select a font for the leaf rows.
Font Style Select a font style for the leaf rows.
Size Select a font size for the leaf rows.

https://insightsoftware.com/


177

Field Description

Vertical Align

Select a row alignment for the leaf rows from one of:

n Top

n Middle

n Bottom

4. In the Parent Row Font section, complete these fields:

Field Description

Font Select a font for the parent rows.
Font Style Select a font style for the parent rows.
Size Select a font size for the parent rows.

Vertical Align

Select a row alignment for the parent rows from one of:

n Top

n Middle

n Bottom

5. In the Default Row Heading Width section, complete these fields.

Field Description

To Fit - columns adjust
to widest content

To specify the width of the report columns as the width of the column with
the longest description or largest number.

Specify Width – enter
value below

To specify the width of the report columns as something other than the
default. Enter the number of spaces in the field.

Displaying scaling settings
The format in which the data in a report appears is called scaling. For example, if you are dealing with
very large numbers, you may want to view those numbers in, say, thousands or millions. This makes the
numbers easier to read.

Depending on your role and the properties of the template, you may be able to specify whether the
scaling setting used in the report is displayed.

To specifying whether the scaling setting of a report is displayed, follow these steps.
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1. In the report view, choose Format > Edit Global Format. The Global Format dialog appears.

2. Click the Scaling tab.

3. Complete these fields:

Field Description

Display
Global
Scaling

To display an indicator of the scaling used in the report, select this field.

Position Select the position within the report in which you want to display the scaling
indicator.

Display on all
pages

Select this field to display the scaling indicator on all pages of the report. Otherwise,
the scaling indicator appears on the first page only.

Font Select a font for the scaling information.
Font Style Select a font style for the scaling information.
Size Select a font size for the scaling information.

4. To see what the report looks like when printed, click OK. The report view appears showing your
changes.
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5. In the Row Heading Options section, complete these fields.

Field Description

Indent

Use the radio buttons to select whether Parent Rows or Leaf Rows are indented in the
report, and the drop-down list to specify how many spaces (0-5) each row should be
indented relative to next level of the hierarchy.

If Parent Rows is selected, leaf symbols in the hierarchy are displayed furthest left in
the report, with parent symbols increasingly indented right the higher in the hierarchy
they reside. If Leaf Rows is selected, the root symbol of the hierarchy is displayed
furthest left in the report, with child and leaf symbols increasingly indented right the
deeper in the hierarchy they reside.

Display
row
headings
on all
pages

Select this field to show row headings on all pages of the report. Otherwise, row
headings appear on the first page only, while all other pages in the report show data
only.

6. To see what the report looks like when printed, click OK. The report view appears showing your
changes.

Changing the position of row headings
Depending on your role and the properties of the template, you may be able to move the row headings in
a report to a new position.

The following illustration shows the row headings in the default position.

To change the position of the row headings, follow these steps.

1. In the report view, do one of the following:

l For View Mode, select Without Page Break.

l Enable the Fit to page option so that the report’s contents fit to one page. To do so, choose
Format > Edit Global Format. The Global Format dialog appears.
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2. Click the Other tab.

3. Make sure Fit to is selected, and select 1 page wide by 1 page tall, in the corresponding fields.

4. Right-click on the heading of the column beside which you want to place the row headers. A pop-up
menu appears.

5. Choose Insert Row Heading, followed by either Before Column or After Column. The row
headings appear in the location you specified.

Specifying fixed symbols
Each dimension needs a reference to an individual default symbol in the dimension. The fixed symbol is
a single symbol selected in one of the fixed dimensions.

By default, each fixed symbol in a report is displayed on all pages of that report, below the data.
Depending on your role and the properties of the template, you may be able to change the position of
these symbols, display them on the first page of the report only, or leave them out of the report
altogether.

To specify the fixed symbols of a report, follow these steps.
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1. In the report view, choose Format > Edit Global Format. The Global Format dialog appears.

2. Click the Fixed Symbols tab.

3. In the Font section, complete these fields:

Field Description

Font Select a font for the fixed symbols.
Font Style Select a font style for the fixed symbols.
Size Select a font size for the fixed symbols.

4. In the Display Options section, complete these fields.

Field Description

Display fixed symbols To display the fixed symbols in the report, select this field.
Position You can display the fixed symbols either above or below the data.
Display on all pages To display the fixed symbols on all pages of the report, select this field.

5. To see what the report looks like when printed, click OK. The report view appears showing your
changes.

Formatting an individual symbol
Depending on your role and the properties of the template, you may be able to edit the appearance of
individual symbols in a report. For example, you may want to underline a specific symbol, add shading to
another, or change the font of another.

For example, in the following illustration, the Total revenue symbol is outlined and shaded, for easier
identification.
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To edit the format of an individual symbol, follow these steps.

1. In the report view, choose Format > Edit Symbol Format, and select the dimension containing the
symbols you want to change. (Alternatively, you can right-click on a symbol name or description,
and in the menu that appears, choose Edit Symbol Format.) The Symbol Format dialog appears,
with the Font tab in view.

2. In the drop-down list in the Symbol Format section, select the symbol whose format you want to edit.
This symbol appears in the list box above, which lists all symbols with special formatting in the
report.

3. Make sure the symbol whose format you want to edit is selected in the list box.

4. Clear the Use Global Font field. The other fields on this tab become active.

5. Complete these fields:

Field Description

Font Select a font for the symbol.
Font Style Select a font style for the symbol.
Size Select a font size for the symbol.
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6. To revert back to the original font, select Use Global Font.

7. Click the Display Options tab.

8. Make sure the symbol whose display options you want to edit is selected in the list box, and
complete these fields:

Field Description

Outline

Select this if you want the symbol’s row or column outlined. Then, in the corresponding
drop-down list, select one of the following:

n Data Only: To outline the data only.

n Data and Header: To outline both the data and heading.

n Data and Bordered Header: To outline both the data and heading, and to add
a border around the header. This option is available only for column symbols.

Shade

Select this if you want the row or column shaded. Then, in the corresponding drop-
down list, select one of the following:

n Data Only: To shade only the data.

n Data and Header: To shade both the data and header.

n Header only: To shade only the header.

Underline

Select this if you want the row underlined. Then, in the corresponding drop-down list,
select one of the following:

n Single: To underline the data for the symbol with a single line.

n Double: To underline the data for the symbol with a double line.
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Field Description

Vertical
Align

This option is available only for row symbols. Select this if you want to change the
vertical alignment of the row. Then, in the corresponding drop-down list, select one of
the following:

n Use Global Setting: To use the global alignment setting.

n Top: To align the symbol to the top of the report.

n Middle: To align the symbol to the middle of the report.

n Bottom: To align the symbol to the bottom of the report.

Prefix If necessary, type a character to precede the data in the cell. For example, you may
want to place a dollar sign ( $ ) before the data.

Left
Justify

Select this to left justify the prefix within the cell. This is useful if you want to align the
prefixes in the report. If you do not select this, the prefix appears immediately to the left
of the first digit in the value.

Suffix If necessary, type a character to follow the data in the cell. For example, you may want
to place a percent sign ( % ) after the data.

If you are editing the format of a column symbol, the Vertical Align option is not available and
additional fields are available under Column Widths.
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9. In addition to the fields listed above, complete the following fields:

Field Description

Use Global
Width Select this option if you want to use the global width for columns.

Specify
Width

To specify the width of the report columns as something other than the default. Enter
the number of spaces in the field.

Wrap Text If you want text to wrap to the width of columns, select this option.

Formatting an individual cell
Depending on your role and the properties of the template, you may be able to edit the format of
individual cells in a report, to make specific intersections of data stand out for easy identification.

For example, in the following report, the cell containing total revenue for the third quarter of 2003 stands
out from the rest of the report.

To edit the format of an individual cell, complete these steps.

1. In the report view, choose Format > Edit Cell Format. (Alternatively, you can right-click on a cell, and
in the menu that appears, choose Edit Cell Format.) The Cell Format dialog appears, with the Font
tab in view.
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2. In the Symbol section, select a symbol for each dimension in the database, to specify the cell’s
coordinates.

3. Click New. The cell’s coordinates appear in the large field above. This field lists all the cells in the
report that have special formatting. To delete special formatting from a cell at any time, select it in
this field, and click Delete.

4. If you do not want to use the default fonts, clear the Use Default Font field. The other fields become
active.

5. Complete these fields:

Field Description

Font Select a font for the data in the cell.
Font Style Select a font style for the data in the cell.
Size Select a font size for the data in the cell.

6. To revert back to the original font, select Use Global Font.
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7. Click the Display Options tab in the Cell Format dialog.

8. Complete these fields:

Field Description

Outline Select this option to outline the cell.
Shade Select this option to shade the cell.

Prefix If necessary, type a character to precede the data in the cell. For example, you may want
to place a dollar sign ( $ ) before the data.

Left
Justify

Select this option to left justify the prefix within the cell. This is useful if you want to align
the prefixes in the report. If you do not select this, the prefix appears immediately to the
left of the first digit in the value.

Suffix If necessary, type a character to follow the data in the cell. For example, you may want to
place a percent sign ( % ) after the data.

9. Click OK. The report view appears showing your changes.

Adjusting spacing in reports
To make a report easier to read, you may be able to separate certain symbols by inserting a blank row or
column between them. Depending on your role and the properties of the template, you may be able to
insert blank rows or columns.

Creating a spacing row or column in a report
To make a report easier to read, you may want to separate certain symbols by inserting a blank row or
column between them.

To create a blank row or column in a report, follow these steps.
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1. In the report view, find the symbol beside which you want to create a blank symbol.

2. Right-click on the symbol. A pop-up menu appears.

3. Choose Insert Blank Symbol. The Create Blank Symbol dialog appears.

4. Complete these fields:

Field Description

Before To insert the blank symbol before the symbol you selected in step 1, select this field.
After To insert the blank symbol after the symbol you selected in step 1, select this field.

5. If you don’t want to use the global font, clear the Use Global Font field. The other Display Options
fields become active.

Field Description

Column
Width

If you don’t want to use the global column width, select Specify Width from the drop-
down list, then type in your desired width in the adjacent field.

Note: The column width field is only displayed when creating a blank
symbol for a column.

Font Select a font for the blank symbol description.
Font Style Select a font style for the blank symbol description.
Size Select a font size for the blank symbol description.

Description If necessary, type a description for the blank symbol. This description is only shown in
the report view.
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6. Click OK. The report appears, showing the extra spacing.

Editing a spacing row or column in a report
You may want to edit a blank row or column in a report.

To edit a blank row or column, follow these steps.

1. In the report view, find the blank symbol you want to edit.

2. Right-click on the symbol. A pop-up menu appears.

3. Choose Edit Blank Symbol. The Edit Blank Symbol dialog is displayed. Make your required changes
to the blank symbol.

Deleting a spacing row or column from a report
You may want to delete a blank row or column in a report.

To delete a blank row or column, follow these steps.

1. In the report view, find the blank symbol you want to delete.

2. Right-click on the symbol. A pop-up menu appears.

3. Choose Remove Blank Symbol. The report appears, with the blank symbol deleted.

Viewing input comments
You can view the comments associated with data included in a report.

You cannot create comments in Longview Analysis and Reporting. You can only view the comments
that others have created in Longview Input.

You can view comments only if the data cells they are associated with are currently visible in the report.

To view input comments in a report, follow these steps.

1. In the template, DataView, or input view, choose View > Report. The report view appears.

2. Select one of the following in the Display drop-down list.

Field Description

Data Only To view only the data in the report.
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Field Description

Comments
Only To view only the comments in the report.

Data and
Comments

To view both the data and comments in the report. If you select this option, you may
have to use the navigation buttons to find the page containing the comments.

The comments appear in the report, showing the cell coordinates, the date, and the author, of the
comments.

3. To revert back to viewing data only, select Data Only in the Display drop-down list.

Printing reports
Once you have prepared a report, you can print it.

Working with page breaks
In reports that span multiple pages, the application automatically inserts page breaks so that the report
can be easily printed. However, these page breaks may not be where you want them.

Depending on your access, you can manually insert page breaks wherever you want in a report.

Note: Manually inserted page breaks do not appear in reports or templates accessed on the
web.

Adding a page break
To add a page break to a report, follow these steps.

1. In the report view, select Without Page Break in the View Mode drop-down list. The report appears
in Without Page Break mode.

2. Right-click anywhere in the body of the report. A pop-up menu appears.
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3. Choose Show Page Break Grid. The report is outlined with a blue frame.

4. Right-click on the row or column heading next to which you want to add a page break. (For symbols
in the across direction, the page break is added to the right of the selected symbol. For symbols in
the down direction, the page break is added below the selected symbol.) A pop-up menu appears.

5. Choose Add Page Break. A dashed blue line appears beside the symbol, signifying a page break.

6. Repeat step 4 and step 5 for each page break you want to add.

7. When you are finished adding page breaks, select With Page Break in the View Mode drop-down
list. The report appears in With Page Break mode, divided into the pages you defined.

Removing a page break
To remove a page break, follow these steps.

1. In the report view, select Without Page Break in the View Mode drop-down list. The report appears
in Without Page Break mode.
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2. If the page break grid is not already showing, right-click anywhere in the report. A pop-up menu
appears.

3. Choose Show Page Break Grid. The page break grid appears displaying all existing page breaks.

4. Right-click on the symbol next to which you want to remove a page break. (For symbols in the
across direction, page breaks appear to the right of the selected symbol. For symbols in the down
direction, page breaks appear below the selected symbol.) A pop-up menu appears.

5. Choose Remove Page Break. The page break is removed.

Note: The only way to remove all manually created page breaks in a report is to remove each
one individually using the steps in this procedure.

Specifying print order
Depending on your role and the properties of the template, you may be able to specify the order in which
the pages of a report are printed — either from left to right, or top to bottom. Also, you can specify
whether the entire contents of the report fit onto one page or not. Settings in this dialog are automatically
used for printing Web reports and templates.

To specify the order in which the pages of a report are printed, follow these steps.
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1. In the report view, choose Format > Edit Global Format. The Global Format dialog appears.

2. Click the Other tab.

3. Complete these fields:

Field Description

Print
Order Select the direction in which you want to print the report.

Adjust
to Select the print size in the report as a percentage of the normal size.

Fit to Select this field to have the entire contents of the report fit into the number of pages you
specify in the corresponding fields.

4. To see what the report looks like when printed, click OK. The report view appears showing your
changes.

Specifying printer options
You can specify printer settings for reports — page width, page orientation, printer tray to use, and so
on. You specify printer options in the Page Setup dialog. Paper and orientation settings specified in this
dialog are used automatically when printing the report from the web.

To specify your printer options, follow these steps.
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1. Choose File > Page Setup. The Page Setup dialog appears.

2. Complete these fields:

Field Description

Size Select the paper size for the report.
Source Select the printer paper tray containing the correct paper for the report.
Orientation Select an orientation for the report.
Margins (inches) Select the top, bottom, left, and right margins for the report.

3. When you are satisfied with the printer settings, click OK. The report view appears.

4. Proceed to Printing a report.

Printing a report
Once you have prepared your report, you can print it. Before you do, make sure you have specified your
printer settings. For more information, see Specifying printer options.

To print a report, follow these steps.
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1. In the report view, choose File > Print. The Print dialog appears.

2. Specify your printing options as required.

3. Click OK. Your report is printed, and the report view appears.

Saving reports
Once you have prepared your report, you can save it.

Saving a report in Acrobat (pdf) format
You can save a report in Acrobat format. An Acrobat document appears in portable document format
and is identified by its file name extension pdf. Reports that you save in Acrobat format are read-only
and can be viewed on any platform.

This is an ideal format for reports you want to post on the company network or intranet.

To view Acrobat documents, you need to have the free Acrobat Reader software, version 6.0 (or later),
installed on your computer. If necessary, you can download the latest version of the software from:
http://www.adobe.com

Role Can perform this task?

Report Publisher yes

Report Author yes

Report User yes

To save a report in Acrobat format, follow these steps.
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1. In the report view, choose File > Save As. The Save dialog appears.

2. Complete these fields:

Field Description

Save in Select the folder in which you want to save the report.
File name Type a name for the report.
Save as type Select Acrobat PDF (*.pdf).

3. Click Save. The file is saved, and the report view appears.

Saving a report in portable network graphics (png)
format
You can save a report in portable network graphics format. This type of file is read-only and is viewed as
a graphic file through a web browser.

This is an ideal format for reports you want to post on the company network or intranet.

Role Can perform this task?

Report Publisher yes

Report Author yes

Report User yes

To save a report in portable network graphics format, follow these steps.
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1. In the report view, choose File > Save As. The Save dialog appears.

2. Complete these fields:

Field Description

Save in Select the folder in which you want to save the report.
File name Type a name for the report.
Save as type Select PNG File (*.png).

3. Click Save. The file is saved, and the report view appears.
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Publishing Report Templates And Batches
When you are finished working on a template, you need to make it available to the people in your
company. To make a template available for use, you publish it.

Publishing report templates
To make a template available to other users, you need to publish it.

Preparing to publish a report template
Do not rush to publish before a template is complete. If you have to make changes to a template that has
already been published, you have to republish it as well, so that the changes are available to users.

Caution: If you publish a template that contains errors or omissions, and your user population
starts to use it, logistical issues can result if you have to modify and republish the template at a
later time. Before publishing a template, be sure to test it thoroughly to ensure its
completeness and accuracy.

Editing dimension and symbol control
When you create a report template, you can specify the level of symbol control that users have in the
published version of that report template.

For more information, see Saving a report template - Report Publishers.

Role Can perform this task?

Report Publisher yes

Report Author no

Report User no

You may want to keep tight control of the dimensions and symbols used in the report. Alternatively, you
may prefer to give users the ability to make some choices on their own.

The way in which you establish the level of control is by specifying whether dimensions are frozen and
drillable:

n A frozen dimension is one in which the Report Publisher selects the symbols that can be used
by the Report User.

n A drillable dimension is one in which the Report User has the ability to expand and collapse the
symbol hierarchies within it.

Depending on the combination you select, you can specify the choices of the Report User.
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Combination Report Publisher Report User

Frozen + Not Drillable
Sets default symbols

for the dimension.

Cannot select symbols.

Can expand or collapse the hierarchy and see data for
any symbol in the hierarchy below the default symbols.

Frozen + Drillable 
Sets default symbols

for the dimension.

Cannot select symbols.

Can expand or collapse the hierarchy and see data for
any symbol in the hierarchy below the default symbols.

Drillable + not Frozen

(If a dimension is not
frozen, it is
automatically
drillable.)

Does not enforce

default symbols for

the dimension.

Is prompted to select symbols in the dimension when
opening the report, if symbols have not already been
selected by the Report Publisher.

If the symbols have already been selected by the
Publisher, the Report User can change them.

Note: To force Report Users to make symbol selections when opening a template, you can
leave any of the down, across, and fixed dimensions blank when publishing.

To specify the Report Users’ level of symbol control in a report template, follow these steps.

1. Open the report template. For more information, see Opening a report template - Report Publishers.

2. Choose Edit > Frozen Symbols. The Select Frozen Dimensions dialog appears.
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3. For each dimension you want to change, complete these fields, as per the table in the introduction
to this section:

Field Description

Frozen Select this field to specify that the dimension is frozen.

Drillable
If Frozen is cleared for this dimension, this field is automatically selected and cannot
be cleared.
Select this field to specify that the dimension is drillable.

Available
Symbols

This field is available only if Frozen is cleared for this dimension. This field is
unavailable for Schedule dimensions.

Click the symbol selector button ( ... ) and use the Available Symbol Selection dialog
to specify the symbols that are available to Report Users in the Symbol Selections
dialog in the template.

If you do not specify any symbols for this field, all symbols that Report Users have
access to in the dimension are available.

Note: The symbols specified for this field should include the symbols
selected for the template in Specifying orientation and symbols in a
template. If a symbol is selected in the template and is not specified as an
available symbol, Report Users cannot reselect it if they remove it in the
Symbol Selections dialog.

Resolution
Depth

This field is available only if Frozen is selected for this dimension.

Specify the number of levels to go down in the hierarchy until a symbol the Report
User has access to is reached. This number is only applicable when a template is set
to use a symbol above the Report User’s access in the hierarchy.

This number may be entered manually (valid values are from 0 to 99) or can be
selected by clicking the cell and selecting the number from the drop-down list. The
default value for this field is 99.

4. Click OK. The report template appears.

5. Save the report template.

Publishing a report template
When you are finished working on a report template, you need to make it available to the people in your
company. To make a report template available for use, you publish it.

Role Can perform this task?

Report Publisher yes

Report Author no

Report User no
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When you publish a report template to the database, any unsaved changes are automatically saved to
the local version of the template as well.

From the Longview Analysis and Reporting dialog
To publish a template from the Longview Analysis and Reporting dialog, follow these steps.

1. Make sure the dimension and symbol control settings are properly defined in the template. For more
information, see Editing dimension and symbol control.

2. Open the Longview Analysis and Reporting dialog and click the Template stab. A list of templates
appears.

Files are listed numerically and alphabetically. If a template has been published, the groups to
which it has been published appear in the Published to groups column.

3. To see all of your existing templates, select Any group in the Templates published to field.

4. Select the template you want to publish. You can select more than one by holding down the Ctrl key
while making your selections.

5. Choose File > Publish, and do one of the following:

l If you selected only one template in step 4, or multiple templates that were originally published
to exactly the same groups, the Publish Template dialog appears.
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Proceed to step 6.

l If you selected more than one template in step 4, and those templates were originally published
to different groups, the Publish Templates dialog appears listing the templates you selected,
and the groups to which they were originally published.

If you are happy with these settings, click OK. The templates are published to the groups listed
in the Published to groups field, and the Longview Analysis and Reporting dialog appears.

Otherwise, click Cancel. The Longview Analysis and Reporting dialog appears. Return to the
beginning of this procedure.
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6. In the Do not publish to groups field, select the groups to which you want to publish the template,
and move them to the Publish to groups field using the right arrow button. You can select more than
one group at a time by holding down the Ctrl key while making your selections.

Note: The groups that appear in these fields represent all groups to which the Report
Publisher belongs (not necessarily all groups on the application database).

7. Click OK. The Longview Analysis and Reporting dialog appears. The groups to which the template
has been published appear in the Published to groups column.

From the view window
To publish a template from the view window, follow these steps.

1. If you have not already saved the view as a report template, do so now. For more information, see
Saving a report template - Report Publishers.

2. Make sure the dimension and symbol control settings are properly defined. For more information,
see Editing dimension and symbol control.

3. In the view window, choose File > Publish/Unpublish. The Publish/Unpublish Template dialog
appears.
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4. In the Do not publish to groups field, select the groups to which you want to publish the template,
and move them to the Publish to groups field using the right arrow button. You can select more than
one group at a time by holding down the Ctrl key while making your selections.

Note: The groups that appear in these fields represent all groups to which the Publisher
belongs (not necessarily all groups on the application database).

5. Click OK. The template is published, and the view reappears.

Unpublishing a report template
The Report Publisher may need to edit a published template from time to time. To edit a published
template, you should make it temporarily unavailable for use, so that users do not start to use the
incorrect published version. To do so, you unpublish it.

Role Can perform this task?

Report Publisher yes

Report Author no

Report User no

If you want to keep a copy of a template for future use, make sure to open the template first, before
unpublishing. When you open the template, you automatically create a copy on your hard drive.
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Caution: If you unpublish a report template associated with a workflow process, and users try
to access the template through the process, they will see an error message.

To unpublish a published template, follow these steps.

1. Open the Longview Analysis and Reporting dialog and click the Template stab. A list of templates
appears.

Files are listed numerically and alphabetically. If a template has been published, the groups to
which it has been published appear in the Published to groups column.

2. For Templates published to select the group to which you published the report template that you
now want to unpublish. A list of report templates published to that group appears. For a list of all
your existing report templates, select Any group.

3. Select the template you want to unpublish. You can select more than one by holding down the Ctrl
key while making your selections.

4. Choose File > Unpublish, and do one of the following:

l If you selected only one template in step 3, or multiple templates that were originally published
to exactly the same groups, the Unpublish Template dialog appears.
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Proceed to step 5.

l If you selected more than one template in step 3, and those templates were originally published
to different groups, the Unpublish Templates dialog appears listing the templates you selected,
and the groups to which they were originally published.

If you are happy with these settings, click OK. The templates are unpublished from the groups
listed in the Published to groups field, and the Longview Analysis and Reporting dialog
appears.

Otherwise, click Cancel. The Longview Analysis and Reporting dialog appears. Return to the
beginning of this procedure.
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5. In the Publish to groups field, select the groups from which you want to remove access to the
template, and move them to the Do not publish to groups field using the left arrow button. You can
select more than one group at a time by holding down the Ctrl key while making your selections.

Note: The groups that appear in these fields represent all groups to which the Report
Publisher belongs (not necessarily all groups on the application database).

6. Click OK. The Longview Analysis and Reporting dialog appears.

Assigning report templates to categories
You may have to work with a large number of report templates. In order to better sort and organize
report templates, you can assign them to categories.

Role Can perform this task?

Report Publisher yes

Report Author no

Report User no

Creating a category
You must create a category before you can assign a template to that category.

To create a category, follow these steps.

1. Open the Longview Analysis and Reporting dialog, and click the Categories tab. A list of categories
appears.
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2. Choose File > New. The Create Category dialog appears.

3. Complete the following fields:

Field Description

Name
Enter a name for the category. You can use all characters except for the following:
backslash ( \ ), forward slash ( / ), apostrophe ( ’ ), double quotation marks ( “ ),
comma ( , ), left brace ( { ), and double brackets ( [[ ) or ( ]] ).

Description

Enter a description for the category. You can use all characters except for the left
brace ( { ). To enter descriptions in alternate languages, click the A icon beside the
field. The Alternate Descriptions dialog appears, enabling you to enter descriptions
for other languages enabled in your system.

4. Click OK. The new category appears in the list of categories.

Deleting a category
If a category is no longer used, or obsolete, you can delete it.

To delete a category, follow these steps.

1. Open the Longview Analysis and Reporting dialog, and click the Categories tab. A list of categories
appears.

2. Select the category you want to delete.

3. Press the Delete key. A confirmation dialog appears.
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4. Click Yes. The category is deleted.

Note: Deleting a category does not delete the templates that are assigned to that
category.

Assigning a template to a category
To assign a report template to a category from the Longview Analysis and Reporting dialog, follow these
steps.

Note: A report template must be published before it can be assigned to a category. For more
information on publishing report templates, see Publishing report templates.

1. In the Longview Analysis and Reporting dialog, click the Templates tab. A list of existing report
templates appears.

2. To see all your existing templates, select Any Group in the Templates published to field.

3. Select the template you want to assign to a category. You can select more than one template by
holding down the Ctrl key while making your selections.
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4. Choose File > Assign Categories. The Categories dialog appears.

5. In the Available Categories field, select the categories to which you want to assign the template, and
move them to the Assign to Categories field using the right arrow button. You can select more than
one category at a time by holding down the Ctrl key while making your selections.

6. Click OK. The Longview Analysis and Reporting dialog appears. The categories to which the
template has been assigned appear in the Assigned Categories column.

Publishing and unpublishing report batches
To make a report batch available to other users, you need to publish it.

Publishing a report batch
Once you have created a report batch, you can publish it to the database so that other users can run the
reports contained within it.

Role Can perform this task?

Report Publisher yes

Report Author no

Report User no

Caution: If you publish a report batch that contains errors or omissions, and your user
population starts to use it, logistical issues can result if you have to modify and republish the
report batch at a later time. Before publishing a report batch, be sure to test it thoroughly to
ensure its completeness and accuracy.

The procedure you use differs depending on your starting point.
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From the Longview Analysis and Reporting dialog
To publish a report batch from the Longview Analysis and Reporting dialog, follow these steps.

1. Open the Longview Analysis and Reporting dialog, click the Batches tab. A list of batch files
appears.

Files are listed numerically and alphabetically. If a batch file has been published, the groups to
which it has been published appear in the Published to groups column.

2. To see all your existing batch files, select Any group in the Templates published to field.

3. Select the batch you want to publish. You can select more than one by holding down the Ctrl key
while making your selections.

4. Choose File > Publish, and do one of the following:

l If you selected only one batch file in step 3, or multiple batch files that were originally published
to exactly the same groups, the Publish/Unpublish Batch dialog appears.
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Proceed to step 5.

l If you selected more than one batch file in step 3, and those batches were originally published
to different groups, the Publish Batches dialog appears listing the batches you selected, and
the groups to which they were originally published.

If you are happy with these settings, click OK. The batches are published to the groups listed in
the Published to groups field, and the Longview Analysis and Reporting dialog appears.

Otherwise, click Cancel. The Longview Analysis and Reporting dialog appears. Return to the
beginning of this procedure.

5. In the Do not publish to groups field, select the groups to which you want to publish the batch, and
move them to the Publish to groups field using the right arrow button. You can select more than one
group at a time by holding down the Ctrl key while making your selections.
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Note: The groups that appear in these fields represent all groups to which the Report
Publisher belongs (not necessarily all groups on the application database).

6. Click OK. The batch files you selected are published, and the Longview Analysis and Reporting
dialog appears.

From the Edit Report Batch dialog
You can publish a report batch from the Edit Report Batch dialog. This can come in handy when you
make changes to a report batch that has been published and want to ensure that those changes are
reflected in the published version.

To publish a report batch from the Edit Report Batch dialog, follow these steps.

1. Create or open a report batch that you want to publish and make any necessary changes. Make
sure you save the report batch. For more information see Creating a report batch.

2. In the Edit Report Batch dialog, choose File > Publish. The Publish/Unpublish Batch dialog appears.

3. In the Do not publish to groups field, select the groups to which you want to publish the batch, and
move them to the Publish to groups field using the right arrow button. You can select more than one
group at a time by holding down the Ctrl key while making your selections.
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Note: The groups that appear in these fields represent all groups to which the Report
Publisher belongs (not necessarily all groups on the application database).

4. Click OK. The batch is published, and the Edit Report Batch dialog appears.

Unpublishing a report batch
You may be able to unpublish a report batch if you need to make a newer version available, or to delete
it altogether.

Role Can perform this task?

Report Publisher yes

Report Author no

Report User no

To unpublish a report batch, follow these steps.

1. Open the Longview Analysis and Reporting dialog, and click the Batches tab.

2. For Templates published to select the group to which you published the batch file that you now want
to unpublish. A list of batch files published to that group appears. For a list of all batch files, select
Any group.

3. Select the batch file you want to unpublish. You can select more than one by holding down the Ctrl
key while making your selections.

4. Choose File > Unpublish, and do one of the following:

l If you selected only one batch file in step 3, or multiple batch files that were originally published
to exactly the same groups, the Unpublish Batch dialog appears.
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Proceed to step 5.

l If you selected more than one batch file in step 3, and those batch files were originally
published to different groups, the Unpublish Batches dialog appears listing the templates you
selected, and the groups to which they were originally published.

If you are happy with these settings, click OK. The batch files are unpublished from the groups
listed in the Published to groups field, and the Longview Analysis and Reporting dialog
appears.

Otherwise, click Cancel. The Longview Analysis and Reporting dialog appears. Return to the
beginning of this procedure.

5. In the Publish to groups field, select the groups from which you want to remove access to the batch
file, and move them to the Do not publish to groups field using the left arrow button. You can select
more than one group at a time by holding down the Ctrl key while making your selections.
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Note: The groups that appear in these fields represent all groups to which the Report
Publisher belongs (not necessarily all groups on the application database).

6. Click OK. The Longview Analysis and Reporting dialog appears.
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Working With Charts
Using the available chart formats, you can find many different ways in which to view data in a graphical
format.

Chart formats
You can view data in several types of chart formats.

Bar chart
A bar chart is a chart in which vertical bars along the horizontal axis represent the value of each symbol
in the down dimension, for each symbol in the across direction.

If you want, you can reverse the orientation of the axes. For more information, see step 8.

Stacking bar chart
A stacking bar chart is a chart in which each bar represents the total “stacked” value of the symbols in
the down dimension (as listed in the legend) for each symbol in the across direction. Each symbol is
shown in proportion to its share of the total value.
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If you want, you can reverse the orientation of the axes. For more information, see step 8.

Line chart
A line chart is a chart in which the value for each symbol in the down direction is plotted for each symbol
in the across direction. The points for each symbol are then connected with a line to show a trend.

If you want, you can reverse the orientation of the axes. For more information, see step 8.

Area chart
An area chart is similar to a line chart in that each point, representing the value of each symbol in the
down dimension, connects to the others with a line. In an area chart, however, the area below the line
is filled to give the value greater visibility. The horizontal axis is the range of symbols in the across
direction. Symbol values are placed one on top of the other, each symbol’s value starting at 0 on the
horizontal axis.
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If you want, you can reverse the orientation of the axes. For more information, see step 8.

Pie chart
A pie chart is a chart in which each symbol in the down dimension appears as a sector of a circle, in
proportion to its share of the total parent value (the total value of the pie). When you view data in pie
chart format, you see one pie for each symbol in the across direction.

Stacking area chart
A stacking area chart is similar to a pie chart in that the values of the symbols in the down dimension
are shown in proportion to their share of the total value of the symbols as a whole. In a stacking chart,
however, the values are stacked on top of each other. The horizontal axis is the range of symbols in the
across direction.
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If you want, you can reverse the orientation of the axes. For more information, see step 8.

Viewing data in alternate formats
The default format for viewing data is report format. Depending on your responsibilities, you may be able
to switch back and forth between report and chart format.

Switching to chart format
Depending on your role and the properties of the template, you may be able to view data in chart format.

To view data in chart format, follow these steps.

1. Specify the orientation and symbols as required.

Note: Make sure only one dimension appears in each of the down and across directions.
Otherwise, the chart does not run.
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2. In the toolbar, choose View > Chart. The data appears in chart format.

3. To switch back to report format, choose View > Normal.

4. To zoom in on a specific area of the chart, left click on the area. To zoom out again, right-click
anywhere in the chart.

5. When the data appears in chart format, choose Format > Chart Preferences. The Chart Preferences
dialog appears, with the General tab in view.

6. Complete these fields:

Field Description

Title Type a title for the chart.
Footer Type the text for the footer of the chart.
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7. Select a chart type:

Field Description

Line To view the chart in line format. For more information, see Line chart.
Pie To view the chart in pie format. For more information, see Pie chart.
Bar To view the chart in bar format. For more information, see Bar chart.

Stacking Bar To view the chart in stacking bar format. For more information, see Stacking bar
chart.

Area To view the chart in area format. For more information, see Area chart.
Stacking
Area

To view the chart in stacking area format. For more information, see Stacking area
chart.

8. Complete these fields:

Field Description

Hide
expanded
parents

To hide the parent symbol in an expanded hierarchy.

Horizontal
orientation To display the chart horizontally.

Grid lines To include grid lines in the chart.

Flip axes To switch the position of the axes in the chart. For example, if the chart shows
ACCOUNTS down and TIMEPER across, select this field to switch them.

3D look To display the chart in three-dimensional format.

9. Click the Colors tab.
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10. Complete these fields:

Field Description

Title Select a color for the title.
Footer Select a color for the footer.
Grid lines Select a color for the grid lines.
Background Select a color for the background.
Labels Select a color for the chart’s labels.

11. For the Data Series section, you can select a color for each symbol in the down dimension of the
chart. To make the color for a symbol transparent, so that you can see the symbols behind it, select
Transparency.

12. Click Apply to see changes before exiting this dialog.

13. When you are finished, click OK. The data appears in chart format.

14. To save the chart as a graphic file, select File > Save Chart As. The Save dialog appears.

15. Complete these fields:

Field Description

Save in Select the folder in which you want to save the chart.
File name Type a name for the file.
Save as type PNG file (*.png) is automatically selected.

16. Click Save. The data appears in chart format.
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Switching to report format
If you were able to make data appear in chart format, you can switch it back to report format. To switch
back to report format, choose View > Normal.
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Working With Reports
You can use reports to view, print, and interact with the data in your system.

Understanding reporting roles
The following table outlines the three standard reporting roles:

Reporting

role
Tasks

Report User Uses the reports created by the Report Publisher to analyze data and run reports.

Report

Author
Creates and formats own reports for analysis.

Report

Publisher

Sets the general content, criteria, and format of the report templates that Report Users

use to analyze data and run reports.

Depending on your assigned reporting role and access, you may be able to perform different tasks when
working with reports. The following table outlines the tasks you can perform:

Task Report User Report Author Report Publisher

Reorienting

dimensions

Report Users can reorient any

dimension that is not frozen.

Report Authors can

reorient all dimensions.

Report Publishers can

reorient all dimensions.

Selecting

symbols in

frozen

dimensions

Report Users cannot select symbols for

frozen dimensions.

Report Authors can

select symbols for

frozen dimensions.

Report Publishers can

select symbols for

frozen dimensions.

Navigating

hierarchies

If the report is configured with Drillable

dimensions, Report Users can drill into

the symbol hierarchies in dimensions in

the selected report

Report Authors can

drill into all hierarchies.

Report Publishers can

drill into all hierarchies.

Viewing

available

symbols

If the report is configured with
Restricted symbols, Report Users can
view symbols only under the specified
hierarchies.

If the report is not configured with
Restricted symbols, Report Users can
view symbols to which they have
access.

Report Authors can

view all symbols to

which they have

access in the

dimension.

Report Publishers can

view all symbols to

which they have access

in the dimension.
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Understanding reports and their features
Reports contain many navigational elements that make it easy for you to view, print, and interact with
data.

The main page of a report displays the report body. From there, you can navigate to the Print Preview
page, the Symbols page, the Longview Report Viewer Help, or you can export the report to Microsoft
Excel.

Some of the interface elements you may see in reports include:

Headers and footers Depending on the way the report was configured, headers and footers may
appear at the top and bottom of the report, respectively. Report Publishers can include supplemental
information about the report in the header and footer. Headers and footers can appear anywhere along
the top and bottom of the report.

Title Depending on the way the report was configured; reports may contain a title. Reports can have left,
center, or right titles. Titles appear above the data.

Toolbar Reports include a toolbar. Depending on the page you are on, the buttons that appear on the
toolbar vary.
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Button Description

Refresh Click the Refresh button to update all information in the current view.

Print Preview Click the Print Preview button to go to the print preview page.

Export to Excel Click the Export to Excel button to export the report to Microsoft Excel.

Symbols Click the Symbols button to go to the Symbols page.

Options Click the Options button to toggle Conditional Displays.

Help Click the Help button to open Help related to reports.

Report body The report body is the main area of the report containing the data. Depending on the way
the report was configured, you may see highlighting or shading.

Information pane The information pane appears at the bottom of the report on the main page. When
you first open a report, the information pane is collapsed. The information pane contains the Comments
tab, the Attachments tab, and, depending on the way the report was configured, the Fixed Symbols tab.
You can expand the pane to view Comments, Attachments, and Fixed Symbols on each respective tab.

Status bar The status bar appears along the bottom of the report and the contains the Zoom Out, Zoom
In, and Zoom to Default magnification options.

Understanding report status
If your System Administrator has configured Data Area Monitoring, reports display status in a status bar.
The status bar appears at the top of the report and contains information regarding the status of the
report. Use the following table to review possible status messages:

Message Description

A
submission
failed

An event
failed

A submission or event failed in the system. The failed item may impact the data in the
report.

You can review the failed item using the User Submissions tool or the Events tool.

A
submission
is in
progress

An event is
in progress

A
submission
and an
event are in
progress

A submission, an event, or both are in progress in the system. The in-progress item may
impact the data in the report.

You can click Refresh to update the status of the report or review the in-progress item
using the User Submissions tool or the Events tool.
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Message Description

(no

message)

You may not see a status message because your System Administrator may not have
configured Data Area Monitoring. The Data Area Monitoring, Data Area Monitoring
Dimensions, and Data Area Status Dimension configuration parameters must be set in
Longview Server Manager. For more information, see the Longview Server Manager
Guide.

You can proceed to analyze data or print the report.

Viewing version information
It may be useful at times to view version information about your Longview system. You can verify the
version information for Report Viewer from reports launched from your Longview Dashboard.

To view version information:

1. From a report opened with Report Viewer, press Ctrl + F1. The About Longview dialog opens.

2. Review version information for the following:

l Longview Report Viewer

l Web Bridge

l Data Server

Note: To copy version information to your Windows clipboard, click Copy info to clipboard.

3. When you are finished, click OK to close the About Longview dialog.

Opening reports
You can open reports from the following locations, depending on the setup of your system and the
products you have purchased:

n Longview Dashboard — Reports to which you have access are available from your Dashboard.
You may see reports in the preconfigured Report Templates panel, or you may see reports in a
panel customized by your administrator.

n Longview Client — Reports to which you have access are available from the Reports category
of the Tax Provision navigation pane.

To open a report from your Longview Dashboard:

1. On your Longview Dashboard page, click the link to the report you want to open. Depending on the
way the report was configured, one of the following occurs:

l The report opens in a new window. You can analyze the data and print the report.

l The Symbol Selection page appears, showing the dimensions for which, you must select
symbols. Proceed to step 2.
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2. For each dimension that appears, type a symbol name, or select a symbol. To add more than one
symbol for a dimension, select a row containing the dimension for which you want to add another
symbol and click Symbol.

Note: You can select only one symbol for fixed dimensions. If the Symbol button is
unavailable, the dimension is fixed. Depending on your role access, you may be able to
modify dimension orientation. For more information, see Modifying dimension orientation.

3. When you are done selecting symbols, click View Report. The report opens.

To open a report from Longview Client:

1. In the Longview Client navigation pane, click the category (Reports or Administration) containing
the report you want to open.

2. Expand the section containing the report and click the report. Depending on the way the report was
configured, one of the following occurs:

l The report opens in the workspace. You can analyze the data and print the report.

l The Symbol Selection page appears in the workspace, showing the dimensions for which, you
must select symbols. Proceed to step 3.

3. For each dimension that appears, type a symbol name, or select a symbol.

Note: If you are opening multiple reports using the same entity selection, you can specify
the relevant entity for each category in the navigation pane.

4. When you are done selecting symbols, click View Report. The report opens.

Modifying symbol options
Depending on your access and the properties of the report, you may be able to modify symbol
selections, add symbols, remove symbols, reorder symbols, display symbol names or descriptions, and
modify the dimension orientation of the report.

For information on the actions you can perform based on your role, see Understanding reporting roles.

Modifying symbol selections
Depending on your access and the properties of the report, you may be able to change the symbols in
the report. For more information on the actions you can perform based on your role, see Understanding
reporting roles.

To modify a symbol selection:

1. Open the report using the appropriate method. For more information, see Opening reports.

2. Click Symbols. The Symbols page displays.

3. In the Symbol Selection section for each symbol selection, you want to modify, type an alternate
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symbol name, or select an alternate symbol.

4. When you are finished, click View Report.

Adding symbols
Depending on your access and the properties of the report, you may be able to add symbols to the
report. You can add symbols for the dimensions in the across and down orientation only. If you want to
include more than one symbol in a fixed dimension, you must first reorient the dimension into the across
or down orientation. For more information, see Modifying dimension orientation.

To add a symbol:

1. Open the report using the appropriate method. For more information, see Opening reports.

2. Click Symbols. The Symbols page displays.

3. In the Symbol Selection section, select the row below which you want to add the new symbol.

4. Click Symbol. The new row appears.

5. Type the name of a symbol or use the symbol selector to select a symbol.

6. When you are finished, click View Report.

Removing symbols
Depending on your access and the properties of the report, you may be able to remove symbols. You
can remove symbols for the dimensions in the across and down orientation only, which can contain
multiple symbols. Fixed dimensions must have only one symbol.

To remove a symbol:

1. Open the report using the appropriate method. For more information, see Opening reports.

2. Click Symbols. The Symbols page displays.

3. In the Symbol Selection section, select the row containing the symbol you want to delete.

4. Click Delete. The symbol is removed.

5. When you are finished, click View Report.

Reordering symbols
Depending on your access and the properties of the report, you may be able to reorder symbols. You
can reorder symbols in the down and across orientation only. Fixed dimensions can have only one
symbol.

To reorder a symbol:

1. Open the report using the appropriate method. For more information, see Opening reports.

2. Click Symbols. The Symbols page displays.

3. In the Symbol Selection section, select the row containing the symbol you want to reorder.
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4. Click Move Up or Move Down.

5. When you are finished, click View Report.

Displaying symbol names and descriptions
Depending on the way the report was configured, you may see symbol names, symbol descriptions, or
both symbol names and symbol descriptions displayed for each dimension when you open the report.
Depending on your role, you may be able to modify these options. Active dimensions must display at
least one of either the symbol name or symbol description. Both the symbol name and symbol
description can be cleared for fixed symbols, but this removes the dimension from the list of fixed
symbols if fixed symbols display for the report.

Note: Symbol name and description display options also apply to printed pages and exported
reports.

To display symbol names and descriptions:

1. Open the report using the appropriate method. For more information, see Opening reports.

2. Click Symbols. The Symbols page appears.

3. In the Symbol Selection section for each dimension, select whether to display symbol Names,
Descriptions, or both. To display symbol Names or Descriptions for all active dimensions, use the
appropriate Select All check box.

Note: If the report Publisher has configured the report to not display fixed symbols, you
cannot change the display options for fixed dimensions.

4. Click View Report. The report appears with the specified display options.

Modifying dimension orientation
Depending on your access and the properties of the report, you may be able to modify the dimension
orientation of the report. For information on the actions you can perform based on your role, see
Understanding reporting roles. Dimensions are listed on the Symbols page in the order defined by the
Report Publisher.

Use the following table to determine the way dimensions display in the report.
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Dimension

orientation
Report appearance

Across or

Down

The left-most dimension listed on the Symbols page is the outermost dimension in the

report.

Fixed

If the report Publisher configured the report to display fixed symbols, the report opens
displaying fixed symbols in dimension order on the Fixed Symbols tab of the information
pane.

If you modify the dimension orientation of fixed symbols, the right-most dimension appears
at the top of the list of fixed dimensions on the Fixed Symbols tab of the information pane,
followed by the other dimensions in the order listed on the Symbols page.

To modify dimension orientation:

1. Open the report using the appropriate method. For more information, see Opening reports.

2. Click Symbols. The Symbols page appears.

3. In the Orientation section for the dimension you want to reorient, select the dimension.

4. Drag and drop the selected dimension into the desired position.

5. When you are finished, click View Report.

Viewing fixed symbols
Depending on the way the report was configured, you may be able to view fixed symbols. Fixed symbols
appear on printed pages if they are displayed on the Fixed Symbols tab of the information pane. For
information on the way fixed symbols display on printed pages, see Understanding printed pages.

Note: The Report Publisher may have configured the report to not display fixed symbols. If
this is the case, the Fixed Symbols tab does not display.

To view fixed symbols:

1. Open the report using the appropriate method. For more information, see Opening reports.

2. In the information pane, click Fixed Symbols. The Fixed Symbols display.

3. Review the symbols for each fixed dimension.

Note: Depending on your role and access, you may be able to make a dimension active. For
more information, see Modifying dimension orientation.

Navigating reports
If the report is configured with Drillable dimensions, you may be able to modify the level of symbol detail
to display in a report.
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Navigating hierarchies
Depending on the symbols selected and the dimension orientation of the report, you may be able to
quickly collapse or expand a hierarchy with one click or you may be able to collapse or expand
hierarchies to specified levels of detail by right-clicking.

Use the following table to determine the level to which you want to expand or collapse a specified
hierarchy using the right-click menu.

Right-click

menu option
Behavior

Collapse All All hierarchies in the selected dimension collapse.

Collapse

Parent
The selected parent collapses.

Expand All for

Selected

Symbol

The hierarchy expands to display all symbols within the selected parent symbol but for

only the selected occurrence of the selected parent symbol. Other occurrences of the

parent symbol do not expand.

Expand One

Level for All

Occurrences

The hierarchy expands to display only the first level of symbols under the selected

parent symbol for all occurrences of the selected parent symbol.

Expand One -

Match Inner

Detail

This option applies to reports which include multiple dimensions in the across or down
orientation. This option is available for outer dimension symbols only.

The outer dimension hierarchy expands one level and for each outer dimension child
symbol, the inner dimension expands to match the inner dimension expansion of the
parent symbol.

Expand All -

Match Inner

Detail 

This option applies to reports which include multiple dimensions in the across or down
orientation. This option is available for outer dimension symbols only.

The outer dimension hierarchy expands to display all symbols and for each outer child
symbol, the inner dimension expands to match the inner dimension expansion of the
parent symbol.

Expand All for

All

The hierarchy expands to display all symbols in all the dimensions in a selected

orientation (across or down).

Note: Use this option with caution. Depending on the size of the report and
the number of symbols, the Expand All for All option may adversely affect
the performance of your system.

To navigate a hierarchy:
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1. Open the report using the appropriate method. For more information, see Opening reports.

2. Do one of the following:

l To determine whether a symbol can be quickly expanded or collapsed, move the mouse over a
symbol. If the symbol can be expanded or collapsed, a hand appears, and a tooltip displays
that reads “Click to Expand” or “Click to Collapse.” Proceed to step 3.

l To display a specific level of detail, right-click the symbol for which to expand or collapse the
hierarchy. The relevant menu options appear. Proceed to step 4.

3. Click the symbol. The symbol expands or collapses one level as indicated.

4. Select the relevant navigation option. The report hierarchy expands or collapses appropriately.

Changing magnification
You can change the magnification of a report to suit your preference for your screen. Modifying the
magnification of a report applies to the current session view only and not the way the report is printed or
exported.

Zooming in and zooming out
You can modify the magnification of a report from 10% to 200%.

To zoom in or zoom out:

1. Open the report using the appropriate method. For more information, see Opening reports.

2. Depending on the way you want to modify the magnification, do one of the following:

l To increase the magnification of the report, click Zoom In on the status bar. The report
magnification increases by 1%. Alternatively, you can drag the slider to the desired
magnification level.

l To decrease the magnification of the report, click Zoom Out on the status bar. The report
magnification decreases by 1%. Alternatively, you can drag the slider to the desired
magnification level.

Note: For information on a multi-page view of the report, see Working with printing.

Restoring magnification defaults
If you have modified the magnification of a report, you can restore the report to the default view of 100%.

To reset the magnification of the report to default, click Restore to default zoom level on the status bar.
The report magnification returns to 100%.

Enabling and disabling conditional displays
Depending on the way the report was configured, the data may have highlighting, filters, and symbol
suppression visible when you open the report. You can enable or disable these conditions.
Preconfigured Tax Provision reports may open with suppressed symbols containing only zero values.
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Note: Conditional display applies to the way data appears on printed pages. Filters and
symbol suppression apply to the way a report appears in Microsoft Excel.

To enable or disable conditional display:

1. Open the report using the appropriate method. For more information, see Opening reports.

2. Click Options. The Options menu appears.

3. Depending on the initial view of the report, select, or clear Apply Conditional Display to enable or
disable highlighting, filters, and symbol suppression.

Note: If the report Publisher has not applied any conditional displays to the report, Apply
Conditional Display is unavailable.

Viewing additional information through links
The report Publisher may have included additional information about the report. You may be able to
view this additional information through a web link, or to an external document such as a PDF file.
Reports can contain the following types of links:

Link type Description and access

Cell-level

Cell-level links resolve to an external URL to provide information relevant to a particular
cell.

You can access cell-level links by right-clicking any cell in the report except calculated cells
or blank cells.

Report-

level

Report-level links resolve to an external URL providing information relevant to the report as
a whole.

You can access report-level links by right-clicking anywhere in the report.

To view additional information:

1. Open the report using the appropriate method. For more information, see Opening reports.

2. Do one of the following:

l To view cell-level links, right-click the cell in which you want to view additional information. A
menu opens, displaying any relevant cell links.

l To view report-level links, right-click anywhere in the report. A menu opens, displaying any
relevant report links.

3. Select the link for which you want to view additional information. The related URL or document
opens.

Reviewing Audit Trail
Depending on the configuration of the report you may have access to review audit trail. Audit trail is
accessed using a link.
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For further information on links, see Viewing additional information through links.

To access audit trail:

1. Right-click in the report.

2. Select Audit

3. Audit Trail appears:

l As a tab, if report is opened in Longview Client.

l As a new window if report is opened in Report Viewer.

4. All related audit transactions are displayed in the table.

l Including changes made on leaf symbols if the report or intersection contains parent symbols.

Note: If the intersection selected only contains calculated data, such as in a translated
currency, not audit data will be available as data changes are only tracked for
submissions.

For more information, see “Reviewing Data Audit” in the Solutions User Guide.

Refreshing report data
You can update the contents of the report you are working with to make sure you are viewing the most
recent data and report status.

Note: Comments and attachments refresh only when the information pane is expanded and
the Comments tab or Attachments tab is in focus.

1. To refresh the contents of a report with data from the database, click Refresh.

Note: You can also press F5 on the keyboard to refresh the report.

Working with comments and attachments
Comments explain entries in reports. Attachments contain supplementary information about reports. If
the intersection for a comment or attachment is visible in the report body, the comment or attachment
appears in the information pane. From the information pane, you can view comments and attachments,
and open and save attachments.

For information on the way comments and attachments print, see Understanding printed pages.

Understanding the information pane
The information pane displays the Comments, Attachments, and Fixed Symbols tabs. You may not see
the Fixed Symbols tab based on the way the Report Publisher has set up the report.
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Note: Comments and attachments are not supported for Schedule reports. If you are working
with a Schedule report, the Comments tab and Attachments tab do not display in the
information pane.

For comments and attachments, the information pane displays the following information for each
comment or attachment:

n the data intersection for the comment or attachment listed by dimension

n the user who submitted the comment or attachment

n the date and time of the submission

n the comment text or attachment link

Reviewing comments or attachments
You can review the list of comments or attachments based on the expansion state of symbols in the
report.

To review comments or attachments:

1. Open the report using the appropriate method. For more information, see Opening reports.

2. Click the Comments tab or Attachments tab. The information pane expands, displaying the list of
comments or attachments in view in the report.

3. To find all comments or attachments associated with the report, modify the expansion state of the
symbols in view in the report. For more information, see Navigating reports.

Opening and saving attachments
From the information pane, you can open and save attachments.

To open and save an attachment:

1. Open the report using the appropriate method. For more information, see Opening reports.

2. In the information pane, click the Attachments tab. The information pane expands, displaying all
attachments visible in the report.

3. In the Attachment column, click the link for the attachment you want to open.

4. Do one of the following:

l To open the attachment, click Open. The attachment opens.

Note: You must have the appropriate program installed on your local machine to
open attachments. If you do not have an appropriate program installed, you are
prompted to either locate a program or save the file.

l To save the attachment, click Save. The Save As dialog opens. Browse to the location to which
to save the file and click Save. The file is saved to the specified location.
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Reviewing underlying comments
Depending on the configuration of the report you may have access to review underlying comments.
Underlying comments are accessed using links. For further information on links, see Viewing additional
information through links.

Note: All out of box reports are configured with the ability to access underlying comments.

To review underlying comments:

1. Right-click in the report.

Note: If you right-click on a data value, you will have the option of choosing underlying
comments for the intersection or report. If you-right-click elsewhere you will have only the
option of underlying comments for the report.

2. Select the appropriate Underlying Comments option.

3. Show Comments appears:

l As a tab, if report is opened in Longview Client.

l As a new window if report is opened in Report Viewer.

4. All related underlying comments are displayed in the table.

l Including comments made on leaf symbols if the report or intersection contains parent
symbols.

l Including comments made in source currencies if the report or intersection contains a reporting
currency.

For more information, see “Reviewing Comments” in the Solutions User Guide.

Working with reports in Microsoft Excel
You can export reports to Microsoft Excel.

Exporting reports to Microsoft Excel
You can export reports to Microsoft Excel. To review the way a report exports to Microsoft Excel, see
Understanding reports in Microsoft Excel. Before you export a report, make sure the report displays the
way you want it to, including the following items:

n Symbol names and descriptions. For more information, see Displaying symbol names and
descriptions.

n Filters and symbol suppression. For more information, see Enabling and disabling conditional
displays.

n Expansion state of symbols. For more information, see Navigating hierarchies.
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To export a report:

1. Open the report using the appropriate method. For more information, see Opening reports.

2. Click Export to Excel. The Export to Excel dialog appears.

3. Select one of the following:

Field Description

As
displayed

To display data in the Excel worksheet using the orientation as displayed in the report.

To understand the way a report appears in Report Viewer and in Microsoft Excel in As
displayed format, proceed to Understanding reports in Microsoft Excel.

In table
format 

To display data in a table format. This format is better suited if you plan to use the data
to create PivotTable reports in Excel.

The data is exported with symbol names in columns (one column per dimension),
followed by a column containing the values. The following formatting is carried over to
the export:

n Symbols names/descriptions (as selected in the report)

n Conditional displays

n Number formatting

n Scaling

4. Click Export. The Save As dialog opens.

5. Navigate to the location where you want the file to be saved.

6. Type a name for the file.

Note: The default name for the file is reportname.xlsx.

7. Click Save. The file opens in Microsoft Excel.

8. To review the differences between the way a report appears in Report Viewer and in Microsoft Excel
in As displayed format, proceed to Understanding reports in Microsoft Excel.

Understanding reports in Microsoft Excel
Reports exported in As displayed format to Microsoft Excel will have slight formatting differences. Use
the following table to review the way report features export in “As displayed” format.
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Feature In the report... In Microsoft Excel...

Report name
The report name displays in the

title bar.

The report name displays as the worksheet name. If

the report name is longer than 31 characters, the first

31 characters display and the remaining characters

truncate.

Titles

The Report Publisher may have

configured the report to contain

a title in any or all of the left,

center, and right positions.

Left, center, and right titles display in cells A1, B1, and
C1, respectively.

Formatting for titles is not carried through to the
exported report.

Note: Column width is dictated by row
headers, column headers, and data, not title
length.

Headers and

Footers

The Report Publisher may have

configured the report to contain

headers and footers in any or all

of the left, center, and right

positions.

Up to 255 characters are displayed for the sum of left,
center, and right header and footer text.
Formatting for headers and footers is not carried
through to excel.

Note: Headers and footers are visible only in
Print Preview and Page Layout View in the
exported report.

Symbol

names

and/or

descriptions

for active

dimension

Depending on the selections on

the Symbols page, you may see

symbol names, symbol

descriptions, or both symbol

names and descriptions

displayed for active dimensions.

Symbol name and symbol description selections are

carried through to exported reports. If the report

displays both a symbol’s name and description for an

active dimension at the time of export, the symbol

name and symbol description are exported to the

same cell and separated by a dash.

Fixed

Symbols

If the Report Publisher has
configured the report to display
Fixed Symbols, Fixed Symbols
display on the Fixed Symbols
tab in the information pane.

If the Report Publisher has
configured the report to hide
Fixed Symbols, the Fixed
Symbols tab does not display in
the report.

If the Report Publisher has configured the report to
display Fixed Symbols, Fixed Symbols display in
collapsed rows according to the following
specifications:

Position: Fixed Symbols may display either above the
data or below the data.

Columns: dimensions display in column A, symbol
names display in column B, and symbol descriptions
display in column C. If only symbol names or only
symbol descriptions are visible in the report, they
appear in column B.
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Feature In the report... In Microsoft Excel...

Conditional

Display

If the Report Publisher has

included any highlighting, filters,

or symbol suppression, these

display in the report when Apply

Conditional Display is selected.

If the Report Publisher has included filters or symbol
suppression, these are carried through to the exported
report when Apply Conditional Display is selected at
the time of export.

Note: Highlighting is not carried through to
the exported report.

Number

formatting

The Report Publisher may have

configured the report to included

number formatting.

Number formatting is carried through to the exported

report.

Font styles

and sizes

The Report Publisher may have

configured the report to display

various font styles and sizes.

Variations in font styles and sizes do not display in the

exported report.

Scaling 

Report data may be scaled. The

Report Publisher may have

configured the report to include

a scaling indicator in the report

title or it may display either

above or below the data.

Scaling is carried through to the data, but the scaling

indicator does not display in the exported report. True

values for data display in the formula bar.

Row

indentation

The Report Publisher may have

indented leaf or parent rows in

the report.

Indentation is carried through to exported reports.

Comments

If the report contains any

comments visible based on the

expansion state of symbols, they

display in a list in the information

pane.

Comments do not display in the exported report.

Attachments

If the report contains any

attachments visible based on

the expansion state of symbols,

they display in a list in the

information pane.

Attachments do not display in the exported report.
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Working with printing
You can specify the way you want a report to appear on printed pages. While you are specifying print
options, at any time you can click Print using system dialog in the settings pane to specify print settings
using your operating system’s standard print dialog.

You can also navigate through multi-page reports on the print preview page and modify the
magnification of the print preview page to see the way the reports will print. Use the following table to
review possible view options on the print preview page.

Status bar option Use to...

Previous page

navigate to the previous page of the report.

This option applies only to reports printed on

more than one page. Alternatively, you can

type a page number to navigate directly to a

specific page.

Next page

navigate to the next page of the report. This

option applies only to reports printed on

more than one page. Alternatively, you can

type a page number to navigate directly to a

specific page.

Zoom Out

decrease the magnification of the print

preview by 1%. Alternatively, you can drag

the slider to the desired zoom level.

Zoom In

increase the magnification of the print

preview by 1%. alternatively, you can drag

the slider to the desired zoom level.

Zoom to Page
reset the magnification of the report to

display one full page.

Note: Modifying the magnification of the print preview applies to the current view only and not
the way the report is printed.

Understanding printed pages
Reports display with some slight differences between the screen and the printed page. These
differences are designed to maximize your experience while viewing reports either on screen or on
printed pages. Use the following table to understand the differences in features you may see when
comparing a report on screen and a report’s printed pages.
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Feature On the screen On the printed page

Title,

Header, and

Footer text

Text for titles, headers, and footers

wraps on the screen if left, center, or right

text overlaps, allowing you to review all

the text the Report Publisher has

included.

Text for titles, headers, and footers wraps if

left, center, or right text overlaps to

accommodate the selected paper size.

Fixed

Symbols

If the Report Publisher has configured
the report to display Fixed Symbols,
Fixed Symbols display only on the Fixed
Symbols tab in the information pane.

If the Report Publisher has configured
the report to hide Fixed Symbols, the
Fixed Symbols tab does not display in
the report.

If the Report Publisher has configured the
report to display Fixed Symbols, Fixed
Symbols display according to the following
specifications:

Position: Fixed Symbols may display either
above data or below data.

Frequency: Fixed Symbols may display on all
pages, or on one page only - either the first
page if the specified position is above the data
or the last page if the specified position is
below the data.

Note: If the Report Publisher has
configured the report to hide Fixed
Symbols, Fixed Symbols do not
appear on printed pages.

Conditional

Display

If the Report Publisher has included any

highlighting, filters, or symbol

suppression, these display on the screen

when Apply Conditional Display is

selected in the report view.

If the Report Publisher has included any
highlighting, filters, or symbol suppression,
these carry through to printed pages when
Apply Conditional Display is selected in the
report view.

Note: When printing in black and
white, highlighting and shading
appear similar.

Comments

If the report contains any comments

visible based on the expansion state of

symbols, they appear in a list in the

information pane.

If the report contains any comments visible

based on the expansion state of symbols, they

print as a list on separate pages at the end of

the report.
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Feature On the screen On the printed page

Attachments

If the report contains any attachments

visible based on the expansion state of

symbols, they appear in a list in the

information pane.

If the report contains any attachments visible

based on the expansion state of symbols, they

print as a list on separate pages at the end of

the report, after the list of comments.

Preparing reports for printing
Before you print a report, it is important to make sure the report displays the way you want it to. You may
want to navigate through a hierarchy, change display options for symbol names or descriptions, or
modify conditional display options.

To prepare a report for printing:

1. Open the report using the appropriate method. For more information, see Opening reports.

2. Confirm that the report displays the following features the way you want it to for printing:

Feature To make changes...

Dimension orientation follow the steps in Modifying symbol selections.
Expansion state of hierarchies follow the steps in Navigating hierarchies.
Displaying symbol names and/ or
descriptions

follow the steps in Displaying symbol names and
descriptions.

Conditional displays follow the steps in Enabling and disabling conditional
displays.

Printing reports
Reports print based on the current view, including the way symbols are expanded or collapsed and
whether conditional display is applied or not applied.

To print a report:

1. Follow the steps in Preparing reports for printing.

2. Click Print Preview. The print preview page displays.

Note: At any time, you can review and select print settings using your computer’s print
options by clicking Print using system dialog.

3. In the Copies field, specify a number between 1 and 32767 for the number of copies to print.
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4. Select the appropriate printer from which you want to print the report.

5. Complete the following fields:

Field Description

Print All
Pages

n Select Print All Pages to print all pages displayed in the report.

n Select Print Custom Range to specify a range of pages to print.

Pages

If you selected Print Custom Range, specify the page range to print.

Note: If there are Comments and Attachments in the report, they print on
separate Comments and Attachments pages after the report content. If you
want to exclude Comments and Attachments from printed pages, specify
the last page displaying report content only.

Print One
Sided

n Select Print One Sided to print the report on only one side of paper.

n Select Print on Both Sides, Flip on Long Edge to print the report on both
sides of the paper, flipping the paper on the long edge.

n Select Print on Both Sides, Flip on Short Edge to print the report on both
sides of the paper, flipping the paper on the short edge.

Collated

n Select Collated to print the report in sequence in its entirety before printing
another copy.

n Select Uncollated to print all copies of the first page of the report before
printing all copies of the next page, and so on.

Portrait
Orientation

n Select Portrait Orientation to print the report so that the page is taller than it
is wide.

n Select Landscape Orientation to print the report so that the page is wider
than it is tall.

(paper size) Depending on your printer and location, various page sizes are available. Select the
paper type on which you want to print the report.

Across,
Then Down

n Select Across, Then Down to print multiple pages from top to bottom.

n Select Down, Then Across to print multiple pages from left to right.
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Field Description

(margins)

n Select Normal Margins to print the report with the Left and Right margins at
0.7 inches and the Top and Bottom margins at 0.75 inches.

n Select Wide Margins to print the report with all four margins at 1 inch.

n Select Narrow Margins to print the report with the Left and Right margins at
0.25 inches and the Top and Bottom margins at 0.75 inches.

n Select Custom Margins to customize the margin size for the printed report.
Specify a number, in inches, for each of the four margins.

No Scaling

n Select No Scaling to print the pages at their actual size. Select Fit Report on
One Page to shrink the printed report to fit on one piece of paper.

n Select Fit All Columns on One Page to shrink the printed report to the width
of one piece of paper.

n Select Fit All Rows on One Page to shrink the printed report to the height of
one piece of paper.

n Select Custom Scaling Options to specify the way you want the report
scaled. Specify one of the following:

n Adjust to - Specify the percentage to which you want the report scaled.

n Fit to (pages) - Specify the number of pages wide and tall to print the report.

6. When you are finished making changes, click anywhere in the preview area to see the updated
settings. The preview updates to display the specified settings.

7. Review the way the report appears for printing.

8. When you have finished specifying print options, click Print. The report prints with the specified
settings.
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Frequently Asked Questions
Have questions about the Analysis and Reporting application? You may be able to find the answers
here.

FAQs on Getting started
This section contains frequently asked questions on getting started in the application.

Can I sign on to the application through the web?
Yes, if your system is configured to do so. If your system is set up to use the web, you need to know the
location of your Longview web pages. Ask your System Administrator for the URL, or for a link to your
Longview web site.

My organization uses Windows authentication, and
I’m having trouble connecting to the application
database. Why?
If your organization uses Windows authentication, and your user ID contains a space somewhere within
the middle of the user ID, the application can process your user ID. However, you cannot have one or
more spaces at the end of your user ID.

Why can’t I connect to the application database?
You may have selected the wrong authentication method.

To correct an authentication problem, make sure you select the correct authentication method
(Windows authentication or Longview authentication).

How do I know if I have access rights to a particular
component?
In order to use an application component, you need to sign on to your Longview web page, or Longview
Component Manager. Look for the icon representing the application component you want to use. If it
does not appear, you do not have access rights to it.

If you need access to a component whose icon does not appear on your screen, see your System
Administrator.

I want to change my connection settings
temporarily, but the Change Settings selection in the
Tools menu is dimmed. What should I do?
You are currently connected to the application database. You can change your connection settings only
when you are working offline.

How do I update my application files?
If you use the application through the web, you do not need to install any files on your computer.
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FAQs on Longview Analysis and Reporting
This section contains frequently asked questions on Longview Analysis and Reporting.

I am the Report Publisher. I want to publish
templates to user groups, but I can’t see those
groups in the Publish dialog. Why?
As the Report Publisher, you must belong to the user groups to which you want to publish templates.
Ask your System Administrator to edit your user ID in Longview Application Administrator, to add those
user groups.

Why does my report view always open the same
size, even though I changed its size in the last
session?
By default, a report view automatically opens in its last saved setting size, as specified in the Options
dialog.

When you manually change the size of an open report view, it reverts back to its last saved setting size
when you close and reopen it.

To change the size of a report view, so that it opens the same size every time, follow these steps.

1. In the DataView window, choose Tools > Options. The Options dialog appears, with the General tab
in view.
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2. For Initial Window Size, select the size in which you want the DataView to appear when you first
open it.

3. Click OK. The DataView appears.

4. Save the DataView.

5. When you reopen the DataView in subsequent sessions, it appears in the size you specified.

Is there a quick way to change the orientation and
symbols in a DataView?
To quickly change the orientation of a DataView, click and drag the dimension buttons in the DataView
to the desired orientation.

Why can’t I see certain symbols in a DataView?
There are two possible reasons for this. Certain symbols in the DataView may be hidden.

To find out which symbols are hidden, follow these steps.

1. In the DataView window, choose Edit > Hidden Symbols. The Hidden Symbol Selection dialog
appears, showing all hidden symbols in the Selected Symbols list.
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2. To make a hidden symbol visible again, select it in the Selected Symbols list, and click Remove.

3. Click OK. The DataView appears, showing the previously hidden symbol.

Or, you could have an active condition in the DataView that suppresses certain data. To see whether
this is the case, do one of the following:

1. Deactivate the conditions in the DataView.

2. Check the Conditional Display dialog to see whether there are any conditions in the DataView that
suppress certain data.

Why can’t I change the data in a DataView?
Longview Analysis and Reporting is a data analysis tool, and as such, you can only view data in a
DataView. You cannot change and submit new data.

Why don’t my DataView conditions show?
You may have deactivated the conditions for the DataView at some point. You must reactivate them.

Why can’t I see floating time period symbols in a
DataView?
You can see floating time period symbols only if your System Administrator has prepared them in
Longview Application Administrator, using the attribute SGPFloatingTimePeriods.

For more information, see your System Administrator.
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I have converted my DataView to an Excel
spreadsheet. Some of the symbols seem to be
missing. Why?
Hidden symbols, suppressed symbols, and the child symbols of collapsed report view symbols, do not
appear in an Excel worksheet. You must make these symbols visible before conversion.

I have converted my DataView to an Excel
spreadsheet, but I can’t change its orientation in
Excel. Why not?
When you converted your DataView, you probably selected the As Displayed option. To be able to
manipulate the data in Excel, you need to select the In PivotTable format option.

https://insightsoftware.com/

	Document Information
	Notices

	Contents
	Getting Started In Longview Analysis and Reporting
	Launching Longview Analysis and Reporting

	Understanding your Longview database
	Dimensions
	Hierarchies
	Symbol information

	Preparing Your System for Longview Analysis and Reporting and Input
	Specifying settings in Longview Application Administrator
	Specifying attributes in Longview Application Administrator

	Working with Longview Analysis and Reporting Files
	Your role in the reporting process
	Your starting point
	Understanding file types and dimensions
	Creating templates and DataViews
	Opening templates and DataViews
	Refreshing templates and DataViews
	Saving templates and DataViews
	Deleting templates and DataViews

	Working with Data Content
	Specifying Default Settings
	Manually
	Automatically

	Specifying Orientation and Symbols In A Template
	Changing Symbol Content In A Template Or View
	Expanding And Collapsing Hierachies
	Working With Conditions
	For an entire view
	For one symbol only

	Adding Calculated Rows And Columns
	Working With Range Calculations
	Editing Symbol Formats
	Editing Cell Formats
	Hiding Symbols
	Adjusting Spacing With Blank Symbols
	Adding Links To A Template
	Parameters
	Tokens
	Specifying the launch mode
	URL syntax
	Link to an App Syntax (for Reports and Apps launched standalone from the Dash...
	Link to an App Syntax (for Reports and Apps launched within the Longview Client)
	Link to a Report Syntax (for reports launched standalone from the Dashboard)
	Link to a Report Syntax (for reports launched within the Longview Client)


	Working With Report Batches
	Creating report batches
	Opening report batches
	Refreshing report batches
	Running report batches
	Deleting report batches

	Designing Reports
	Understanding reports and their features
	Viewing files in report format
	Selecting new symbols for reports
	Navigating reports
	Formatting reports
	Viewing input comments
	Printing reports
	Saving reports

	Publishing Report Templates And Batches
	Publishing report templates
	Assigning report templates to categories
	Publishing and unpublishing report batches

	Working With Charts
	Chart formats
	Viewing data in alternate formats

	Working With Reports
	Understanding reporting roles
	Understanding reports and their features
	Opening reports
	Modifying symbol options
	Navigating reports
	Enabling and disabling conditional displays
	Viewing additional information through links
	Refreshing report data
	Working with comments and attachments
	Working with reports in Microsoft Excel
	Working with printing

	Frequently Asked Questions
	FAQs on Getting started
	FAQs on Longview Analysis and Reporting


